]> git.pld-linux.org Git - packages/gitlab-ce.git/commitdiff
gitlab-workhorse 0.8.2 required
authorElan Ruusamäe <glen@delfi.ee>
Fri, 23 Sep 2016 20:46:42 +0000 (23:46 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Fri, 23 Sep 2016 20:46:42 +0000 (23:46 +0300)
check gitlab-workhorse and gitlab-shell versions at package build time

gitlab-ce.spec

index 8e60c18c8cf89cab2fc1d2e0db937c42e1e60a9d..96fb2aef306521f0d30a83b235569e879fb842ea 100644 (file)
 %bcond_with    krb5            # build with kerberos support
 %bcond_without gem_cache       # use local cache to speedup gem installation
 
+%define        shell_version 3.6.0
+%define        workhorse_version 0.8.2
 Summary:       A Web interface to create projects and repositories, manage access and do code reviews
 Name:          gitlab-ce
 Version:       8.12.0
-Release:       0.74
+Release:       0.75
 License:       MIT
 Group:         Applications/WWW
 # md5 deliberately omitted until this package is useful
@@ -54,8 +56,8 @@ BuildRequires:        zlib-devel
 Requires(post,preun):  /sbin/chkconfig
 Requires:      apache-base
 Requires:      git-core >= 2.7.4
-Requires:      gitlab-shell >= 3.6.0
-Requires:      gitlab-workhorse >= 0.7.11
+Requires:      gitlab-shell >= %{shell_version}
+Requires:      gitlab-workhorse >= %{workhorse_version}
 Requires:      nodejs
 Requires:      rc-scripts
 Requires:      ruby-bundler
@@ -106,6 +108,11 @@ mv config/database.yml.mysql config/database.yml
 find -name .gitkeep | xargs rm
 
 %build
+v=$(cat GITLAB_SHELL_VERSION)
+test "$v" = "%{shell_version}"
+v=$(cat GITLAB_WORKHORSE_VERSION)
+test "$v" = "%{workhorse_version}"
+
 %if %{with gem_cache}
 cachedir="%{_specdir}/cache/%{version}.%{_arch}"
 install -d vendor/bundle
This page took 0.098648 seconds and 4 git commands to generate.