]> git.pld-linux.org Git - packages/gd.git/blob - gd.spec
add upstream revert of api breakage; rel 2
[packages/gd.git] / gd.spec
1 #
2 # Conditional build:
3 %bcond_without  avif            # AVIF support via libavif
4 %bcond_without  fontconfig      # fontconfig support
5 %bcond_without  heif            # HEIF support via libheif
6 %bcond_with     libimagequant   # LIQ quantization method support (breaks transparency in TrueColor->palette conversion)
7 %bcond_without  raqm            # RAQM complex text layout support
8 %bcond_with     sse             # SSE math on ix86
9 %bcond_without  xpm             # XPM support (requires X11 libs)
10 %bcond_without  tests           # "make check"
11 #
12 %ifarch pentium3 pentium4
13 %define with_sse        1
14 %endif
15 Summary:        Library for PNG, JPEG creation
16 Summary(es.UTF-8):      Biblioteca para manipulación de imágenes
17 Summary(pl.UTF-8):      Biblioteka do tworzenia grafiki w formacie PNG, JPEG
18 Summary(pt_BR.UTF-8):   Biblioteca para manipulação de imagens
19 Name:           gd
20 Version:        2.3.3
21 Release:        2
22 License:        BSD-like
23 Group:          Libraries
24 #Source0Download: https://github.com/libgd/libgd/releases
25 Source0:        https://github.com/libgd/libgd/releases/download/%{name}-%{version}/lib%{name}-%{version}.tar.xz
26 # Source0-md5:  7a58b54d375eda236414201252a0ee3c
27 Patch0:         %{name}-fontpath.patch
28 Patch1:         %{name}-loop.patch
29 Patch2:         api-breakage.patch
30 URL:            https://libgd.github.io/
31 BuildRequires:  autoconf >= 2.54
32 BuildRequires:  automake
33 %{?with_fontconfig:BuildRequires:       fontconfig-devel}
34 BuildRequires:  freetype-devel >= 1:2.1.10
35 BuildRequires:  gettext-tools
36 %{?with_avif:BuildRequires:     libavif-devel >= 0.8.2}
37 %{?with_heif:BuildRequires:     libheif-devel >= 1.7.0}
38 %{?with_libimagequant:BuildRequires:    libimagequant-devel}
39 BuildRequires:  libjpeg-devel
40 BuildRequires:  libpng-devel >= 2:1.4.0
41 %{?with_raqm:BuildRequires:     libraqm-devel}
42 BuildRequires:  libtiff-devel >= 4
43 BuildRequires:  libtool >= 2:2
44 BuildRequires:  libwebp-devel
45 BuildRequires:  pkgconfig
46 BuildRequires:  sed >= 4
47 BuildRequires:  tar >= 1:1.22
48 %{?with_xpm:BuildRequires:      xorg-lib-libXpm-devel}
49 BuildRequires:  xz
50 BuildRequires:  zlib-devel
51 Requires:       freetype >= 1:2.1.10
52 %{?with_avif:Requires:  libavif >= 0.8.2}
53 %{?with_heif:Requires:  libheif >= 1.7.0}
54 Provides:       gd(gif) = %{version}-%{release}
55 # versioned by php version rotate_from_php code comes from
56 Provides:       gd(imagerotate) = 5.2.0
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 gd is the image manipulating library. It was created to allow graphs,
61 charts and the like to be generated on the fly for use on the World
62 wide Web, but is useful for any application in which custom images are
63 useful. It is not a paint program; it is a library. gd library creates
64 PNG, JPEG, GIF and WBMP images. PNG is a more compact format, and full
65 compression is available. JPEG works well with photographic images,
66 and is still more compatible with the major Web browsers than even PNG
67 is. WBMP is intended for wireless devices (not regular web browsers).
68
69 %description -l es.UTF-8
70 Esta es la biblioteca gd para el manejo de imágenes. Fue creada para
71 uso en la Web, creando gráficos automáticamente. Pero es útil para
72 cualquier programa que necesite de imágenes personalizados. No es un
73 programa de dibujo; es una biblioteca.
74
75 %description -l pl.UTF-8
76 gd to biblioteka do obróbki obrazów. Została stworzona, aby umożliwić
77 dynamiczne generowanie wykresów i podobnych rzeczy na potrzeby WWW,
78 ale może być przydatna także dla każdej aplikacji tworzącej własne
79 obrazy. Biblioteka ta pozwala na tworzenie plików graficznych w
80 formatach PNG, JPEG, GIF i WBMP. PNG jest zwartym formatem z
81 bezstratną kompresją. JPEG dobrze nadaje się do obrazów
82 fotograficznych i jest obsługiwany nawet przez więcej przeglądarek WWW
83 niż PNG. WBMP jest przeznaczony dla urządzeń bezprzewodowych (a nie
84 zwykłych przeglądarek WWW).
85
86 %description -l pt_BR.UTF-8
87 Esta é a biblioteca gd para manipulação de imagens. Ela foi criada
88 para uso na Web, gerando gráficos automaticamente. Mas é útil para
89 qualquer programa que precise de imagens personalizados. Não é um
90 programa de desenho; é uma biblioteca.
91
92 %package devel
93 Summary:        Development part of the GD library
94 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollar programas usando gd
95 Summary(pl.UTF-8):      Część biblioteki GD przeznaczona dla developerów
96 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para desenvolver programas usando gd
97 Group:          Development/Libraries
98 Requires:       %{name} = %{version}-%{release}
99 Requires:       fontconfig-devel
100 Requires:       freetype-devel >= 1:2.1.10
101 %{?with_avif:Requires:  libavif-devel >= 0.8.2}
102 %{?with_heif:Requires:  libheif-devel >= 1.7.0}
103 %{?with_libimagequant:Requires: libimagequant-devel}
104 Requires:       libjpeg-devel
105 Requires:       libpng-devel
106 %{?with_raqm:Requires:  libraqm-devel}
107 Requires:       libtiff-devel >= 4
108 Requires:       libwebp-devel
109 %{?with_xpm:Requires:   xorg-lib-libXpm-devel}
110 Requires:       zlib-devel
111 Provides:       gd-devel(gif) = %{version}-%{release}
112 Provides:       gd-devel(imagerotate) = 5.2.0
113
114 %description devel
115 This package contains the files needed for development of programs
116 linked against GD.
117
118 %description devel -l es.UTF-8
119 Este paquete contiene los archivos de inclusión y las bibliotecas
120 necesarias para desarrollar programas usando gd.
121
122 %description devel -l pl.UTF-8
123 Pakiet ten zawiera pliki potrzebne do rozwoju programów korzystających
124 z biblioteki GD.
125
126 %description devel -l pt_BR.UTF-8
127 Este pacote contém os arquivos de inclusão e as bibliotecas
128 necessárias para desenvolver programas usando gd.
129
130 %package static
131 Summary:        Static GD library
132 Summary(pl.UTF-8):      Statyczna biblioteka GD
133 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com libgd
134 Group:          Development/Libraries
135 Requires:       %{name}-devel = %{version}-%{release}
136 Provides:       gd-static(gif) = %{version}-%{release}
137 Provides:       gd-static(imagerotate) = 5.2.0
138
139 %description static
140 This package contains static gd library.
141
142 %description static -l pl.UTF-8
143 Ten pakiet zawiera statyczną bibliotekę gd.
144
145 %description static -l pt_BR.UTF-8
146 Este pacote contem bibliotecas estáticas para desenvolvimento com
147 libgd.
148
149 %package progs
150 Summary:        Utility programs that use libgd
151 Summary(es.UTF-8):      Programas utilitarios libgd
152 Summary(pl.UTF-8):      Narzędzia używające libgd
153 Summary(pt_BR.UTF-8):   Programas utilitários libgd
154 Group:          Applications/Graphics
155 Requires:       %{name} = %{version}-%{release}
156
157 %description progs
158 These are utility programs supplied with gd, the image manipulation
159 library. The libgd-progs package contains a group of scripts for
160 manipulating the graphics files in formats which are supported by the
161 libgd library.
162
163 %description progs -l pl.UTF-8
164 Ten pakiet zawiera programy używające biblioteki gd, służące do
165 obróbki plików graficznych w formatach obsługiwanych przez libgd.
166
167 %description progs -l pt_BR.UTF-8
168 Este pacote inclui vários utilitários para manipulação de arquivos gd
169 para uso pelos programas que usam a libgd.
170
171 %prep
172 %setup -q -n libgd-%{version}
173 %patch0 -p1
174 %patch1 -p1
175 %patch2 -p1
176
177 %build
178 %{__libtoolize}
179 %{__aclocal} -I m4
180 %{__automake}
181 %{__autoheader}
182 %{__autoconf}
183 %ifarch %{ix86}
184 %if %{with sse}
185 CFLAGS="%{rpmcflags} -msse -mfpmath=sse"
186 %endif
187 %endif
188 %configure \
189         %{!?with_avif:--without-avif} \
190         %{!?with_fontconfig:--without-fontconfig} \
191         %{!?with_heif:--without-heif} \
192         %{!?with_libimagequant:--without-liq} \
193         %{!?with_raqm:--without-raqm} \
194         %{!?with_xpm:--without-xpm}
195 %{__make}
196
197 %if %{with tests}
198 %ifarch %{ix86}
199 # https://github.com/libgd/libgd/issues/359
200 XFAIL_TESTS="$XFAIL_TESTS gdimagegrayscale/basic"
201 %if %{without sse}
202 # 387 arithmetic is inexact, https://github.com/libgd/libgd/issues/242
203 XFAIL_TESTS="$XFAIL_TESTS gdimagecopyresampled/bug00201"
204 %endif
205 %endif
206 %if %{with raqm}
207 # https://github.com/libgd/libgd/issues/613
208 XFAIL_TESTS="$XFAIL_TESTS gdimagestringft/gdimagestringft_bbox"
209 %endif
210 export XFAIL_TESTS
211 %{__make} check
212 %endif
213
214 %install
215 rm -rf $RPM_BUILD_ROOT
216
217 %{__make} install \
218         DESTDIR=$RPM_BUILD_ROOT
219
220 %clean
221 rm -rf $RPM_BUILD_ROOT
222
223 %post   -p /sbin/ldconfig
224 %postun -p /sbin/ldconfig
225
226 %files
227 %defattr(644,root,root,755)
228 %doc CONTRIBUTORS COPYING README.md
229 %attr(755,root,root) %{_libdir}/libgd.so.*.*.*
230 %attr(755,root,root) %ghost %{_libdir}/libgd.so.3
231
232 %files devel
233 %defattr(644,root,root,755)
234 %attr(755,root,root) %{_libdir}/libgd.so
235 %{_libdir}/libgd.la
236 %{_includedir}/gd*.h
237 %{_pkgconfigdir}/gdlib.pc
238
239 %files static
240 %defattr(644,root,root,755)
241 %{_libdir}/libgd.a
242
243 %files progs
244 %defattr(644,root,root,755)
245 %attr(755,root,root) %{_bindir}/annotate
246 %attr(755,root,root) %{_bindir}/bdftogd
247 %attr(755,root,root) %{_bindir}/gd2copypal
248 %attr(755,root,root) %{_bindir}/gd2togif
249 %attr(755,root,root) %{_bindir}/gd2topng
250 %attr(755,root,root) %{_bindir}/gdcmpgif
251 %attr(755,root,root) %{_bindir}/gdparttopng
252 %attr(755,root,root) %{_bindir}/gdtopng
253 %attr(755,root,root) %{_bindir}/giftogd2
254 %attr(755,root,root) %{_bindir}/pngtogd
255 %attr(755,root,root) %{_bindir}/pngtogd2
256 %attr(755,root,root) %{_bindir}/webpng
This page took 0.059633 seconds and 3 git commands to generate.