]> git.pld-linux.org Git - packages/freerdp2.git/commitdiff
- fix building with openssl 3.0.0, rel 2 auto/th/freerdp2-2.4.0-2
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 29 Sep 2021 21:06:23 +0000 (23:06 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 29 Sep 2021 21:06:23 +0000 (23:06 +0200)
freerdp2.spec
openssl3.patch [new file with mode: 0644]

index 56e5a8089fc9be51fcb4746fabc9ebfe422cea87..d40b956280c8f9b2174706519a8f07343d802db4 100644 (file)
@@ -37,7 +37,7 @@ Summary:      Remote Desktop Protocol client
 Summary(pl.UTF-8):     Klient protokołu RDP
 Name:          freerdp2
 Version:       2.4.0
-Release:       1
+Release:       2
 License:       Apache v2.0
 Group:         Applications/Communications
 Source0:       https://pub.freerdp.com/releases/freerdp-%{version}.tar.gz
@@ -45,6 +45,7 @@ Source0:      https://pub.freerdp.com/releases/freerdp-%{version}.tar.gz
 Patch0:                freerdp-opt.patch
 Patch1:                freerdp-gsm.patch
 Patch2:                docbook-xsl.patch
+Patch3:                openssl3.patch
 URL:           http://www.freerdp.com/
 %{?with_directfb:BuildRequires:        DirectFB-devel}
 %{?with_opencl:BuildRequires:  OpenCL-devel}
@@ -195,6 +196,7 @@ wykorzystujących biblioteki FreeRDP 2.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 cat << EOF > xfreerdp.desktop
 [Desktop Entry]
diff --git a/openssl3.patch b/openssl3.patch
new file mode 100644 (file)
index 0000000..d0992ec
--- /dev/null
@@ -0,0 +1,31 @@
+--- freerdp-2.4.0/winpr/libwinpr/utils/ssl.c.orig      2021-07-27 11:58:27.000000000 +0200
++++ freerdp-2.4.0/winpr/libwinpr/utils/ssl.c   2021-09-29 23:00:16.142585681 +0200
+@@ -32,6 +32,7 @@
+ #include <openssl/ssl.h>
+ #include <openssl/err.h>
++#include <openssl/evp.h>
+ #include "../log.h"
+ #define TAG WINPR_TAG("utils.ssl")
+@@ -244,9 +245,9 @@
+ #else
+               WLog_DBG(TAG, "Ensuring openssl fips mode is ENabled");
+-              if (FIPS_mode() != 1)
++              if (EVP_default_properties_is_fips_enabled(NULL) != 1)
+               {
+-                      if (FIPS_mode_set(1))
++                      if (EVP_default_properties_enable_fips(NULL, 1))
+                               WLog_INFO(TAG, "Openssl fips mode ENabled!");
+                       else
+                       {
+@@ -358,7 +358,7 @@
+ #if (OPENSSL_VERSION_NUMBER < 0x10001000L) || defined(LIBRESSL_VERSION_NUMBER)
+       return FALSE;
+ #else
+-      return (FIPS_mode() == 1);
++      return (EVP_default_properties_is_fips_enabled(NULL) == 1);
+ #endif
+ }
This page took 0.170599 seconds and 4 git commands to generate.