]> git.pld-linux.org Git - packages/eric6.git/blob - eric6.spec
48af5b7712da7e2dc6cd672e26ca6d8602cc0877
[packages/eric6.git] / eric6.spec
1 # TODO: Switch to python3
2
3 %define         module  eric6
4 Summary:        Eric6 - a full featured Python IDE
5 Summary(pl.UTF-8):      Eric6 - pełnowartościowe IDE dla Pythona
6 # Name must match the python module/package name (as on pypi or in 'import' statement)
7 Name:           eric6
8 Version:        6.1.8
9 Release:        1
10 License:        GPL v3
11 Group:          Libraries/Python
12 Source0:        https://sourceforge.net/projects/eric-ide/files/eric6/stable/%{version}/eric6-%{version}.tar.gz
13 # Source0-md5:  a070c679fbc93fab4f3b718a5875e5d0
14 URL:            http://eric-ide.python-projects.org/index.html
15 BuildRequires:  rpm-pythonprov
16 # for the py_build, py_install macros
17 BuildRequires:  rpmbuild(macros) >= 1.714
18 BuildRequires:  python-modules
19 BuildRequires:  python-setuptools
20 # NOTE: As for 6.1.8  eric6 still tries to import PyQt5 while having PyQt4 leading to crash
21 #       http://die-offenbachs.homelinux.org:48888/issues/issue204
22 # for --pyqt=4
23 # BuildRequires:        python-PyQt4-qscintilla2
24 # BuildRequires:        python-PyQt4-uic
25 # for --pyqt=5
26 BuildRequires:  python-PyQt5-qscintilla2
27 BuildRequires:  python-PyQt5-uic
28 Requires:       python-modules
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Eric is a Python IDE written using PyQt and QScintilla. It provides
34 various features such as any number of open editors, an integrated
35 (remote) debugger, project management facilities, unit test,
36 refactoring and much more.
37
38 %description -l pl.UTF-8
39 Eric jest pythonowym graficznym środowiskiem programistycznym
40 używającym PyQt i QScintilla.
41
42 %prep
43 %setup -q
44
45 %build
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 python install.py -z -c -b %{_bindir} -d %{py_sitescriptdir} -i $RPM_BUILD_ROOT  --pyqt=5
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc README.rst
57 %{py_sitescriptdir}/%{module}
58 %attr(755,root,root) %{_bindir}/eric6
59 %attr(755,root,root) %{_bindir}/eric6_*
60 # for --pyqt=4
61 # %{_datadir}/qt4/qsci/api/qss/
62 # %{_datadir}/qt4/qsci/api/ruby/
63 # NOTE: file %{_datadir}/qt4/qsci/api/ruby/Ruby-1.8.7.api from install of eric6-6.1.8-0.1.noarch conflicts with file from package eric4-4.5.24-3.noarch
64 # %{_datadir}/qt4/qsci/api/python/eric6.*
65 # %{_datadir}/qt4/qsci/api/python/zope-*.api
66
67 # for --pyqt=5
68 %{_datadir}/qt5/qsci/api/qss/
69 %{_datadir}/qt5/qsci/api/ruby/
70 %{_datadir}/qt5/qsci/api/python/eric6.*
71 %{_datadir}/qt5/qsci/api/python/zope-*.api
72
73 %{_pixmapsdir}/eric*.png
74 %{_desktopdir}/eric6.desktop
75 %{_desktopdir}/eric6_webbrowser.desktop
76 %{_datadir}/appdata/eric6.appdata.xml
77 %{py_sitescriptdir}/eric6config.py
78 %{py_sitescriptdir}/eric6plugins
This page took 0.042037 seconds and 2 git commands to generate.