]> git.pld-linux.org Git - packages/ekg.git/blob - ekg.spec
4422461e4d1cc3348d225d68a91d5f3b73208237
[packages/ekg.git] / ekg.spec
1 #
2 # Conditional build:
3 %bcond_without  aspell          # without spell checking
4 %bcond_without  voip            # without VoIP support
5 %bcond_without  python          # with python support
6 %bcond_without  pthread         # build with Posix threads support
7 %bcond_with     ioctl_daemon    # with ioctl_daemon (suid root)
8 %bcond_with     lock_reason     # with lock_reason patch
9 #
10 Summary:        A client compatible with Gadu-Gadu
11 Summary(de.UTF-8):      Ein Cliente kompatibel mit Gadu-Gadu
12 Summary(es.UTF-8):      Un cliente compatible con Gadu-Gadu
13 Summary(it.UTF-8):      Un cliente compatibile con Gadu-Gadu
14 Summary(pl.UTF-8):      Klient kompatybilny z Gadu-Gadu
15 Name:           ekg
16 Version:        1.7
17 Release:        14
18 Epoch:          4
19 License:        GPL v2
20 Group:          Applications/Communications
21 Source0:        http://ekg.chmurka.net/%{name}-%{version}.tar.gz
22 # Source0-md5:  2aa92b56517fdf09d75519a105772b74
23 Source1:        %{name}.conf
24 Patch0:         %{name}-LDFLAGS.patch
25 Patch1:         %{name}-lock_reason.patch
26 Patch2:         %{name}-external_libgadu.patch
27 Patch3:         %{name}-giflib.patch
28 URL:            http://ekg.chmurka.net/
29 BuildRequires:  %{_bindir}/perl
30 %{?with_aspell:BuildRequires:   aspell-devel}
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 BuildRequires:  giflib-devel >= 5.1
34 BuildRequires:  libgadu-devel >= 4:1.7.0
35 %{?with_voip:BuildRequires:     libgsm-devel}
36 BuildRequires:  libjpeg-devel
37 BuildRequires:  ncurses-devel
38 BuildRequires:  openssl-devel >= 0.9.7d
39 BuildRequires:  pkgconfig
40 %if %{with python}
41 BuildRequires:  python
42 BuildRequires:  python-devel
43 BuildRequires:  python-modules
44 %endif
45 BuildRequires:  readline-devel
46 BuildRequires:  zlib-devel
47 Requires:       libgadu >= 4:1.7.0
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 EKG ("Eksperymentalny Klient Gadu-Gadu") is an open source gadu-gadu
52 client for UNIX systems. Gadu-Gadu is an instant messaging program,
53 very popular in Poland.
54
55 EKG features include:
56   - irssi-like ncurses interface
57   - sending and receiving files
58   - voice conversations
59   - launching shell commands on certain events
60   - reading input from pipe
61   - python scripting support
62   - speech synthesis (using an external program)
63   - encryption support
64
65 Please note that the program is not internationalized and all messages
66 are in Polish (although the commands are in English).
67
68 %description -l de.UTF-8
69 Ein Cliente kompatibel mit Gadu-Gadu.
70
71 %description -l es.UTF-8
72 Un cliente compatible con Gadu-Gadu.
73
74 %description -l it.UTF-8
75 Un cliente compatibile con Gadu-Gadu.
76
77 %description -l pl.UTF-8
78 EKG ("Eksperymentalny Klient Gadu-Gadu") jest open source'owym
79 klientem gadu-gadu dla systemów uniksowych. Gadu-Gadu to popularny w
80 Polsce komunikator internetowy.
81
82 Możliwości EKG:
83   - interfejs użytkownika podobny do irssi,
84   - wysyłanie i odbieranie plików,
85   - rozmowy głosowe,
86   - uruchamianie poleceń powłoki w określonych sytuacjach,
87   - wczytywanie wejścia z potoku,
88   - wsparcie dla skryptów w języku Python,
89   - synteza mowy (z użyciem zewnętrznego programu),
90   - wsparcie dla szyfrowania.
91
92 Program nie jest umiędzynarodowiony i wszystkie komunikaty są po
93 polsku (jednak komendy są w języku angielskim).
94
95 %prep
96 %setup -q
97 %patch0 -p0
98 %if %{with lock_reason}
99 %patch1 -p1
100 %endif
101 %patch2 -p0
102 %patch3 -p1
103
104 %build
105 %{__aclocal} -I m4
106 %{__autoheader}
107 %{__autoconf}
108 %configure \
109         CFLAGS_LIBGADU="%{rpmcflags}" \
110         --enable-dynamic \
111         --enable-shared \
112         --enable-static \
113 %if %{with pthread}
114         --with-pthread \
115 %else
116         --without-pthread \
117 %endif
118         --without-bind \
119         %{?with_python:--with-python} \
120         %{!?with_voip:--without-libgsm} \
121         %{?with_aspell:--enable-aspell} \
122         %{?with_ioctl_daemon:--enable-ioctld}
123
124 %{__make}
125
126 %if %{with ioctl_daemon}
127 %{__make} -C src ioctld
128 %endif
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 install -d $RPM_BUILD_ROOT%{_sysconfdir}
133
134 %{__make} install install-ekl2 \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
138
139 # For libgadu-devel
140
141 rm -f examples/Makefile examples/Makefile.in examples/.cvsignore
142 rm -rf examples/CVS
143
144 %if %{with ioctl_daemon}
145 install src/ioctld $RPM_BUILD_ROOT%{_bindir}
146 %endif
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %files
152 %defattr(644,root,root,755)
153 %doc docs/{7thguard,dcc,files,gdb,python,sim,themes,ui-ncurses,vars,voip}.txt
154 %{?with_aspell:%doc docs/slownik.txt}
155 %doc ChangeLog docs/{FAQ,README,TODO,ULOTKA} docs/emoticons.{ansi,sample}
156 %attr(755,root,root) %{_bindir}/e*
157 %{?with_ioctl_daemon:%attr(4755,root,root) %{_bindir}/ioctld}
158 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.conf
159 %{_datadir}/ekg
160 %{_mandir}/man1/*
161 %lang(pl) %{_mandir}/pl/man1/*
This page took 0.392538 seconds and 2 git commands to generate.