]> git.pld-linux.org Git - packages/curl.git/commitdiff
upstream build fix for !x86 && !arm64 auto/th/curl-7.84.0-1
authorJan Palus <atler@pld-linux.org>
Mon, 27 Jun 2022 10:42:56 +0000 (12:42 +0200)
committerJan Palus <atler@pld-linux.org>
Mon, 27 Jun 2022 10:42:56 +0000 (12:42 +0200)
curl.spec
sched.patch [new file with mode: 0644]

index 638c7a16148d62b87dc4fe422899d10a9fe48cb6..ff82541b4fdd6092417e4dc850b05cb7317909fe 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -32,6 +32,7 @@ Source0:      https://curl.haxx.se/download/%{name}-%{version}.tar.xz
 # Source0-md5: 6ce66afa416bb11b8f39cc9e059afd5b
 Patch0:                %{name}-ac.patch
 Patch1:                %{name}-krb5flags.patch
+Patch2:                sched.patch
 URL:           http://curl.haxx.se/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
@@ -243,6 +244,7 @@ Dopełnianianie parametrów w ZSH dla polecenia curl.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %{__rm} m4/lt*.m4 m4/libtool.m4
 
diff --git a/sched.patch b/sched.patch
new file mode 100644 (file)
index 0000000..33f08fa
--- /dev/null
@@ -0,0 +1,26 @@
+From e2e7f54b7bea521fa8373095d0f43261a720cda0 Mon Sep 17 00:00:00 2001
+From: Daniel Stenberg <daniel@haxx.se>
+Date: Mon, 27 Jun 2022 08:46:21 +0200
+Subject: [PATCH] easy_lock.h: include sched.h if available to fix build
+
+Patched-by: Harry Sintonen
+
+Closes #9054
+---
+ lib/easy_lock.h | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/lib/easy_lock.h b/lib/easy_lock.h
+index 819f50ce815b8..1f54289ceb2d3 100644
+--- a/lib/easy_lock.h
++++ b/lib/easy_lock.h
+@@ -36,6 +36,9 @@
+ #elif defined (HAVE_ATOMIC)
+ #include <stdatomic.h>
++#if defined(HAVE_SCHED_YIELD)
++#include <sched.h>
++#endif
+ #define curl_simple_lock atomic_bool
+ #define CURL_SIMPLE_LOCK_INIT false
This page took 0.23039 seconds and 4 git commands to generate.