]> git.pld-linux.org Git - packages/cryptlib.git/blob - cryptlib.spec
- release 3 (by relup.sh)
[packages/cryptlib.git] / cryptlib.spec
1 #
2 %define         libver  3.3.3
3 #
4 %define         _ver    %(echo %{version} | tr -d .)
5 Summary:        Peter Gutmann's general purpose encryption library
6 Summary(pl.UTF-8):      Biblioteka kryptograficzna ogólnego przeznaczenia Petera Gutmanna
7 Name:           cryptlib
8 Version:        3.3.3
9 Release:        3
10 License:        sleepycat
11 Group:          Libraries
12 Source0:        ftp://ftp.franken.de/pub/crypt/cryptlib/cl%{_ver}.zip
13 # Source0-md5:  afdb94894f7f798702703f4a95a2e7ac
14 Patch0:         %{name}-rdtsc.patch
15 Patch1:         %{name}-soname.patch
16 URL:            http://www.cs.auckland.ac.nz/~pgut001/cryptlib/
17 BuildRequires:  python-devel >= 1:2.5
18 BuildRequires:  python-setuptools
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  sed >= 4.0
21 BuildRequires:  unzip
22 BuildRequires:  which
23 %pyrequires_eq  python-modules
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The cryptlib encryption library provides an easy-to-use interface
28 which allows even inexperienced crypto programmers to easily add
29 strong encryption and authentication services to their software. The
30 library contains DES, triple DES, IDEA, MDC/SHS, RC2, RC4, RC5, SAFER,
31 SAFER-SK, Blowfish, and Blowfish-SK conventional encryption, MD2, MD4,
32 MD5, RIPEMD-160 and SHA hash algorithms, and Diffie-Hellman, DSA, and
33 RSA public-key encryption.
34
35 %description -l pl.UTF-8
36 Biblioteka kryptograficzna cryptlib udostępnia łatwy w użyciu
37 interfejs pozwalający nawet niedoświaczonym programistom kryptografii
38 łatwo dodawać do swoich programów usługi kryptograficzne i
39 uwierzytelnienia. Biblioteka zawiera szyfry konwencjonalne DES, 3DES,
40 IDEA, MDC/SHS, RC2, RC4, RC5, SAFER, SAFER-SK, Blowfish i Blowfish-SK,
41 algorytmy skrótu MD2, MD4, MD5, RIPEMD-160 i SHA oraz szyfry klucza
42 publicznego Diffie-Hellmana, DSA i RSA.
43
44 %package devel
45 Summary:        Header file for cryptlib library
46 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki cryptlib
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description devel
51 The header file for developing applications that use the cryptlib
52 cryptography library.
53
54 %description devel -l pl.UTF-8
55 Plik nagłówkowy do tworzenia aplikacji korzystających z biblioteki
56 kryptograficznej cryptlib.
57
58 %package static
59 Summary:        Static cryptlib library
60 Summary(pl.UTF-8):      Statyczna biblioteka cryptlib
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static cryptlib library.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka cryptlib.
69
70 %package -n python-cryptlib
71 Summary:        Python bindings for cryptlib
72 Summary(pl.UTF-8):      Wiązania języka Python do biblioteki cryptlib
73 Group:          Libraries/Python
74 Requires:       python >= 1:2.4
75
76 %description -n python-cryptlib
77 Python bindings for cryptlib library.
78
79 %description -n python-cryptlib -l pl.UTF-8
80 Wiązania języka Python do biblioteki cryptlib.
81
82 %prep
83 %setup -q -T -c
84 unzip -q -L -a %{SOURCE0}
85 %patch0 -p1
86 %patch1 -p1
87
88 sed -i -e 's/ -O3 / %{rpmcflags} /' makefile
89
90 %build
91 %{__make} \
92         CC="%{__cc}"
93
94 %{__make} shared \
95         CC="%{__cc}"
96
97 ln -sf libcl.so.%{libver} libcl.so
98
99 cd bindings
100 %py_build
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir},%{py_sitedir}}
105
106 install cryptlib.h $RPM_BUILD_ROOT%{_includedir}
107 install libcl.a $RPM_BUILD_ROOT%{_libdir}
108 install libcl.so.%{libver} $RPM_BUILD_ROOT%{_libdir}
109 ln -s libcl.so.%{libver} $RPM_BUILD_ROOT%{_libdir}/libcl.so.3
110 ln -s libcl.so.%{libver} $RPM_BUILD_ROOT%{_libdir}/libcl.so
111
112 cd bindings
113 %py_install
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_libdir}/libcl.so.%{libver}
124 %attr(755,root,root) %ghost %{_libdir}/libcl.so.3
125
126 %files devel
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_libdir}/libcl.so
129 %{_includedir}/cryptlib.h
130
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/libcl.a
134
135 %files -n python-cryptlib
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{py_sitedir}/cryptlib_py.so
138 %{py_sitedir}/cryptlib_py-*.egg-info
This page took 0.094312 seconds and 3 git commands to generate.