]> git.pld-linux.org Git - packages/crossmingw32-wxWidgets.git/commitdiff
- updated to 2.8.0 rc1 auto/th/wxWidgets-2_8_0-0_1 auto/th/wxWidgets-2_8_0-0_2 auto/th/wxWidgets-2_8_0-0_rc3_1 auto/th/wxWidgets-2_8_1-1 auto/th/wxWidgets-2_8_1-2 auto/th/wxWidgets-2_8_1-3 auto/th/wxWidgets-2_8_6-1 auto/th/wxWidgets-2_8_7-1 auto/th/wxWidgets-2_8_8-1 auto/th/wxWidgets-2_8_9-1 auto/ti/wxWidgets-2_8_7-1 auto/ti/wxWidgets-2_8_8-1 auto/ti/wxWidgets-2_8_9-1
authorJarosław Kruk <jareq@pld-linux.org>
Mon, 27 Nov 2006 16:56:46 +0000 (16:56 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    wxWidgets-ac.patch -> 1.3
    wxWidgets-gif0delay.patch -> 1.3

wxWidgets-ac.patch
wxWidgets-gif0delay.patch

index f83a6ed79533d199e8b04104c7d24a7e4311b52f..3abb62538593ffb9061e2843fbb7a6c5cd6962ab 100644 (file)
@@ -1,6 +1,6 @@
 --- wxWidgets-2.5.3/configure.in.orig  2005-02-20 19:38:45.461014000 +0100
 +++ wxWidgets-2.5.3/configure.in       2005-02-20 20:58:15.485860176 +0100
-@@ -2218,7 +2217,7 @@
+@@ -2670,7 +2670,7 @@
              dnl HAVE_STDLIB_H which are already defined and this provokes
              dnl a compiler warning which configure considers as an error...
              AC_MSG_CHECKING(for jpeglib.h)
@@ -9,7 +9,7 @@
                  AC_TRY_COMPILE(
                      [
                          #undef HAVE_STDLIB_H
-@@ -2230,7 +2229,7 @@
+@@ -2682,7 +2682,7 @@
                      ac_cv_header_jpeglib_h=yes,
                      ac_cv_header_jpeglib_h=no
                  )
index 24756ea6e93f7e003f263a86ad854b2533c9d2f7..3c4821ae906d39904eeddfc4d7f18571920abbf4 100644 (file)
@@ -1,36 +1,32 @@
-Protection against 0 (too short in general) delay in GIF animation.
-It caused xchm to hang just animating GIF without actually displaying anything.
-(affected wxgtk*; not wxx11univ because of different implementation)
-
---- wxWidgets-2.5.3/src/html/m_image.cpp.orig  2004-09-28 13:18:36.000000000 +0200
-+++ wxWidgets-2.5.3/src/html/m_image.cpp       2005-02-20 21:06:55.564796160 +0100
-@@ -337,6 +337,11 @@
+--- wxWidgets-2.7.1/src/html/m_image.cpp.orig  2006-10-12 14:52:20.000000000 +0200
++++ wxWidgets-2.7.1/src/html/m_image.cpp       2006-10-15 20:32:56.000000000 +0200
+@@ -333,6 +333,11 @@
  
      DECLARE_NO_COPY_CLASS(wxGIFTimer)
  };
 +
 +static int safedelay(int ms)
 +{
-+      return (ms >= 10) ? ms : 10;
++       return (ms >= 10) ? ms : 10;
 +}
  #endif
  
  
-@@ -390,7 +395,7 @@
+@@ -388,7 +393,7 @@
                          if ( m_gifDecoder->IsAnimation() )
                          {
                              m_gifTimer = new wxGIFTimer(this);
--                            m_gifTimer->Start(m_gifDecoder->GetDelay(), true);
-+                            m_gifTimer->Start(safedelay(m_gifDecoder->GetDelay()), true);
+-                            m_gifTimer->Start(m_gifDecoder->GetDelay(0), true);
++                            m_gifTimer->Start(safedelay(m_gifDecoder->GetDelay(0)), true);
                          }
                          else
                          {
-@@ -517,7 +522,7 @@
-         m_window->Refresh(img.HasMask(), &rect);
+@@ -522,7 +527,7 @@
+         win->Refresh(img.HasMask(), &rect);
      }
  
--    timer->Start(m_gifDecoder->GetDelay(), true);
-+    timer->Start(safedelay(m_gifDecoder->GetDelay()), true);
+-    timer->Start(m_gifDecoder->GetDelay(m_nCurrFrame), true);
++    timer->Start(safedelay(m_gifDecoder->GetDelay(m_nCurrFrame)), true);
  }
  
  void wxHtmlImageCell::Layout(int w)
This page took 0.049733 seconds and 4 git commands to generate.