]> git.pld-linux.org Git - packages/crossmingw32-gtkmm.git/blob - crossmingw32-gtkmm.spec
- updated to 2.22.0
[packages/crossmingw32-gtkmm.git] / crossmingw32-gtkmm.spec
1 Summary:        A C++ interface for the GTK+ (a GUI library for X) - cross MinGW32 version
2 Summary(pl.UTF-8):      Wrapper C++ dla GTK+ - skrośna wersja MinGW32
3 %define         realname   gtkmm
4 Name:           crossmingw32-%{realname}
5 Version:        2.22.0
6 Release:        1
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtkmm/2.22/%{realname}-%{version}.tar.bz2
10 # Source0-md5:  4356dfde44b13f7fb1bfbd97623f37dd
11 URL:            http://www.gtkmm.org/
12 BuildRequires:  autoconf >= 2.59
13 BuildRequires:  automake >= 1:1.9
14 BuildRequires:  crossmingw32-atkmm >= 2.22.0
15 BuildRequires:  crossmingw32-cairomm >= 1.6.3
16 BuildRequires:  crossmingw32-gcc-c++ >= 3.3.1
17 BuildRequires:  crossmingw32-glibmm >= 2.24.0
18 BuildRequires:  crossmingw32-gtk+2 >= 2.20.0
19 BuildRequires:  crossmingw32-pangomm >= 2.26.0
20 BuildRequires:  libtool >= 2:1.5
21 BuildRequires:  mm-common >= 0.8
22 BuildRequires:  perl-base >= 1:5.6.0
23 BuildRequires:  pkgconfig >= 1:0.15
24 Requires:       crossmingw32-atkmm >= 2.22.0
25 Requires:       crossmingw32-cairomm >= 1.6.3
26 Requires:       crossmingw32-gtk+2 >= 2.20.0
27 Requires:       crossmingw32-pangomm >= 2.26.0
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         no_install_post_strip   1
31
32 %define         target                  i386-mingw32
33 %define         target_platform         i386-pc-mingw32
34
35 %define         _sysprefix              /usr
36 %define         _prefix                 %{_sysprefix}/%{target}
37 %define         _libdir                 %{_prefix}/lib
38 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
39 %define         _dlldir                 /usr/share/wine/windows/system
40 %define         __cc                    %{target}-gcc
41 %define         __cxx                   %{target}-g++
42
43 %ifnarch %{ix86}
44 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
45 %define         optflags        -O2
46 %endif
47 # -z options are invalid for mingw linker
48 %define         filterout_ld    -Wl,-z,.*
49
50 %description
51 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
52 library. The interface provides a convenient interface for C++
53 programmers to create GUIs with GTK+'s flexible object-oriented
54 framework. Features include type safe callbacks, widgets that are
55 extensible using inheritance and over 110 classes that can be freely
56 combined to quickly create complex user interfaces.
57
58 This package contains the cross version for Win32.
59
60 %description -l pl.UTF-8
61 gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
62 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
63 także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
64
65 Ten pakiet zawiera wersję skrośną dla Win32.
66
67 %package static
68 Summary:        Static gtkmm libraries (cross MinGW32 version)
69 Summary(pl.UTF-8):      Statyczne biblioteki gtkmm (wersja skrośna MinGW32)
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72
73 %description static
74 Static gtkmm libraries (cross MinGW32 version).
75
76 %description static -l pl.UTF-8
77 Statyczne biblioteki gtkmm (wersja skrośna MinGW32).
78
79 %package dll
80 Summary:        DLL gtkmm libraries for Windows
81 Summary(pl.UTF-8):      Biblioteki DLL gtkmm dla Windows
82 Group:          Applications/Emulators
83 Requires:       crossmingw32-atkmm-dll >= 2.22.0
84 Requires:       crossmingw32-cairomm-dll >= 1.6.3
85 Requires:       crossmingw32-gtk+2-dll >= 2.20.0
86 Requires:       crossmingw32-pangomm-dll >= 2.26.0
87 Requires:       wine
88
89 %description dll
90 DLL gtkmm libraries for Windows.
91
92 %description dll -l pl.UTF-8
93 Biblioteki DLL gtkmm dla Windows.
94
95 %prep
96 %setup -q -n %{realname}-%{version}
97
98 %build
99 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
100 %{__libtoolize}
101 %{__aclocal} -I build
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105 %configure \
106         --targe=%{target} \
107         --host=%{target} \
108         --disable-documentation \
109         --enable-static
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 install -d $RPM_BUILD_ROOT%{_dlldir}
120 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
121
122 %if 0%{!?debug:1}
123 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
124 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
125 %endif
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS ChangeLog NEWS PORTING README
133 %{_libdir}/libgdkmm-2.4.dll.a
134 %{_libdir}/libgtkmm-2.4.dll.a
135 %{_libdir}/libgdkmm-2.4.la
136 %{_libdir}/libgtkmm-2.4.la
137 %{_libdir}/gdkmm-2.4
138 %{_libdir}/gtkmm-2.4
139 %{_includedir}/gdkmm-2.4
140 %{_includedir}/gtkmm-2.4
141 %{_pkgconfigdir}/gdkmm-2.4.pc
142 %{_pkgconfigdir}/gtkmm-2.4.pc
143
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libgdkmm-2.4.a
147 %{_libdir}/libgtkmm-2.4.a
148
149 %files dll
150 %defattr(644,root,root,755)
151 %{_dlldir}/libgdkmm-2.4-*.dll
152 %{_dlldir}/libgtkmm-2.4-*.dll
This page took 0.184867 seconds and 3 git commands to generate.