]> git.pld-linux.org Git - packages/crossmingw32-freetype.git/blame - crossmingw32-freetype.spec
- updated to 2.4.12
[packages/crossmingw32-freetype.git] / crossmingw32-freetype.spec
CommitLineData
3294533f 1#
2# Conditional build:
46479e07 3%bcond_without lcd # without LCD subpixel color filtering (Microsoft patents in USA)
1e7243e1 4#
8bddf7fd 5%define realname freetype
7b9bae77
JB
6Summary: TrueType font rasterizer - MinGW32 cross version
7Summary(pl.UTF-8): Rasteryzer fontów TrueType - wersja skrośna dla MinGW32
8bddf7fd 8Name: crossmingw32-%{realname}
055d56e2
JB
9Version: 2.4.12
10Release: 1
b5e35991 11License: GPL v2 or FTL
1e7243e1 12Group: Development/Libraries
46479e07 13Source0: http://downloads.sourceforge.net/freetype/%{realname}-%{version}.tar.bz2
055d56e2 14# Source0-md5: 3463102764315eb86c0d3c2e1f3ffb7d
3294533f 15URL: http://www.freetype.org/
31924283 16BuildRequires: crossmingw32-bzip2
3c4380bc 17BuildRequires: crossmingw32-gcc
8bddf7fd 18BuildRequires: crossmingw32-zlib >= 1.2.3-2
3294533f 19BuildRequires: python
31924283 20Requires: crossmingw32-bzip2
8bddf7fd 21Requires: crossmingw32-zlib >= 1.2.3-2
3294533f 22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%define specflags_ia32 -fomit-frame-pointer
25# see <freetype/internal/ftserv.h>, the real horror
26%define specflags -fno-strict-aliasing
27
28%define no_install_post_strip 1
29
30%define target i386-mingw32
31%define target_platform i386-pc-mingw32
3294533f 32
33%define _sysprefix /usr
34%define _prefix %{_sysprefix}/%{target}
b5aa177c
JB
35%define _libdir %{_prefix}/lib
36%define _pkgconfigdir %{_prefix}/lib/pkgconfig
1e7243e1 37%define _dlldir /usr/share/wine/windows/system
3294533f 38%define __cc %{target}-gcc
39%define __cxx %{target}-g++
d230bce9 40%define __pkgconfig_provides %{nil}
dce5a0f7 41%define __pkgconfig_requires %{nil}
3294533f 42
46479e07
JB
43%ifnarch %{ix86}
44# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
45%define optflags -O2
46%endif
4f990096 47# -z options are invalid for mingw linker, most of -f options are Linux-specific
46479e07 48%define filterout_ld -Wl,-z,.*
4f990096 49%define filterout_c -f[-a-z0-9=]*
46479e07 50
3294533f 51%description
52The FreeType engine is a free and portable TrueType font rendering
53engine. It has been developed to provide TrueType support to a great
54variety of platforms and environments.
55
56Note that FreeType is a *library*. It is not a font server for your
57favorite platform, even though it was designed to be used in many of
58them. Note also that it is *not* a complete text-rendering library.
59Its purpose is simply to open and manage font files, as well as load,
60hint and render individual glyphs efficiently. You can also see it as
61a "TrueType driver" for a higher-level library, though rendering text
62with it is extremely easy, as demo-ed by the test programs.
63
1e7243e1 64This package contains the cross version for Win32.
3294533f 65
66%description -l pl.UTF-8
67FreeType jest biblioteką służącą do rasteryzacji fontów
68TrueType. Jest to jedynie biblioteka, a nie serwer fontów, chociaż
69została ona zaprojektowana do używania także w takich serwerach.
70Nie jest to też kompletna biblioteka do rasteryzacji tekstu. Jej
71celem jest tylko odczytywanie i zarządzanie plikami z fontami oraz
72wczytywanie i wykonywanie hintingu i rasteryzacji poszczególnych
73glifów. Może być także uważana za "sterownik TrueType" dla
74bibliotek wyższego poziomu, jednak użycie samej biblioteki FreeType
75do rasteryzacji jest bardzo proste, co można zobaczyć w programach
76demonstracyjnych.
77
1e7243e1
JB
78Ten pakiet zawiera wersję skrośną dla Win32.
79
80%package static
7b9bae77
JB
81Summary: Static freetype library (cross MinGW32 version)
82Summary(pl.UTF-8): Statyczna biblioteka freetype (wersja skrośna MinGW32)
1e7243e1
JB
83Group: Development/Libraries
84Requires: %{name} = %{version}-%{release}
85
86%description static
7b9bae77 87Static freetype library (cross MinGW32 version).
1e7243e1
JB
88
89%description static -l pl.UTF-8
7b9bae77 90Statyczna biblioteka freetype (wersja skrośna MinGW32).
1e7243e1
JB
91
92%package dll
93Summary: DLL freetype library for Windows
94Summary(pl.UTF-8): Biblioteka DLL freetype dla Windows
95Group: Applications/Emulators
96Requires: crossmingw32-zlib-dll
97Requires: wine
98
99%description dll
100DLL freetype library for Windows.
101
102%description dll -l pl.UTF-8
103Biblioteka DLL freetype dla Windows.
3294533f 104
105%prep
8bddf7fd 106%setup -q -n %{realname}-%{version}
3294533f 107
108%build
109CFLAGS="%{rpmcflags} \
1c57a66b
JB
110%{?with_lcd:-DFT_CONFIG_OPTION_SUBPIXEL_RENDERING} \
111-DTT_CONFIG_OPTION_SUBPIXEL_HINTING \
112" \
3294533f 113%configure \
3294533f 114 --target=%{target} \
6181c873 115 --build=i686-pc-linux-gnu \
116 --host=%{target} \
117 --enable-shared
3294533f 118
119%{__make}
120
121%install
122rm -rf $RPM_BUILD_ROOT
3294533f 123
124%{__make} install \
125 DESTDIR=$RPM_BUILD_ROOT
126
1e7243e1 127install -d $RPM_BUILD_ROOT%{_dlldir}
8bddf7fd 128mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
1e7243e1
JB
129
130%if 0%{!?debug:1}
131%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
132%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
133%endif
134
135rm -rf $RPM_BUILD_ROOT%{_datadir}/aclocal
136
3294533f 137%clean
138rm -rf $RPM_BUILD_ROOT
139
140%files
141%defattr(644,root,root,755)
0443e0ca 142%doc docs/{CHANGES,FTL.TXT,LICENSE.TXT,TODO,formats.txt,raster.txt}
1e7243e1
JB
143%{_libdir}/libfreetype.dll.a
144%{_libdir}/libfreetype.la
3294533f 145%{_includedir}/freetype2
5bc110d4
JB
146%{_includedir}/ft2build.h
147%{_pkgconfigdir}/freetype2.pc
1e7243e1
JB
148
149%files static
150%defattr(644,root,root,755)
151%{_libdir}/libfreetype.a
152
153%files dll
154%defattr(644,root,root,755)
8bddf7fd 155%{_dlldir}/libfreetype-*.dll
This page took 0.052554 seconds and 4 git commands to generate.