]> git.pld-linux.org Git - packages/crossmingw32-freetype.git/blame - crossmingw32-freetype.spec
do not provide pkgconfig deps in system namespace
[packages/crossmingw32-freetype.git] / crossmingw32-freetype.spec
CommitLineData
3294533f 1#
2# Conditional build:
46479e07 3%bcond_without lcd # without LCD subpixel color filtering (Microsoft patents in USA)
1e7243e1 4#
8bddf7fd 5%define realname freetype
7b9bae77
JB
6Summary: TrueType font rasterizer - MinGW32 cross version
7Summary(pl.UTF-8): Rasteryzer fontów TrueType - wersja skrośna dla MinGW32
8bddf7fd 8Name: crossmingw32-%{realname}
1c57a66b 9Version: 2.4.11
d230bce9 10Release: 2
b5e35991 11License: GPL v2 or FTL
1e7243e1 12Group: Development/Libraries
46479e07 13Source0: http://downloads.sourceforge.net/freetype/%{realname}-%{version}.tar.bz2
1c57a66b 14# Source0-md5: b93435488942486c8d0ca22e8f768034
3294533f 15URL: http://www.freetype.org/
31924283 16BuildRequires: crossmingw32-bzip2
3c4380bc 17BuildRequires: crossmingw32-gcc
8bddf7fd 18BuildRequires: crossmingw32-zlib >= 1.2.3-2
3294533f 19BuildRequires: python
31924283 20Requires: crossmingw32-bzip2
8bddf7fd 21Requires: crossmingw32-zlib >= 1.2.3-2
3294533f 22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%define specflags_ia32 -fomit-frame-pointer
25# see <freetype/internal/ftserv.h>, the real horror
26%define specflags -fno-strict-aliasing
27
28%define no_install_post_strip 1
29
30%define target i386-mingw32
31%define target_platform i386-pc-mingw32
3294533f 32
33%define _sysprefix /usr
34%define _prefix %{_sysprefix}/%{target}
b5aa177c
JB
35%define _libdir %{_prefix}/lib
36%define _pkgconfigdir %{_prefix}/lib/pkgconfig
1e7243e1 37%define _dlldir /usr/share/wine/windows/system
3294533f 38%define __cc %{target}-gcc
39%define __cxx %{target}-g++
d230bce9 40%define __pkgconfig_provides %{nil}
3294533f 41
46479e07
JB
42%ifnarch %{ix86}
43# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
44%define optflags -O2
45%endif
46# -z options are invalid for mingw linker
47%define filterout_ld -Wl,-z,.*
48
3294533f 49%description
50The FreeType engine is a free and portable TrueType font rendering
51engine. It has been developed to provide TrueType support to a great
52variety of platforms and environments.
53
54Note that FreeType is a *library*. It is not a font server for your
55favorite platform, even though it was designed to be used in many of
56them. Note also that it is *not* a complete text-rendering library.
57Its purpose is simply to open and manage font files, as well as load,
58hint and render individual glyphs efficiently. You can also see it as
59a "TrueType driver" for a higher-level library, though rendering text
60with it is extremely easy, as demo-ed by the test programs.
61
1e7243e1 62This package contains the cross version for Win32.
3294533f 63
64%description -l pl.UTF-8
65FreeType jest biblioteką służącą do rasteryzacji fontów
66TrueType. Jest to jedynie biblioteka, a nie serwer fontów, chociaż
67została ona zaprojektowana do używania także w takich serwerach.
68Nie jest to też kompletna biblioteka do rasteryzacji tekstu. Jej
69celem jest tylko odczytywanie i zarządzanie plikami z fontami oraz
70wczytywanie i wykonywanie hintingu i rasteryzacji poszczególnych
71glifów. Może być także uważana za "sterownik TrueType" dla
72bibliotek wyższego poziomu, jednak użycie samej biblioteki FreeType
73do rasteryzacji jest bardzo proste, co można zobaczyć w programach
74demonstracyjnych.
75
1e7243e1
JB
76Ten pakiet zawiera wersję skrośną dla Win32.
77
78%package static
7b9bae77
JB
79Summary: Static freetype library (cross MinGW32 version)
80Summary(pl.UTF-8): Statyczna biblioteka freetype (wersja skrośna MinGW32)
1e7243e1
JB
81Group: Development/Libraries
82Requires: %{name} = %{version}-%{release}
83
84%description static
7b9bae77 85Static freetype library (cross MinGW32 version).
1e7243e1
JB
86
87%description static -l pl.UTF-8
7b9bae77 88Statyczna biblioteka freetype (wersja skrośna MinGW32).
1e7243e1
JB
89
90%package dll
91Summary: DLL freetype library for Windows
92Summary(pl.UTF-8): Biblioteka DLL freetype dla Windows
93Group: Applications/Emulators
94Requires: crossmingw32-zlib-dll
95Requires: wine
96
97%description dll
98DLL freetype library for Windows.
99
100%description dll -l pl.UTF-8
101Biblioteka DLL freetype dla Windows.
3294533f 102
103%prep
8bddf7fd 104%setup -q -n %{realname}-%{version}
3294533f 105
106%build
107CFLAGS="%{rpmcflags} \
1c57a66b
JB
108%{?with_lcd:-DFT_CONFIG_OPTION_SUBPIXEL_RENDERING} \
109-DTT_CONFIG_OPTION_SUBPIXEL_HINTING \
110" \
3294533f 111%configure \
3294533f 112 --target=%{target} \
6181c873 113 --build=i686-pc-linux-gnu \
114 --host=%{target} \
115 --enable-shared
3294533f 116
117%{__make}
118
119%install
120rm -rf $RPM_BUILD_ROOT
3294533f 121
122%{__make} install \
123 DESTDIR=$RPM_BUILD_ROOT
124
1e7243e1 125install -d $RPM_BUILD_ROOT%{_dlldir}
8bddf7fd 126mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
1e7243e1
JB
127
128%if 0%{!?debug:1}
129%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
130%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
131%endif
132
133rm -rf $RPM_BUILD_ROOT%{_datadir}/aclocal
134
3294533f 135%clean
136rm -rf $RPM_BUILD_ROOT
137
138%files
139%defattr(644,root,root,755)
0443e0ca 140%doc docs/{CHANGES,FTL.TXT,LICENSE.TXT,TODO,formats.txt,raster.txt}
1e7243e1
JB
141%{_libdir}/libfreetype.dll.a
142%{_libdir}/libfreetype.la
3294533f 143%{_includedir}/freetype2
5bc110d4
JB
144%{_includedir}/ft2build.h
145%{_pkgconfigdir}/freetype2.pc
1e7243e1
JB
146
147%files static
148%defattr(644,root,root,755)
149%{_libdir}/libfreetype.a
150
151%files dll
152%defattr(644,root,root,755)
8bddf7fd 153%{_dlldir}/libfreetype-*.dll
This page took 0.069253 seconds and 4 git commands to generate.