]> git.pld-linux.org Git - packages/crossmingw32-binutils.git/blob - crossmingw32-binutils.spec
- updated to 2.40
[packages/crossmingw32-binutils.git] / crossmingw32-binutils.spec
1 Summary:        Cross MinGW32 GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - MinGW32 binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - MinGW32 binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla MinGW32 - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - MinGW32 binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - MinGW32 binutils
7 Name:           crossmingw32-binutils
8 Version:        2.40
9 Release:        1
10 License:        GPL v3+
11 Group:          Development/Tools
12 Source0:        https://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.lz
13 # Source0-md5:  be3411283c27eb0984104a2fda12e102
14 URL:            http://www.sourceware.org/binutils/
15 BuildRequires:  autoconf >= 2.69
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  bash
18 BuildRequires:  bison
19 BuildRequires:  flex
20 BuildRequires:  gettext-tools
21 BuildRequires:  lzip
22 BuildRequires:  perl-tools-pod
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  texinfo >= 6.3
25 BuildRequires:  zstd-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         target          i386-mingw32
29 %define         arch            %{_prefix}/%{target}
30
31 %description
32 crossmingw32 is a complete cross-compiling development system for
33 building stand-alone Microsoft Windows applications under Linux using
34 the MinGW32 build libraries. This includes a binutils, gcc with g++
35 and objc, and libstdc++, all cross targeted to i386-mingw32, along
36 with supporting Win32 libraries in 'coff' format from free sources.
37
38 This package contains cross targeted binutils.
39
40 %description -l pl.UTF-8
41 crossmingw32 jest kompletnym systemem do kroskompilacji, pozwalającym
42 budować aplikacje MS Windows pod Linuksem używając bibliotek MinGW32.
43 System składa się z binutils, gcc z g++ i objc, libstdc++ - wszystkie
44 generujące kod dla platformy i386-mingw32, oraz z bibliotek w formacie
45 COFF.
46
47 Ten pakiet zawiera binutils generujące skrośnie binaria dla Win32.
48
49 %prep
50 %setup -q -n binutils-%{version}
51
52 # file contains hacks for ac 2.69 only
53 %{__rm} config/override.m4
54 %{__sed} -i '/^m4_include(config\/override\.m4/d' configure.ac
55
56 %build
57 cp -f /usr/share/automake/config.* .
58 %{__aclocal}
59 %{__autoconf}
60
61 # non-standard regeneration (needed because of libdir patch)
62 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
63 for dir in gas bfd; do
64         cd $dir || exit 1
65         %{__aclocal} -I .. -I ../config -I ../bfd
66         %{__automake} Makefile
67         test -f doc/Makefile.am && %{__automake} doc/Makefile
68         %{__autoconf}
69         cd ..
70 done
71
72 # We don't install libbfd (nor use shared binutils libraries) to avoid
73 # conflict with native binutils.
74
75 # ldscripts won't be generated properly if SHELL is not bash...
76 CFLAGS="%{rpmcflags}" \
77 LDFLAGS="%{rpmldflags}" \
78 CONFIG_SHELL="/bin/bash" \
79 ./configure \
80         --disable-nls \
81         --disable-shared \
82         --disable-silent-rules \
83         --prefix=%{_prefix} \
84         --libdir=%{_libdir} \
85         --mandir=%{_mandir} \
86         --infodir=%{_infodir} \
87         --host=%{_target_platform} \
88         --build=%{_target_platform} \
89         --target=%{target}
90
91 %{__make} all \
92         tooldir=%{_prefix}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install \
98         INSTALL='$$s/install-sh -c' \
99         prefix=$RPM_BUILD_ROOT%{_prefix} \
100         mandir=$RPM_BUILD_ROOT%{_mandir} \
101         infodir=$RPM_BUILD_ROOT%{_infodir} \
102         libdir=$RPM_BUILD_ROOT%{_libdir}
103
104 %{__rm} $RPM_BUILD_ROOT%{_libdir}/bfd-plugins/*.a
105
106 # not prefixed, keep infos only from native packages
107 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}
108
109 # "filesystem" for crossmingw32-* packages (move to crossmingw32-dirs?)
110 install -d $RPM_BUILD_ROOT%{arch}/lib/pkgconfig
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %files
116 %defattr(644,root,root,755)
117 %doc README
118 # mingw32 directory tree
119 %dir %{arch}
120 %dir %{arch}/lib
121 %dir %{arch}/lib/pkgconfig
122 %dir %{arch}/bin
123 # binutils files
124 %attr(755,root,root) %{arch}/bin/ar
125 %attr(755,root,root) %{arch}/bin/as
126 %attr(755,root,root) %{arch}/bin/dlltool
127 %attr(755,root,root) %{arch}/bin/ld
128 %attr(755,root,root) %{arch}/bin/ld.bfd
129 %attr(755,root,root) %{arch}/bin/nm
130 %attr(755,root,root) %{arch}/bin/objcopy
131 %attr(755,root,root) %{arch}/bin/objdump
132 %attr(755,root,root) %{arch}/bin/ranlib
133 %attr(755,root,root) %{arch}/bin/readelf
134 %attr(755,root,root) %{arch}/bin/strip
135 %{arch}/lib/ldscripts
136 %attr(755,root,root) %{_bindir}/%{target}-addr2line
137 %attr(755,root,root) %{_bindir}/%{target}-ar
138 %attr(755,root,root) %{_bindir}/%{target}-as
139 %attr(755,root,root) %{_bindir}/%{target}-c++filt
140 %attr(755,root,root) %{_bindir}/%{target}-dlltool
141 %attr(755,root,root) %{_bindir}/%{target}-dllwrap
142 %attr(755,root,root) %{_bindir}/%{target}-elfedit
143 %attr(755,root,root) %{_bindir}/%{target}-gprof
144 %attr(755,root,root) %{_bindir}/%{target}-ld
145 %attr(755,root,root) %{_bindir}/%{target}-ld.bfd
146 %attr(755,root,root) %{_bindir}/%{target}-nm
147 %attr(755,root,root) %{_bindir}/%{target}-objcopy
148 %attr(755,root,root) %{_bindir}/%{target}-objdump
149 %attr(755,root,root) %{_bindir}/%{target}-ranlib
150 %attr(755,root,root) %{_bindir}/%{target}-readelf
151 %attr(755,root,root) %{_bindir}/%{target}-size
152 %attr(755,root,root) %{_bindir}/%{target}-strings
153 %attr(755,root,root) %{_bindir}/%{target}-strip
154 %attr(755,root,root) %{_bindir}/%{target}-windmc
155 %attr(755,root,root) %{_bindir}/%{target}-windres
156 %{_mandir}/man1/%{target}-addr2line.1*
157 %{_mandir}/man1/%{target}-ar.1*
158 %{_mandir}/man1/%{target}-as.1*
159 %{_mandir}/man1/%{target}-c++filt.1*
160 %{_mandir}/man1/%{target}-dlltool.1*
161 %{_mandir}/man1/%{target}-elfedit.1*
162 %{_mandir}/man1/%{target}-gprof.1*
163 %{_mandir}/man1/%{target}-ld.1*
164 %{_mandir}/man1/%{target}-nm.1*
165 %{_mandir}/man1/%{target}-objcopy.1*
166 %{_mandir}/man1/%{target}-objdump.1*
167 %{_mandir}/man1/%{target}-ranlib.1*
168 %{_mandir}/man1/%{target}-readelf.1*
169 %{_mandir}/man1/%{target}-size.1*
170 %{_mandir}/man1/%{target}-strings.1*
171 %{_mandir}/man1/%{target}-strip.1*
172 %{_mandir}/man1/%{target}-windmc.1*
173 %{_mandir}/man1/%{target}-windres.1*
This page took 0.126617 seconds and 3 git commands to generate.