]> git.pld-linux.org Git - packages/cogl.git/blob - cogl.spec
518a66ff7dd04d50a21b5d3bf4fa3539a43b8dbd
[packages/cogl.git] / cogl.spec
1 #
2 # Conditional build
3 %bcond_without  static_libs     # static libraries
4 #
5 Summary:        A library for using 3D graphics hardware to draw pretty pictures
6 Summary(pl.UTF-8):      Biblioteka do rysowania ładnych obrazków przy użyciu sprzętowej grafiki 3D
7 Name:           cogl
8 Version:        1.12.0
9 Release:        1
10 License:        LGPL v2+
11 Group:          Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/cogl/1.12/%{name}-%{version}.tar.xz
13 # Source0-md5:  2ec55647764ee208182fbe07ee9f7e9c
14 # https://bugzilla.gnome.org/show_bug.cgi?id=684731
15 Patch0:         %{name}-fix-experimental-doc-build.patch
16 URL:            http://www.clutter-project.org/
17 BuildRequires:  OpenGL-GLX-devel
18 BuildRequires:  autoconf >= 2.59
19 BuildRequires:  automake >= 1:1.11
20 BuildRequires:  cairo-devel >= 1.10
21 BuildRequires:  gdk-pixbuf2-devel
22 BuildRequires:  gettext-devel >= 0.18.1
23 BuildRequires:  glib2-devel >= 1:2.28.0
24 BuildRequires:  gobject-introspection-devel >= 0.9.5
25 BuildRequires:  gtk-doc >= 1.13
26 BuildRequires:  libdrm-devel
27 BuildRequires:  libtool >= 2:2.2.6
28 BuildRequires:  pango-devel >= 1:1.20
29 BuildRequires:  pkgconfig
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xorg-lib-libX11-devel
32 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.4
33 BuildRequires:  xorg-lib-libXdamage-devel
34 BuildRequires:  xorg-lib-libXext-devel
35 BuildRequires:  xorg-lib-libXfixes-devel >= 3
36 BuildRequires:  xz
37 Requires:       cairo >= 1.10
38 Requires:       glib2 >= 1:2.28.0
39 Requires:       pango >= 1:1.20
40 Requires:       xorg-lib-libXcomposite >= 0.4
41 Requires:       xorg-lib-libXfixes >= 3
42 Suggests:       OpenGL
43 Conflicts:      clutter < 1.8.0
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Cogl is a small open source library for using 3D graphics hardware to
48 draw pretty pictures. The API departs from the flat state machine
49 style of OpenGL and is designed to make it easy to write orthogonal
50 components that can render without stepping on each others toes.
51
52 %description -l pl.UTF-8
53 Cogl to mała biblioteka o otwartych źródłach, pozwalająca na rysowanie
54 ładnych rysunków przy użyciu sprzętu graficznego 3D. API wywodzi się z
55 automatu skończonego w stylu OpenGL i zostało tak zaprojektowane, aby
56 ułatwić pisanie ortogonalnych komponentów, potrafiących renderować bez
57 przeszkadzania sobie nawzajem.
58
59 %package devel
60 Summary:        Header files for cogl library
61 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cogl
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       cairo-devel >= 1.10
65 Requires:       glib2-devel >= 1:2.28.0
66 Requires:       gobject-introspection-devel >= 0.9.5
67 Requires:       libdrm-devel
68 Requires:       pango-devel >= 1:1.20
69 Requires:       xorg-lib-libXcomposite-devel >= 0.4
70 Requires:       xorg-lib-libXdamage-devel
71 Requires:       xorg-lib-libXext-devel
72 Requires:       xorg-lib-libXfixes-devel >= 3
73 Conflicts:      clutter-devel < 1.8.0
74
75 %description devel
76 Header files for building and developing applications with cogl.
77
78 %description devel -l pl.UTF-8
79 Pliki nagłówkowe do tworzenia aplikacji z użyciem biblioteki cogl.
80
81 %package static
82 Summary:        Static cogl libraries
83 Summary(pl.UTF-8):      Statyczne biblioteki cogl
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86 Conflicts:      clutter-static < 1.8.0
87
88 %description static
89 Static cogl libraries.
90
91 %description static -l pl.UTF-8
92 Statyczne biblioteki cogl.
93
94 %package doc
95 Summary:        API documentation for cogl
96 Summary(pl.UTF-8):      Dokumentacja API cogl
97 Group:          Documentation
98
99 %description doc
100 This package contains API documentation for cogl.
101
102 %description doc -l pl.UTF-8
103 Ten pakiet zawiera dokumentację API cogl.
104
105 %prep
106 %setup -q
107 %patch0 -p1
108
109 %build
110 %{__gettextize}
111 %{__libtoolize}
112 %{__aclocal} -I build/autotools
113 %{__autoconf}
114 %{__autoheader}
115 %{__automake}
116 %configure \
117         --disable-gdk-pixbuf \
118         --disable-silent-rules \
119         --enable-cairo \
120         --enable-cogl-pango \
121         --enable-glx \
122         --enable-gtk-doc \
123         --enable-introspection \
124         %{?with_static_libs:--enable-static} \
125         --with-html-dir=%{_gtkdocdir}
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 # obsoleted by pkg-config
135 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcogl.la
136 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcogl-pango.la
137
138 %find_lang %{name}
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %files -f %{name}.lang
147 %defattr(644,root,root,755)
148 %doc ChangeLog NEWS README
149 %attr(755,root,root) %{_libdir}/libcogl.so.*.*.*
150 %attr(755,root,root) %ghost %{_libdir}/libcogl.so.11
151 %attr(755,root,root) %{_libdir}/libcogl-pango.so.*.*.*
152 %attr(755,root,root) %ghost %{_libdir}/libcogl-pango.so.0
153 %{_libdir}/girepository-1.0/Cogl-1.0.typelib
154 %{_libdir}/girepository-1.0/CoglPango-1.0.typelib
155
156 %files devel
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_libdir}/libcogl.so
159 %attr(755,root,root) %{_libdir}/libcogl-pango.so
160 %{_includedir}/cogl
161 %{_pkgconfigdir}/cogl-1.0.pc
162 %{_pkgconfigdir}/cogl-2.0-experimental.pc
163 %{_pkgconfigdir}/cogl-gl-1.0.pc
164 %{_pkgconfigdir}/cogl-pango-1.0.pc
165 %{_pkgconfigdir}/cogl-pango-2.0-experimental.pc
166 %{_datadir}/gir-1.0/Cogl-1.0.gir
167 %{_datadir}/gir-1.0/CoglPango-1.0.gir
168
169 %if %{with static_libs}
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/libcogl.a
173 %{_libdir}/libcogl-pango.a
174 %endif
175
176 %files doc
177 %defattr(644,root,root,755)
178 %{_gtkdocdir}/cogl
179 %{_gtkdocdir}/cogl-2.0-experimental
This page took 0.096657 seconds and 2 git commands to generate.