]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
2fc04ab40fa4ad2af2df794a9cf1dc5cdad205c7
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_without  libjpegturbo    # use libjpeg-turbo features
9 %bcond_without  nacl                    # build Native Client support
10 %bcond_without  pulseaudio              # with pulseaudio
11 %bcond_without  sandboxing              # with sandboxing
12 %bcond_with             selinux                 # with SELinux (need policy first)
13 %bcond_with             shared_libs             # with shared libs
14 %bcond_with             sse2                    # use SSE2 instructions
15 %bcond_without  system_flac             # system flac
16 %bcond_without  system_ffmpeg   # system ffmpeg instead of ffmpegsumo
17 %bcond_without  system_harfbuzz # system harfbuzz
18 %bcond_without  system_jsoncpp  # system jsoncpp
19 %bcond_without  system_libexif  # system libexif
20 %bcond_without  system_libmtp   # system libmtp
21 %bcond_without  system_libusb   # system libusb-1
22 %bcond_without  system_libwebp  # system libwebp
23 %bcond_without  system_libxnvctrl       # system libxnvctrl
24 %bcond_without  system_minizip  # system minizip
25 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
26 %bcond_without  system_protobuf # system protobuf
27 %bcond_without  system_speex    # system speex
28 %bcond_with             system_sqlite   # system sqlite
29 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
30 %bcond_with             system_v8               # system v8
31 %bcond_without  system_libvpx   # system libvpx
32 %bcond_without  system_yasm             # system yasm
33 %bcond_without  system_zlib             # system zlib
34 %bcond_without  tcmalloc                # use tcmalloc
35 %bcond_without  verbose                 # verbose build (V=1)
36
37 # TODO
38 # - check system sqlite linking problems
39 # - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
40 # - use_system_ssl (use_openssl: http://crbug.com/62803)
41 # - use_system_hunspell
42 # - use_system_stlport
43 # - other defaults: src/build/common.gypi
44
45 # NOTES:
46 # - mute BEEP mixer if you do not want to hear horrible system bell when
47 #   pressing home/end in url bar or more ^F search results on page.
48 # - space considerations:
49 #   - unpacked sources: ~490MiB
50 #   - built code: ~1.4GiB (x86_64/i686)
51 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
52 # - to look for new tarball, use update-source.sh script
53
54 # NOTE TO USERS:
55 # To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
56 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
57 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
58
59 %define         gyp_rev 1014
60 Summary:        A WebKit powered web browser
61 Name:           chromium-browser
62 Version:        25.0.1364.45
63 Release:        0.25
64 License:        BSD, LGPL v2+ (ffmpeg)
65 Group:          X11/Applications/Networking
66 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{version}.tar.gz
67 # Source0-md5:  2995d5aa3f1ecb470e60e0984229fcce
68 Source1:        %{name}.default
69 Source2:        %{name}.sh
70 Source3:        %{name}.desktop
71 Source5:        find-lang.sh
72 Source6:        update-source.sh
73 Source7:        clean-source.sh
74 Source8:        get-source.sh
75 Source9:        master_preferences.json
76 Patch1:         plugin-searchdirs.patch
77 #Patch2:                system-nspr.patch
78 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
79 Patch4:         path-libpdf.patch
80 Patch6:         get-webkit_revision.patch
81 Patch7:         dlopen_sonamed_gl.patch
82 Patch8:         chromium_useragent.patch.in
83 Patch9:         chromium-ppapi.patch
84 Patch10:        system-libxnvctrl.patch
85 # https://bugs.gentoo.org/show_bug.cgi?id=393471
86 # libjpeg-turbo >= 1.1.90 supports that feature
87 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
88 Patch12:        system-ffmpeg.patch
89 Patch13:        system-libpng.patch
90 Patch14:        system-opus.patch
91 Patch15:        nacl-build-irt.patch
92 Patch16:        nacl-linkingfix.patch
93 Patch18:        nacl-no-untar.patch
94 Patch19:        system-jsoncpp.patch
95 Patch23:        no-pnacl.patch
96 Patch24:        nacl-verbose.patch
97 Patch25:        gnome3-volume-control.patch
98 Patch26:        master-prefs-path.patch
99 Patch27:        tcmalloc-glibc2.16.patch
100 URL:            http://www.chromium.org/Home
101 %{?with_gconf:BuildRequires:    GConf2-devel}
102 BuildRequires:  alsa-lib-devel
103 BuildRequires:  atk-devel
104 BuildRequires:  bison
105 BuildRequires:  bzip2-devel
106 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
107 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
108 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
109 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
110 %{?with_cups:BuildRequires:     cups-devel}
111 BuildRequires:  elfutils-devel
112 BuildRequires:  expat-devel
113 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
114 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
115 BuildRequires:  fontconfig-devel
116 BuildRequires:  glib2-devel
117 BuildRequires:  gperf
118 BuildRequires:  gtest-devel
119 BuildRequires:  gtk+2-devel
120 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
121 %{?with_kerberos:BuildRequires: heimdal-devel}
122 BuildRequires:  hicolor-icon-theme
123 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
124 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
125 BuildRequires:  libevent-devel
126 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
127 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
128 BuildRequires:  libicu-devel >= 4.6
129 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
130 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
131 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
132 BuildRequires:  libpng-devel
133 %{?with_selinux:BuildRequires:  libselinux-devel}
134 BuildRequires:  libstdc++-devel
135 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
136 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
137 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
138 BuildRequires:  libxml2-devel
139 BuildRequires:  libxslt-devel
140 %{?with_system_minizip:BuildRequires:   minizip-devel}
141 BuildRequires:  nspr-devel
142 BuildRequires:  nss-devel >= 1:3.12.3
143 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
144 BuildRequires:  pam-devel
145 BuildRequires:  pango-devel
146 BuildRequires:  pciutils-devel
147 BuildRequires:  perl-modules
148 BuildRequires:  pkgconfig
149 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
150 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
151 BuildRequires:  python
152 #BuildRequires: python-gyp >= 1-%{gyp_rev}
153 BuildRequires:  python-modules
154 BuildRequires:  python-ply
155 BuildRequires:  rpm >= 4.4.9-56
156 BuildRequires:  rpmbuild(macros) >= 1.453
157 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
158 BuildRequires:  sqlite3-devel >= 3.6.1
159 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
160 BuildRequires:  subversion
161 BuildRequires:  tar >= 1:1.22
162 BuildRequires:  udev-devel
163 BuildRequires:  usbutils
164 BuildRequires:  util-linux
165 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
166 BuildRequires:  which
167 BuildRequires:  xorg-lib-libXScrnSaver-devel
168 BuildRequires:  xz
169 %{?with_system_yasm:BuildRequires:      yasm}
170 %{?with_system_zlib:BuildRequires:      zlib-devel}
171 Requires:       browser-plugins >= 2.0
172 Requires:       desktop-file-utils
173 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
174 Requires:       hicolor-icon-theme
175 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
176 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
177 Requires:       xdg-utils >= 1.0.2-4
178 Provides:       wwwbrowser
179 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
180 Obsoletes:      chromium-browser-inspector < 15.0.863.0
181 ExclusiveArch:  %{ix86} %{x8664} arm
182 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
183
184 %define         find_lang       sh find-lang.sh %{buildroot}
185
186 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
187 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
188
189 %if %{without debuginfo}
190 %define         _enable_debug_packages  0
191 %endif
192
193 %description
194 Chromium is an open-source browser project that aims to build a safer,
195 faster, and more stable way for all Internet users to experience the
196 web.
197
198 Chromium serves as a base for Google Chrome, which is Chromium
199 rebranded (name and logo) with very few additions such as usage
200 tracking and an auto-updater system.
201
202 %package l10n
203 Summary:        chromium-browser language packages
204 Group:          I18n
205 Requires:       %{name} = %{version}-%{release}
206
207 %description l10n
208 Chromium is an open-source browser project that aims to build a safer,
209 faster, and more stable way for all Internet users to experience the
210 web.
211
212 This package contains language packages for 50 languages:
213
214 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
215 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
216 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
217 zh-TW
218
219 %prep
220 %setup -q
221
222 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
223 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
224 . ./src/chrome/VERSION
225 ver=$MAJOR.$MINOR.$BUILD.$PATCH
226 test "$ver" = %{version}
227
228 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
229 test "$gyp_rev" = %{gyp_rev} || :
230
231 v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
232
233 # add chromium and pld to useragent
234 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
235 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
236     -e 's/@BUILD_DIST_NAME@/PLD/g' \
237     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
238     < %{PATCH8} | %{__patch} -p1
239
240 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
241 ln -s %{SOURCE7} src
242
243 %patch1 -p1
244 %patch3 -p1
245 %patch4 -p1
246 %patch6 -p1
247 %patch7 -p1
248 %patch10 -p1
249 %patch15 -p1
250 cd src
251 %patch9 -p0
252 #%patch2 -p1
253 %{!?with_libjpegturbo:%patch11 -p0}
254 %patch12 -p1
255 %patch13 -p0
256 %patch14 -p2
257 %patch16 -p1
258 %patch19 -p1
259 %patch25 -p1
260 %patch27 -p1
261 cd ..
262 %patch18 -p1
263 %patch23 -p1
264 %patch24 -p1
265 %patch26 -p1
266
267 cd src
268
269 # Missing gyp files in tarball.
270 # https://code.google.com/p/chromium/issues/detail?id=144823
271 if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
272         echo "tarball fixed, please remove workaround"
273         exit 1
274 fi
275
276 install -d chrome/test/data/nacl
277 cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
278 {
279  'targets': [
280    {
281      'target_name': 'nacl_tests',
282      'type': 'none',
283    },
284  ],
285 }
286 EOF
287
288 sh -x clean-source.sh \
289         %{!?with_nacl:nacl=0} \
290         %{!?with_system_protobuf:protobuf=0} \
291         %{!?with_system_v8:v8=0} \
292         %{!?with_system_zlib:zlib=0} \
293         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
294         %{nil}
295
296 %build
297 cd src
298
299 %if %{with nacl}
300 rm -rf native_client/toolchain/linux_x86_newlib
301 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
302 # Make symlinks for NaCL
303 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
304
305 cd native_client/toolchain/linux_x86_newlib
306 ln -s x86_64-nacl/bin bin
307 cd x86_64-nacl/bin
308 __cc='%{__cc}'
309 if [ "${__cc#ccache}" != "$__cc" ]; then
310         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
311         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
312         %{__sed} -i -e '1i#!/bin/sh' gcc g++
313         chmod +x gcc g++
314 else
315         ln -s %{_bindir}/x86_64-nacl-gcc gcc
316         ln -s %{_bindir}/x86_64-nacl-g++ g++
317 fi
318 ln -s gcc x86_64-nacl-gcc
319 ln -s g++ x86_64-nacl-g++
320 ln -s %{_bindir}/x86_64-nacl-ar .
321 ln -s %{_bindir}/x86_64-nacl-ar ar
322 ln -s %{_bindir}/x86_64-nacl-as as
323 ln -s %{_bindir}/x86_64-nacl-ranlib .
324 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
325 ln -s %{_bindir}/x86_64-nacl-strip .
326 ln -s %{_bindir}/x86_64-nacl-strip strip
327 ln -s %{_prefix}/x86_64-nacl/lib ../lib
328 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
329 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
330 cd ../../../../..
331 fi
332 %endif
333
334 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
335 test -e Makefile || \
336         CC="%{__cc}" \
337         CXX="%{__cxx}" \
338         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
339         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
340         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
341 %{__python} build/gyp_chromium \
342         --format=make \
343         -Goutput_dir=../out \
344         build/all.gyp \
345 %ifarch %{ix86}
346         -Dtarget_arch=ia32 \
347 %endif
348 %ifarch %{x8664}
349         -Dtarget_arch=x64 \
350 %endif
351 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
352         -Dno_strict_aliasing=1 -Dgcc_version=44 \
353 %endif
354 %if %{with sandboxing}
355         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
356         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
357 %endif
358         %{!?debug:-Dwerror=} \
359         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
360         %{?with_shared_libs:-Dlibrary=shared_library} \
361         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
362         -Dinclude_tests=0 \
363 %if %{with nacl}
364         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
365         -Ddisable_glibc_untar=1 \
366         -Ddisable_newlib_untar=1 \
367         -Ddisable_glibc=1 \
368         -Ddisable_pnacl=1 \
369         -Dbuild_pnacl_newlib=0 \
370 %else
371         -Ddisable_pnacl_untar=1 \
372         -Ddisable_nacl=1 \
373 %endif
374         %{!?with_sse2:-Ddisable_sse2=1} \
375         %{?with_selinux:-Dselinux=1} \
376         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
377         -Dlinux_link_libpci=1 \
378         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
379         -Dlinux_use_gold_binary=0 \
380         -Dlinux_use_gold_flags=0 \
381         %{gyp_with cups} \
382         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
383         %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
384         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
385         %{gyp_with pulseaudio} \
386         %{gyp_with system_ffmpeg} \
387         %{gyp_with system_flac} \
388         %{gyp_with system_harfbuzz} \
389         %{gyp_with system_libexif} \
390         %{gyp_with system_libmtp} \
391         %{gyp_with system_libsrtp} \
392         %{gyp_with system_libusb} \
393         %{gyp_with system_libvpx} \
394         %{gyp_with system_libwebp} \
395         %{gyp_with system_libxnvctrl} \
396         %{gyp_with system_minizip} \
397         %{gyp_with system_opus} \
398         %{gyp_with system_protobuf} \
399         %{gyp_with system_speex} \
400         %{gyp_with system_sqlite} \
401         %{gyp_with system_v8} \
402         %{gyp_with system_yasm} \
403         %{gyp_with system_zlib} \
404         -Duse_system_bzip2=1 \
405         -Duse_system_expat=1 \
406         -Duse_system_icu=1 \
407         -Duse_system_libevent=1 \
408         -Duse_system_libjpeg=1 \
409         -Duse_system_libpng=1 \
410         -Duse_system_libxml=1 \
411         -Duse_system_libxslt=1 \
412         -Duse_system_xdg_utils=1 \
413
414 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
415 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
416         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
417         %{?with_verbose:V=1} \
418         CC.host="%{__cc}" \
419         CXX.host="%{__cxx}" \
420         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
421
422 %install
423 rm -rf $RPM_BUILD_ROOT
424 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
425         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
426
427 cd out/%{!?debug:Release}%{?debug:Debug}
428 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
429 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
430 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
431 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
432 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
433 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
434 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
435 %if %{without system_ffmpeg}
436 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
437 %endif
438 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
439 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
440
441 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
442
443 %if %{with nacl}
444 # Install Native Client files on platforms that support it.
445 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
446 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
447 %ifarch %{x8664}
448 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
449 %endif
450 %ifarch %{ix86}
451 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
452 %endif
453 %endif
454
455 cd -
456
457 for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
458         size=${icon##*/product_logo_}
459         size=${size%.png}
460
461         # this will skip non-numeric (22_mono_invert, 22_mono)
462         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
463         test -d "$dir" || continue
464
465         install -d $RPM_BUILD_ROOT$dir
466         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
467 done
468
469 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
470 # http://code.google.com/p/chromium/issues/detail?id=24507
471 gecko-mediaplayer*.so
472 EOF
473
474 # find locales
475 %find_lang %{name}.lang
476 # always package en-US
477 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
478
479 %clean
480 rm -rf $RPM_BUILD_ROOT
481
482 %post
483 %update_icon_cache hicolor
484 %update_desktop_database
485 %update_browser_plugins
486
487 %postun
488 if [ "$1" = 0 ]; then
489         %update_icon_cache hicolor
490         %update_browser_plugins
491 fi
492
493 %files
494 %defattr(644,root,root,755)
495 %doc src/{AUTHORS,LICENSE}
496 %{_browserpluginsconfdir}/browsers.d/%{name}.*
497 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
498 %dir %{_sysconfdir}/%{name}
499 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
500 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
501 %attr(755,root,root) %{_bindir}/%{name}
502 %{_mandir}/man1/%{name}.1*
503 %{_desktopdir}/*.desktop
504 %{_iconsdir}/hicolor/*/apps/%{name}.png
505 %dir %{_libdir}/%{name}
506 %{_libdir}/%{name}/chrome*.pak
507 %{_libdir}/%{name}/content_resources.pak
508 %{_libdir}/%{name}/resources.pak
509 %dir %{_libdir}/%{name}/locales
510 %{_libdir}/%{name}/locales/en-US.pak
511 %dir %{_libdir}/%{name}/resources
512 %{_libdir}/%{name}/resources/inspector
513 %dir %{_libdir}/%{name}/themes
514 %dir %{_libdir}/%{name}/extensions
515 %dir %{_libdir}/%{name}/plugins
516 %attr(755,root,root) %{_libdir}/%{name}/%{name}
517 # These unique permissions are intentional and necessary for the sandboxing
518 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
519
520 # ffmpeg libs
521 %if %{without system_ffmpeg}
522 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
523 %endif
524
525 %if %{with nacl}
526 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
527 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
528 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
529 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
530 %endif
531
532 %files l10n -f %{name}.lang
533 %defattr(644,root,root,755)
This page took 0.094898 seconds and 2 git commands to generate.