]> git.pld-linux.org Git - packages/boost.git/blob - boost.spec
9f3390427f0ac1b520ffb984a6c992cd9b1a1519
[packages/boost.git] / boost.spec
1 #
2 # TODO:
3 #       - think about building MPI.
4 #       - split shared libs from core package into -iostreams/-serialization.
5 #
6 # Conditional build:
7 %bcond_without  python  # without boost-python support
8
9 %define         fver    %(echo %{version} | tr . _)
10 Summary:        The Boost C++ Libraries
11 Summary(pl.UTF-8):      Biblioteki C++ "Boost"
12 Name:           boost
13 Version:        1.56.0
14 Release:        2
15 License:        Boost Software License and others
16 Group:          Libraries
17 Source0:        http://downloads.sourceforge.net/boost/%{name}_%{fver}.tar.bz2
18 # Source0-md5:  a744cf167b05d72335f27c88115f211d
19 Patch0:         %{name}-link.patch
20 # FC Patches:
21 # https://svn.boost.org/trac/boost/ticket/5637
22 Patch203:       %{name}-1.54.0-mpl-print.patch
23 # https://svn.boost.org/trac/boost/ticket/8870
24 Patch211:       %{name}-1.54.0-spirit-unused_typedef.patch
25 Patch212:       %{name}-1.54.0-spirit-unused_typedef-2.patch
26 # https://svn.boost.org/trac/boost/ticket/8871
27 Patch213:       %{name}-1.54.0-numeric-unused_typedef.patch
28 # https://svn.boost.org/trac/boost/ticket/8878
29 Patch218:       %{name}-1.54.0-locale-unused_typedef.patch
30 # https://svn.boost.org/trac/boost/ticket/8881
31 Patch221:       %{name}-1.54.0-mpi-unused_typedef.patch
32 # https://svn.boost.org/trac/boost/ticket/8888
33 Patch222:       %{name}-1.54.0-python-unused_typedef.patch
34 # https://svn.boost.org/trac/boost/ticket/9038
35 Patch224:       %{name}-1.54.0-pool-test_linking.patch
36 URL:            http://www.boost.org/
37 BuildRequires:  bzip2-devel
38 BuildRequires:  expat-devel
39 BuildRequires:  libicu-devel
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  perl-base
42 %{?with_python:BuildRequires:   python-devel >= 2.2}
43 BuildRequires:  rpm-pythonprov
44 BuildRequires:  zlib-devel
45 BuildConflicts: gcc = 5:3.3.1
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         specflags       -DBOOST_IOSTREAMS_USE_DEPRECATED=1
49
50 %description
51 The Boost web site provides free peer-reviewed portable C++ source
52 libraries. The emphasis is on libraries which work well with the C++
53 Standard Library. One goal is to establish "existing practice" and
54 provide reference implementations so that the Boost libraries are
55 suitable for eventual standardization. Some of the libraries have
56 already been proposed for inclusion in the C++ Standards Committee's
57 upcoming C++ Standard Library Technical Report.
58
59 %description -l pl.UTF-8
60 Strona http://www.boost.org/ dostarcza darmowe biblioteki C++ wraz z
61 kodem źródłowym. Nacisk położono na biblioteki, które dobrze
62 współpracują ze standardową biblioteką C++. Celem jest ustanowienie
63 "istniejącej praktyki" i dostarczenie implementacji, tak że biblioteki
64 "Boost" nadają się do ewentualnej standaryzacji. Niektóre z bibliotek
65 już zostały zgłoszone do komitetu standaryzacyjnego C++ w nadchodzącym
66 Raporcie Technicznym Biblioteki Standardowej C++.
67
68 %package devel
69 Summary:        Boost C++ development headers
70 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek C++ Boost
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       %{name}-chrono = %{version}-%{release}
74 Requires:       %{name}-context = %{version}-%{release}
75 Requires:       %{name}-date_time = %{version}-%{release}
76 Requires:       %{name}-filesystem = %{version}-%{release}
77 Requires:       %{name}-graph = %{version}-%{release}
78 Requires:       %{name}-locale = %{version}-%{release}
79 Requires:       %{name}-log = %{version}-%{release}
80 Requires:       %{name}-program_options = %{version}-%{release}
81 Requires:       %{name}-regex = %{version}-%{release}
82 Requires:       %{name}-signals = %{version}-%{release}
83 Requires:       %{name}-system = %{version}-%{release}
84 Requires:       %{name}-test = %{version}-%{release}
85 Requires:       %{name}-thread = %{version}-%{release}
86 Requires:       %{name}-timer = %{version}-%{release}
87 Requires:       %{name}-wave = %{version}-%{release}
88 Requires:       libstdc++-devel
89 Obsoletes:      boost-any-devel
90 Obsoletes:      boost-array-devel
91 Obsoletes:      boost-asio
92 Obsoletes:      boost-bind-devel
93 Obsoletes:      boost-call_traits-devel
94 Obsoletes:      boost-compatibility-devel
95 Obsoletes:      boost-compose-devel
96 Obsoletes:      boost-compressed_pair-devel
97 Obsoletes:      boost-concept_check-devel
98 Obsoletes:      boost-conversion-devel
99 Obsoletes:      boost-crc-devel
100 Obsoletes:      boost-date_time-devel
101 Obsoletes:      boost-filesystem-devel
102 Obsoletes:      boost-graph-devel
103 Obsoletes:      boost-mem_fn-devel
104 Obsoletes:      boost-mpl-devel
105 Obsoletes:      boost-preprocessor-devel
106 Obsoletes:      boost-program_options-devel
107 Obsoletes:      boost-ref-devel
108 Obsoletes:      boost-regex-devel
109 Obsoletes:      boost-signals-devel
110 Obsoletes:      boost-spirit-devel
111 Obsoletes:      boost-statechart-devel
112 Obsoletes:      boost-static_assert-devel
113 Obsoletes:      boost-test-devel
114 Obsoletes:      boost-thread-devel
115 Obsoletes:      boost-tr1-devel
116 Obsoletes:      boost-type_traits-devel
117 Obsoletes:      boost-typeof-devel
118 Obsoletes:      boost-uBLAS-devel
119 Obsoletes:      boost-utility-devel
120 Obsoletes:      boost-wave-devel
121 Obsoletes:      boost-xpressive-devel
122
123 %description devel
124 Header files for the Boost C++ libraries.
125
126 %description devel -l pl.UTF-8
127 Pliki nagłówkowe bibliotek C++ Boost.
128
129 %package static
130 Summary:        Static version of base Boost C++ libraries
131 Summary(pl.UTF-8):      Statyczne wersje podstawowych bibliotek C++ Boost
132 Group:          Development/Libraries
133 Requires:       %{name}-devel = %{version}-%{release}
134 Obsoletes:      boost-static < 1.33
135
136 %description static
137 Static version of base Boost C++ libraries.
138
139 %description static -l pl.UTF-8
140 Statyczne wersje podstawowych bibliotek C++ Boost.
141
142 %package python
143 Summary:        Boost.Python library
144 Summary(pl.UTF-8):      biblioteka Boost.Python
145 Group:          Libraries
146 Requires:       python
147
148 %description python
149 Use the Boost Python Library to quickly and easily export a C++
150 library to Python such that the Python interface is very similar to
151 the C++ interface. It is designed to be minimally intrusive on your
152 C++ design. In most cases, you should not have to alter your C++
153 classes in any way in order to use them with Boost.Python. The system
154 should simply ``reflect'' your C++ classes and functions into Python.
155
156 %description python -l pl.UTF-8
157 Biblioteka Boost Python służy do szybkiego i prostego eksportu
158 biblioteki C++ do Pythona, tak że interfejs Pythona jest bardzo
159 podobny do interfejsu C++. Biblioteka jest zaprojektowana tak, żeby
160 narzucać jak najmniej wymagań dotyczących konstrukcjii C++. W
161 większości przypadków nie trzeba w ogóle zmieniać własnych klas C++,
162 żeby używać ich z Boost.Python. System powinien po prostu ,,odbić''
163 klasy C++ i funkcje do Pythona.
164
165 %package python-devel
166 Summary:        Boost.Python development headers
167 Summary(pl.UTF-8):      Pliki nagłówkowe dla Boost.Python
168 Group:          Development/Libraries
169 Requires:       %{name}-devel = %{version}-%{release}
170 Requires:       %{name}-python = %{version}-%{release}
171
172 %description python-devel
173 Headers for the Boost.Python library.
174
175 %description python-devel -l pl.UTF-8
176 Pliki nagłówkowe dla biblioteki Boost.Python.
177
178 %package python-static
179 Summary:        Static version of Boost.Python library
180 Summary(pl.UTF-8):      Statyczna wersja biblioteki Boost.Python
181 Group:          Development/Libraries
182 Requires:       %{name}-python-devel = %{version}-%{release}
183
184 %description python-static
185 Static version of Boost.Python library.
186
187 %description python-static -l pl.UTF-8
188 Statyczna wersja biblioteki Boost.Python.
189
190 %package chrono
191 Summary:        Useful time utilities
192 Summary(pl.UTF-8):      Przydatne funkcje związane z czasem
193 Group:          Libraries
194 Obsoletes:      boost < 1.33
195
196 %description chrono
197 Useful time utilities.
198
199 %description chrono -l pl.UTF-8
200 Przydatne funkcje związane z czasem.
201
202 %package context
203 Summary:        Boost.Context - context switching library
204 Summary(pl.UTF-8):      Boost.Context - biblioteka do zmiany kontekstu
205 Group:          Libraries
206
207 %description context
208 Boost.Context - context switching library, providing a sort of
209 cooperative multitasking on a single thread.
210
211 %description context -l pl.UTF-8
212 Boost.Context - biblioteka do zmiany kontekstu, zapewniająca pewną
213 wielozadaniowość kooperatywnąw ramach pojedynczego wątku.
214
215 %package date_time
216 Summary:        Date-Time library
217 Summary(pl.UTF-8):      Biblioteka daty-czasu
218 Group:          Libraries
219 Obsoletes:      boost < 1.33
220
221 %description date_time
222 A set of date-time libraries.
223
224 %description date_time -l pl.UTF-8
225 Zbiór bibliotek daty-czasu.
226
227 %package filesystem
228 Summary:        Portable paths, iteration over directories, and other useful filesystem operations
229 Summary(pl.UTF-8):      Przenośne ścieżki, iteracje katalogów i inne użyteczne operacje na systemie plików
230 Group:          Libraries
231 Requires:       %{name}-system = %{version}-%{release}
232 Obsoletes:      boost < 1.33
233
234 %description filesystem
235 The boost::filesystem library provides portable facilities to query
236 and manipulate paths, files, and directories.
237
238 %description filesystem -l pl.UTF-8
239 Przenośna biblioteka boost::filesystem dostarcza ułatwienia w
240 operacjach na ścieżkach, plikach i katalogach.
241
242 %package graph
243 Summary:        General purpose, generic C++ library for graph data structures and graph algorithms
244 Summary(pl.UTF-8):      Biblioteka ogólnego przeznaczenia w C++ dla struktur danych typu grafy oraz algorytmów związanych z grafami
245 Group:          Libraries
246
247 %description graph
248 The boost::graph library provides portable facilities to operate on
249 graph data structures using graph algorithms.
250
251 %description graph -l pl.UTF-8
252 Przenośna biblioteka boost::graph dostarcza ułatwienia w operacjach na
253 strukturach danych typu graf za pomocą algorytmów związanych z
254 grafami.
255
256 %package locale
257 Summary:        Provide localization and Unicode handling tools for C++
258 Summary(pl.UTF-8):      Narzędzia do obsługi lokalizacji i Unikodu w C++
259 Group:          Libraries
260
261 %description locale
262 Provide localization and Unicode handling tools for C++.
263
264 %description locale -l pl.UTF-8
265 Narzędzia do obsługi lokalizacji i Unikodu w C++.
266
267 %package log
268 Summary:        Provide logging tools for C++
269 Summary(pl.UTF-8):      Narzędzia do logowania w C++
270 Group:          Libraries
271
272 %description log
273 Provide logging tools for C++.
274
275 %description log -l pl.UTF-8
276 Narzędzia do logowania w C++.
277
278 %package program_options
279 Summary:        Access to program options, via conventional methods such as command line and config file
280 Summary(pl.UTF-8):      Dostęp do opcji programu za pomocą typowych metod, jak linia poleceń i plik konfiguracyjny
281 Group:          Libraries
282
283 %description program_options
284 The program_options library allows program developers to obtain
285 program options, that is (name, value) pairs from the user, via
286 conventional methods such as command line and config file.
287
288 %description program_options -l pl.UTF-8
289 Biblioteka program_options umożliwia uzyskanie od użytkownika opcji
290 programu, czyli par (nazwa, wartość), za pomocą typowych metod, takich
291 jak linia poleceń, czy plik konfiguracyjny.
292
293 %package regex
294 Summary:        Boost C++ regular expressions library
295 Summary(pl.UTF-8):      Biblioteka wyrażeń regularnych Boost C++
296 Group:          Libraries
297
298 %description regex
299 Shared library for Boost C++ regular expressions.
300
301 %description regex -l pl.UTF-8
302 Biblioteka współdzielona do obsługi wyrażeń regularnych w C++.
303
304 %package signals
305 Summary:        Signals & slots callback implementation
306 Summary(pl.UTF-8):      Implementacja sygnałów i slotów
307 Group:          Libraries
308 Obsoletes:      boost < 1.33
309
310 %description signals
311 The boost::signals library is an implementation of a signals and slots
312 system.
313
314 %description signals -l pl.UTF-8
315 Biblioteka boost::signals jest implementacją systemu sygnałów i
316 slotów.
317
318 %package system
319 Summary:        Support for getting system specific error codes
320 Summary(pl.UTF-8):      Wsparcie dla pobierania specyficznych dla systemu kodów błędów
321 Group:          Libraries
322
323 %description system
324 The Boost System library provides simple, light-weight error_code
325 objects that encapsulate system-specific error code values, yet also
326 provide access to more abstract and portable error conditions objects.
327
328 %description system -l pl.UTF-8
329 Biblioteka Boost System udostępnia proste, lekkie obiekty error_code
330 obudowujące wartości kodów błędów specyficznych dla systemu, dając
331 jednocześnie dostęp do bardziej abstrakcyjnych i przenośnych obiektów
332 błędów.
333
334 %package test
335 Summary:        Support for program testing and execution monitoring
336 Summary(pl.UTF-8):      Wsparcie dla testowania i monitorowania programu
337 Group:          Libraries
338 Obsoletes:      boost < 1.33
339
340 %description test
341 Support for simple program testing, full unit testing, and for program
342 execution monitoring.
343
344 %description test -l pl.UTF-8
345 Wsparcie dla prostego testowania programu, pełnego testowania i
346 monitorowania wykonania programu.
347
348 %package thread
349 Summary:        Portable C++ threads library
350 Summary(pl.UTF-8):      Przenośna biblioteka wątków C++
351 Group:          Libraries
352 Obsoletes:      boost < 1.33
353
354 %description thread
355 Portable C++ threads library - shared library.
356
357 %description thread -l pl.UTF-8
358 Przenośna biblioteka wątków dla C++ - biblioteka dzielona.
359
360 %package timer
361 Summary:        Event timer, progress timer, and progress display classes
362 Summary(pl.UTF-8):      Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu
363 Group:          Libraries
364 Obsoletes:      boost < 1.33
365
366 %description timer
367 Event timer, progress timer, and progress display classes.
368
369 %description timer -l pl.UTF-8
370 Klasy do obsługi pomiarów czasu, postępu i wyświetlania postępu.
371
372 %package wave
373 Summary:        Boost.Wave - a standard compliant C++ preprocessor library
374 Summary(pl.UTF-8):      Boost.Wave - zgodna ze standardem biblioteka preprocesora C++
375 Group:          Development/Libraries
376
377 %description wave
378 Boost.Wave - a standard compliant C++ preprocessor library.
379
380 %description wave -l pl.UTF-8
381 Boost.Wave - zgodna ze standardem biblioteka preprocesora C++.
382
383 %package doc
384 Summary:        Boost C++ Library documentation
385 Summary(pl.UTF-8):      Dokumentacja dla biblioteki Boost C++
386 Group:          Documentation
387 Requires:       %{name}-devel = %{version}-%{release}
388
389 %description doc
390 Documentation for the Boost C++ Library.
391
392 %description doc -l pl.UTF-8
393 Dokumentacja dla biblioteki Boost C++.
394
395 %prep
396 %setup -q -n %{name}_%{fver}
397 %patch0 -p1
398
399 %patch203 -p0
400 %patch211 -p1
401 %patch212 -p1
402 %patch213 -p1
403 %patch218 -p1
404 %patch221 -p1
405 %patch222 -p1
406 %patch224 -p1
407
408 # - don't know how to pass it through (b)jam -s (no way?)
409 #   due to oversophisticated build flags system.
410 # - pass -fPIC due to <shared-linkable> removal.
411 %{__sed} -i "s/<optimization>speed : -O3/<optimization>speed : ${CXXFLAGS:-%rpmcxxflags} -fPIC/" tools/build/src/tools/gcc.jam
412
413 # cleanup -g switch to avoid override debuginfocflags.
414 %{__sed} -i 's/<debug-symbols>on : -g/<debug-symbols>on :/' tools/build/src/tools/gcc.jam
415 # link against shared expat library.
416 #%{__sed} -i 's:find-static:find-shared:' libs/graph/build/Jamfile.v2
417
418 cat << EOF > tools/build/src/user-config.jam
419 using gcc : %{cxx_version} : %{__cxx} ;
420 EOF
421
422 # cleanup backups after patching
423 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
424
425 %build
426 %if %{with python}
427 PYTHON_VERSION=$(%{__python} -c 'import sys; print sys.version[0:3]')
428 PYTHON_ROOT=%{_prefix}
429 %else
430 PYTHON_ROOT=
431 PYTHON_VERSION=
432 %endif
433 EXPAT_INCLUDE=%{_includedir} \
434 EXPAT_LIBPATH=%{_libdir} \
435 ICU_PATH=%{_prefix} \
436 ./bootstrap.sh --prefix=%{_prefix}
437 ./b2 \
438         -d2 --toolset=gcc \
439         variant=release debug-symbols=on inlining=on link=static,shared threading=multi
440
441 %install
442 rm -rf $RPM_BUILD_ROOT
443 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
444
445 cp -rf boost $RPM_BUILD_ROOT%{_includedir}
446
447 install -p stage/lib/lib*.a $RPM_BUILD_ROOT%{_libdir}
448 install -p stage/lib/lib*.so.*.*.* $RPM_BUILD_ROOT%{_libdir}
449 cp -a stage/lib/lib*.so $RPM_BUILD_ROOT%{_libdir}
450
451 # documentation
452 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}
453
454 # as the documentation doesn't completely reside in a directory of its
455 # own, we need to find out ourselves... this looks for HTML files and
456 # then collects everything linked from those.  this is certainly quite
457 # unoptimized wrt mkdir calls, but does it really matter?
458 installdocs() {
459 for i in $(find -type f -name '*.htm*'); do
460         # bjam docu is included in the boost-jam RPM
461         if test "`echo $i | sed 's,jam_src,,'`" = "$i"; then
462                 install -d $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/${i%/*}
463                 for LINKED in `%{__perl} - $i $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$i <<'EOT'
464                         sub rewrite_link
465                         {
466                                 my $link = shift;
467                                 # rewrite links from boost/* to %{_includedir}/boost/* and
468                                 # ignore external links as well as document-internal ones.
469                                 # HTML files are also ignored as they get installed anyway.
470                                 if (!($link =~ s,^(?:../)*boost/,%{_includedir}/boost/,) && !($link =~ m,(?:^[^/]+:|^\#|\.html?(?:$|\#)),))
471                                 {
472                                         (my $file = $link) =~ s/\#.*//;
473                                         print "$file\n";
474                                 }
475                                 $link;
476                         }
477                         open IN, @ARGV[0];
478                         open OUT, ">@ARGV[1]";
479                         my $in_link;
480                         while (<IN>)
481                         {
482                                 $in_link and s/^\s*"([^"> ]*)"/'"' . rewrite_link($1) . '"'/e;
483                                 s/(href|src)="([^"> ]*)"/"$1=\"" . rewrite_link($2) . '"'/eig;
484                                 print OUT;
485                                 $in_link = /href|src=\s*$/;
486                         }
487 EOT`; do
488                         TARGET=${i%/*}/$LINKED
489                         # ignore non-existant linked files
490                         if test -f $TARGET; then
491                                 install -D -m 644 $TARGET $RPM_BUILD_ROOT%{_docdir}/boost-%{version}/$TARGET
492                         fi
493                 done
494         fi
495 done
496 }; installdocs
497
498 %clean
499 rm -rf $RPM_BUILD_ROOT
500
501 %post   -p /sbin/ldconfig
502 %postun -p /sbin/ldconfig
503
504 %post   chrono -p /sbin/ldconfig
505 %postun chrono -p /sbin/ldconfig
506
507 %post   context -p /sbin/ldconfig
508 %postun context -p /sbin/ldconfig
509
510 %post   date_time -p /sbin/ldconfig
511 %postun date_time -p /sbin/ldconfig
512
513 %post   filesystem -p /sbin/ldconfig
514 %postun filesystem -p /sbin/ldconfig
515
516 %post   graph -p /sbin/ldconfig
517 %postun graph -p /sbin/ldconfig
518
519 %post   locale -p /sbin/ldconfig
520 %postun locale -p /sbin/ldconfig
521
522 %post   python -p /sbin/ldconfig
523 %postun python -p /sbin/ldconfig
524
525 %post   program_options -p /sbin/ldconfig
526 %postun program_options -p /sbin/ldconfig
527
528 %post   regex -p /sbin/ldconfig
529 %postun regex -p /sbin/ldconfig
530
531 %post   signals -p /sbin/ldconfig
532 %postun signals -p /sbin/ldconfig
533
534 %post   system -p /sbin/ldconfig
535 %postun system -p /sbin/ldconfig
536
537 %post   test -p /sbin/ldconfig
538 %postun test -p /sbin/ldconfig
539
540 %post   thread -p /sbin/ldconfig
541 %postun thread -p /sbin/ldconfig
542
543 %post   timer -p /sbin/ldconfig
544 %postun timer -p /sbin/ldconfig
545
546 %post   wave -p /sbin/ldconfig
547 %postun wave -p /sbin/ldconfig
548
549 %files
550 %defattr(644,root,root,755)
551 %attr(755,root,root) %{_libdir}/libboost_atomic.so.*.*.*
552 %attr(755,root,root) %{_libdir}/libboost_container.so.*.*.*
553 %attr(755,root,root) %{_libdir}/libboost_coroutine.so.*.*.*
554 %attr(755,root,root) %{_libdir}/libboost_iostreams.so.*.*.*
555 %attr(755,root,root) %{_libdir}/libboost_math_*.so.*.*.*
556 %attr(755,root,root) %{_libdir}/libboost_random.so.*.*.*
557 %attr(755,root,root) %{_libdir}/libboost_serialization.so.*.*.*
558 %attr(755,root,root) %{_libdir}/libboost_wserialization.so.*.*.*
559
560 %files devel
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{_libdir}/libboost_atomic.so
563 %attr(755,root,root) %{_libdir}/libboost_chrono.so
564 %attr(755,root,root) %{_libdir}/libboost_container.so
565 %attr(755,root,root) %{_libdir}/libboost_context.so
566 %attr(755,root,root) %{_libdir}/libboost_coroutine.so
567 %attr(755,root,root) %{_libdir}/libboost_date_time.so
568 %attr(755,root,root) %{_libdir}/libboost_filesystem.so
569 %attr(755,root,root) %{_libdir}/libboost_graph.so
570 %attr(755,root,root) %{_libdir}/libboost_iostreams.so
571 %attr(755,root,root) %{_libdir}/libboost_locale.so
572 %attr(755,root,root) %{_libdir}/libboost_log.so
573 %attr(755,root,root) %{_libdir}/libboost_log_setup.so
574 %attr(755,root,root) %{_libdir}/libboost_math_*.so
575 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so
576 %attr(755,root,root) %{_libdir}/libboost_program_options.so
577 %attr(755,root,root) %{_libdir}/libboost_regex.so
578 %attr(755,root,root) %{_libdir}/libboost_random.so
579 %attr(755,root,root) %{_libdir}/libboost_serialization.so
580 %attr(755,root,root) %{_libdir}/libboost_signals.so
581 %attr(755,root,root) %{_libdir}/libboost_system.so
582 %attr(755,root,root) %{_libdir}/libboost_thread.so
583 %attr(755,root,root) %{_libdir}/libboost_timer.so
584 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so
585 %attr(755,root,root) %{_libdir}/libboost_wave.so
586 %attr(755,root,root) %{_libdir}/libboost_wserialization.so
587 %{_includedir}/boost
588 %exclude %{_includedir}/boost/python
589 %exclude %{_includedir}/boost/python.hpp
590
591 %files static
592 %defattr(644,root,root,755)
593 %{_libdir}/libboost_atomic.a
594 %{_libdir}/libboost_chrono.a
595 %{_libdir}/libboost_container.a
596 %{_libdir}/libboost_context.a
597 %{_libdir}/libboost_coroutine.a
598 %{_libdir}/libboost_date_time.a
599 %{_libdir}/libboost_exception.a
600 %{_libdir}/libboost_filesystem.a
601 %{_libdir}/libboost_graph.a
602 %{_libdir}/libboost_iostreams.a
603 %{_libdir}/libboost_locale.a
604 %{_libdir}/libboost_log.a
605 %{_libdir}/libboost_log_setup.a
606 %{_libdir}/libboost_math_*.a
607 %{_libdir}/libboost_prg_exec_monitor.a
608 %{_libdir}/libboost_program_options.a
609 %{_libdir}/libboost_random.a
610 %{_libdir}/libboost_regex.a
611 %{_libdir}/libboost_serialization.a
612 %{_libdir}/libboost_signals.a
613 %{_libdir}/libboost_system.a
614 %{_libdir}/libboost_test_exec_monitor.a
615 %{_libdir}/libboost_timer.a
616 %{_libdir}/libboost_thread.a
617 %{_libdir}/libboost_unit_test_framework.a
618 %{_libdir}/libboost_wave.a
619 %{_libdir}/libboost_wserialization.a
620
621 %if %{with python}
622 %files python
623 %defattr(644,root,root,755)
624 %attr(755,root,root) %{_libdir}/libboost_python.so.*.*.*
625
626 %files python-devel
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_libdir}/libboost_python.so
629 %{_includedir}/boost/python
630 %{_includedir}/boost/python.hpp
631
632 %files python-static
633 %defattr(644,root,root,755)
634 %{_libdir}/libboost_python.a
635 %endif
636
637 %files chrono
638 %defattr(644,root,root,755)
639 %attr(755,root,root) %{_libdir}/libboost_chrono.so.*.*.*
640
641 %files context
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{_libdir}/libboost_context.so.*.*.*
644
645 %files date_time
646 %defattr(644,root,root,755)
647 %attr(755,root,root) %{_libdir}/libboost_date_time.so.*.*.*
648
649 %files filesystem
650 %defattr(644,root,root,755)
651 %attr(755,root,root) %{_libdir}/libboost_filesystem.so.*.*.*
652
653 %files graph
654 %defattr(644,root,root,755)
655 %attr(755,root,root) %{_libdir}/libboost_graph.so.*.*.*
656
657 %files locale
658 %defattr(644,root,root,755)
659 %attr(755,root,root) %{_libdir}/libboost_locale.so.*.*.*
660
661 %files log
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_libdir}/libboost_log.so.*.*.*
664 %attr(755,root,root) %{_libdir}/libboost_log_setup.so.*.*.*
665
666 %files program_options
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_libdir}/libboost_program_options.so.*.*.*
669
670 %files regex
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_libdir}/libboost_regex.so.*.*.*
673
674 %files signals
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_libdir}/libboost_signals.so.*.*.*
677
678 %files system
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_libdir}/libboost_system.so.*.*.*
681
682 %files test
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{_libdir}/libboost_prg_exec_monitor.so.*.*.*
685 %attr(755,root,root) %{_libdir}/libboost_unit_test_framework.so.*.*.*
686
687 %files thread
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_libdir}/libboost_thread.so.*.*.*
690
691 %files timer
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{_libdir}/libboost_timer.so.*.*.*
694
695 %files wave
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{_libdir}/libboost_wave.so.*.*.*
698
699 %files doc
700 %defattr(644,root,root,755)
701 %{_docdir}/%{name}-%{version}
This page took 0.128964 seconds and 2 git commands to generate.