]> git.pld-linux.org Git - packages/bonnie++.git/commitdiff
- CFLAGS renamed to CXXFLAGS and fixed
authorsparky <sparky@pld-linux.org>
Thu, 10 Aug 2006 01:13:21 +0000 (01:13 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- LFLAGS renamed to LDFLAGS and fixed

Changed files:
    bonnie++-flags.patch -> 1.1

bonnie++-flags.patch [new file with mode: 0644]

diff --git a/bonnie++-flags.patch b/bonnie++-flags.patch
new file mode 100644 (file)
index 0000000..7e3a49b
--- /dev/null
@@ -0,0 +1,28 @@
+diff -Nur bonnie++-1.03a.orig/Makefile.in bonnie++-1.03a.flags/Makefile.in
+--- bonnie++-1.03a.orig/Makefile.in    2002-10-13 22:26:36.000000000 +0200
++++ bonnie++-1.03a.flags/Makefile.in   2006-08-10 03:12:24.000000000 +0200
+@@ -8,8 +8,9 @@
+ eprefix=@exec_prefix@
+ #MORE_WARNINGS=-Weffc++ -Wcast-align
+ WFLAGS=-Wall -W -Wshadow -Wpointer-arith -Wwrite-strings -pedantic -ffor-scope $(MORE_WARNINGS)
+-CFLAGS=-O2 @debug@ -DNDEBUG $(WFLAGS) $(MORECFLAGS)
+-CXX=@CXX@ $(CFLAGS)
++CXXFLAGS=@CXXFLAGS@ @debug@ -DNDEBUG $(WFLAGS) $(MORECFLAGS)
++CXX=@CXX@ $(CXXFLAGS)
++LDFLAGS = @LDFLAGS@
+ INSTALL=@INSTALL@
+ INSTALL_PROGRAM=@INSTALL_PROGRAM@
+@@ -27,10 +28,10 @@
+ ALLOBJS=$(BONOBJS) $(ZCAVOBJS)
+ bonnie++: bonnie++.cpp $(BONOBJS)
+-      $(CXX) bonnie++.cpp -o bonnie++ $(BONOBJS) $(LFLAGS)
++      $(CXX) $(LDFLAGS) bonnie++.cpp -o bonnie++ $(BONOBJS)
+ zcav: zcav.cpp $(ZCAVOBJS)
+-      $(CXX) zcav.cpp -o zcav $(ZCAVOBJS) $(LFLAGS)
++      $(CXX) $(LDFLAGS) zcav.cpp -o zcav $(ZCAVOBJS)
+ install-bin: $(EXES)
+       mkdir -p $(eprefix)/bin $(eprefix)/sbin
This page took 0.032922 seconds and 4 git commands to generate.