]> git.pld-linux.org Git - packages/bitlbee.git/commitdiff
- up to 3.5.1 auto/th/bitlbee-3.5.1-1
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 24 Nov 2019 12:41:59 +0000 (13:41 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 24 Nov 2019 12:41:59 +0000 (13:41 +0100)
- dropped native skype support, unmaintained dead code, see https://wiki.bitlbee.org/HowtoSkype

bitlbee.spec
skype-no-groups.patch [deleted file]
skyped-transport.patch [deleted file]
systemd.patch [deleted file]

index f07b7b7f96307be7be32aad45ac8237213f7d78b..723b731d52db40e4a735478168caa2496dd20480 100644 (file)
@@ -8,17 +8,14 @@
 Summary:       An IRC to other chat networks gateway
 Summary(pl.UTF-8):     Bramka pomiędzy IRC-em i innymi sieciami komunikacyjnymi
 Name:          bitlbee
-Version:       3.2
-Release:       3
+Version:       3.5.1
+Release:       1
 License:       GPL v2+ and MIT
 Group:         Daemons
 Source0:       http://get.bitlbee.org/src/%{name}-%{version}.tar.gz
-# Source0-md5: 6a8fe98e96a47c636004a245075d5d7c
+# Source0-md5: ec866f937258c16e1e2e70f3dec67430
 URL:           http://www.bitlbee.org/
 Patch0:                config.patch
-Patch1:                systemd.patch
-Patch3:                skype-no-groups.patch
-Patch4:                skyped-transport.patch
 BuildRequires: asciidoc
 BuildRequires: glib2-devel >= 1:2.14
 BuildRequires: gnutls-devel
@@ -68,44 +65,13 @@ Requires:   %{name} = %{version}-%{release}
 The bitlbee-otr package includes OTR plugin for bitlbee. Not
 completely stable and not 100% foolproof so use at your own risk.
 
-%package protocol-skype
-Summary:       Skype protocol support for bitlbee
-Group:         Daemons
-Requires:      %{name} = %{version}-%{release}
-Suggests:      skyped
-
-%description protocol-skype
-Skype protocol support for bitlbee.
-
-%package -n skyped
-Summary:       Remote control of the Skype GUI client
-Group:         Daemons
-Requires:      python-skype
-
-%description -n skyped
-Skype supports remote control of the GUI client only via X11 or DBus
-messages. This is hard in care you want remote control. This daemon
-listens on a TCP port and runs on the same machine where the GUI
-client runs. It passes all the input it gets to Skype directly, except
-for a few commands which is related to authentication. The whole
-communication is done via SSL.
-
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
-%patch3 -p1
-%patch4 -p1
 
 # fix wrong assumption with $DESTDIR
 %{__sed} -i -e 's,$(shell id -u),0,' Makefile
 
-# fix #!%{_bindir}/env python -> #!%{__python}:
-%{__sed} -i -e '1s,^#!.*python.*,#!%{__python},' protocols/skype/*.py
-
-# fix config path
-%{__sed} -i -e 's,/usr/local/etc/skyped,%{_sysconfdir}/skyped,' protocols/skype/*.py
-
 %build
 CFLAGS="%{rpmcflags}" \
 ./configure \
@@ -127,7 +93,7 @@ CFLAGS="%{rpmcflags}" \
 %if %{with otr}
        --otr=plugin \
 %endif
-       --skype=plugin \
+       --skype=0
 
 %{__make}
 
@@ -165,7 +131,6 @@ fi
 %{_mandir}/man5/bitlbee.conf.5*
 %{_mandir}/man8/bitlbee.8*
 %{_datadir}/bitlbee
-%dir %{_libdir}/%{name}
 %attr(770,root,bitlbee) %{_localstatedir}/lib/bitlbee
 %{systemdunitdir}/bitlbee.service
 %{systemdunitdir}/bitlbee.socket
@@ -182,17 +147,3 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/%{name}/otr.so
 %endif
-
-%files protocol-skype
-%defattr(644,root,root,755)
-%doc protocols/skype/{HACKING,NEWS,README}
-%attr(755,root,root) %{_libdir}/%{name}/skype.so
-
-%files -n skyped
-%defattr(644,root,root,755)
-%doc protocols/skype/{skyped.txt,client.sh}
-%dir %{_sysconfdir}/skyped
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/skyped/skyped.cnf
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/skyped/skyped.conf
-%attr(755,root,root) %{_sbindir}/skyped
-%{_mandir}/man1/skyped.1*
diff --git a/skype-no-groups.patch b/skype-no-groups.patch
deleted file mode 100644 (file)
index a1479e0..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-Do not download custom groups, makes skyped to lag because those queries timeout
-
-http://bugs.bitlbee.org/bitlbee/ticket/946
-
---- bitlbee-3.0.5/protocols/skype/skype.c~     2012-02-18 12:55:09.000000000 +0200
-+++ bitlbee-3.0.5/protocols/skype/skype.c      2012-04-15 15:12:57.245107505 +0300
-@@ -1170,8 +1170,7 @@
-       skype_printf(ic, "PASSWORD %s\n", ic->acc->pass);
-       /* This will download all buddies and groups. */
--      st = skype_printf(ic, "SEARCH GROUPS CUSTOM\n");
--      skype_printf(ic, "SEARCH FRIENDS\n");
-+      st = skype_printf(ic, "SEARCH FRIENDS\n");
-       skype_printf(ic, "SET USERSTATUS ONLINE\n");
diff --git a/skyped-transport.patch b/skyped-transport.patch
deleted file mode 100644 (file)
index e52bced..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
---- bitlbee-3.0.5/protocols/skype/skyped.py~   2012-08-20 13:12:13.498690222 +0300
-+++ bitlbee-3.0.5/protocols/skype/skyped.py    2012-08-20 13:45:21.105984684 +0300
-@@ -275,8 +275,12 @@
-               sock.close()
- class SkypeApi:
--      def __init__(self):
--              self.skype = Skype4Py.Skype()
-+      def __init__(self, transport = None):
-+              if transport:
-+                      self.skype = Skype4Py.Skype(Transport = transport)
-+              else:
-+                      self.skype = Skype4Py.Skype()
-+
-               self.skype.OnNotify = self.recv
-               self.skype.Client.Start()
-@@ -352,6 +356,7 @@
-               self.host = "0.0.0.0"
-               self.log = None
-               self.port = None
-+              self.transport = None
-               self.version = False
-               # well, this is a bit hackish. we store the socket of the last connected client
-               # here and notify it. maybe later notify all connected clients?
-@@ -373,6 +378,7 @@
-       -l      --log           set the log file in background mode (default: none)
-       -n      --nofork        don't run as daemon in the background
-       -p      --port          set the tcp port (default: %s)
-+      -t      --transport     enforce Skype4Py transport (x11 or dbus) (defaults to Skype4Py default)
-       -v      --version       display version information""" % (self.cfgpath, self.host, self.port)
-               sys.exit(ret)
-@@ -420,7 +426,7 @@
- if __name__=='__main__':
-       options = Options()
-       try:
--              opts, args = getopt.getopt(sys.argv[1:], "c:dhH:l:np:v", ["config=", "debug", "help", "host=", "log=", "nofork", "port=", "version"])
-+              opts, args = getopt.getopt(sys.argv[1:], "c:dhH:l:np:t:v", ["config=", "debug", "help", "host=", "log=", "nofork", "port=", "transport=", "version"])
-       except getopt.GetoptError:
-               options.usage(1)
-       for opt, arg in opts:
-@@ -438,6 +444,8 @@
-                       options.daemon = False
-               elif opt in ("-p", "--port"):
-                       options.port = int(arg)
-+              elif opt in ("-t", "--transport"):
-+                      options.transport = arg
-               elif opt in ("-v", "--version"):
-                       options.version = True
-       if options.help:
-@@ -484,7 +492,7 @@
-       if hasgobject:
-               server(options.host, options.port)
-       try:
--              skype = SkypeApi()
-+              skype = SkypeApi(options.transport)
-       except Skype4Py.SkypeAPIError, s:
-               sys.exit("%s. Are you sure you have started Skype?" % s)
-       if hasgobject:
diff --git a/systemd.patch b/systemd.patch
deleted file mode 100644 (file)
index 44d0e2f..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
---- bitlbee-3.0.3.orig/init/bitlbee.service.in
-+++ bitlbee-3.0.3/init/bitlbee.service.in
-@@ -3,7 +3,9 @@ Description=BitlBee IRC/IM gateway
- After=syslog.target
- [Service]
--ExecStart=@sbindir@/bitlbee -F -n
-+Type=simple
-+ExecStart=@sbindir@bitlbee -D -n
-+Restart=always
- [Install]
- WantedBy=multi-user.target
---- bitlbee-3.0.5/init/bitlbee@.service.in~    2012-02-18 12:55:09.000000000 +0200
-+++ bitlbee-3.0.5/init/bitlbee@.service.in     2012-04-15 11:44:51.390614993 +0300
-@@ -3,6 +3,6 @@
- After=syslog.target
- [Service]
--ExecStart=@sbindir@/bitlbee -I
-+ExecStart=@sbindir@bitlbee -I
- StandardInput=socket
- User=bitlbee
This page took 0.042553 seconds and 4 git commands to generate.