]> git.pld-linux.org Git - packages/bison.git/blob - bison.spec
c26ab08a02c0fe3eae7a075d90d0388b9d57ddbd
[packages/bison.git] / bison.spec
1 Summary:        A GNU general-purpose parser generator
2 Summary(de.UTF-8):      GNU-Parser-Generator
3 Summary(es.UTF-8):      Generador de parser de la GNU
4 Summary(fr.UTF-8):      Générateur d'analyseur lexical de GNU
5 Summary(pl.UTF-8):      GNU generator składni
6 Summary(pt_BR.UTF-8):   Gerador de parser da GNU
7 Summary(ru.UTF-8):      Bison - генератор парсеров GNU
8 Summary(tr.UTF-8):      GNU ayrıştırıcı üreticisi
9 Summary(uk.UTF-8):      Bison - генератор парсерів GNU
10 Name:           bison
11 Version:        3.8.2
12 Release:        1
13 License:        GPL v3+
14 Group:          Development/Tools
15 Source0:        https://ftp.gnu.org/gnu/bison/%{name}-%{version}.tar.lz
16 # Source0-md5:  26e76218c2a50a0dd307286d42eb0af9
17 Source1:        %{name}.1.pl
18 Patch0:         %{name}-info.patch
19 URL:            http://www.gnu.org/software/bison/
20 BuildRequires:  flex
21 BuildRequires:  gcc >= 5:3.2
22 BuildRequires:  gettext-tools >= 0.19
23 BuildRequires:  help2man
24 BuildRequires:  libtextstyle-devel >= 0.20.5
25 BuildRequires:  libxslt-progs
26 BuildRequires:  lzip
27 BuildRequires:  m4 >= 1.4.6
28 # find_lang -a
29 BuildRequires:  rpmbuild(find_lang) >= 1.31
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  texinfo >= 4.0
32 Requires:       %{name}-runtime = %{version}-%{release}
33 Requires:       libtextstyle >= 0.20.5
34 Requires:       m4 >= 1.4.6
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Bison is a general purpose parser generator which converts a grammar
39 description for an LALR context-free grammar into a C program to parse
40 that grammar. Bison can be used to develop a wide range of language
41 parsers, from ones used in simple desk calculators to complex
42 programming languages. Bison is upwardly compatible with Yacc, so any
43 correctly written Yacc grammar should work with Bison without any
44 changes. If you know Yacc, you shouldn't have any trouble using Bison
45 (but you do need to be very proficient in C programming to be able to
46 use Bison). Many programs use Bison as part of their build process.
47 Bison is only needed on systems that are used for development.
48
49 %description -l de.UTF-8
50 Dies ist der GNU-Parser-Generator, der größtenteils mit yacc
51 kompatibel ist. Viele Programme benutzen ihn als Teil des
52 Aufbauvorgangs. Bison wird nur auf Systemen benötigt, die zur
53 Entwicklung verwendet werden.
54
55 %description -l es.UTF-8
56 Este es el creador de análisis gramatical GNU más compatible con yacc.
57 Varios programas lo utilizan como parte del su proceso de
58 construcción. Bison solamente hace falta en sistemas que se usan para
59 desarrollo.
60
61 %description -l fr.UTF-8
62 Générateur d'analyseur lexical de GNU compatible avec yacc. De
63 nombreux programmes l'utilisent dans leur phase de construction. Bison
64 ne sert que sur les systèmes utilisés pour le développement.
65
66 %description -l pl.UTF-8
67 W pakiecie znajduje się implementacja GNU generatora analizatora
68 składni, który jest odpowiednikiem programu yacc. Wiele programów
69 podczas kompilacji potrzebuje tego programu aby proces budowy plików
70 binarnych przebiegał prawidłowo. Bison jest potrzebny tylko w
71 systemach, w których prowadzone są różnego rodzaju kompilacje.
72
73 %description -l pt_BR.UTF-8
74 Este é o gerador de análise gramatical GNU que é mais compatível com
75 yacc. Vários programas o utilizam como parte do seu processo de
76 construção. Bison é somente necessário em sistemas que são usados para
77 desenvolvimento.
78
79 %description -l ru.UTF-8
80 Bison - это парсер, в основном совместимый с yacc. Многие программы
81 используют его в процессе компилляции. Bison нужен только в системах,
82 которые используются для разработки программ.
83
84 %description -l tr.UTF-8
85 byacc bir yacc ayrıştırıcısıdır. Pek çok program tarafından, kurulum
86 süreci sırasında kullanılır. Geliştirme yapanlara gerekli olabilir.
87
88 %description -l uk.UTF-8
89 Bison - це парсер, здебільшого сумісний з yacc. Багато програм
90 використовують його в процесі компіляції. Bison потрібен тільки в
91 системах, які використовуються для розробки програм.
92
93 %package runtime
94 Summary:        Runtime library for programs containing bison-generated parsers
95 Summary(pl.UTF-8):      Biblioteka uruchomieniowa dla programów zawierajacych parsery bisonowe
96 Group:          Libraries
97
98 %description runtime
99 Runtime library for internationalized programs containing
100 bison-generated parsers.
101
102 %description runtime -l pl.UTF-8
103 Biblioteka uruchomieniowa dla umiędzynarodowionych programów
104 zawierajacych parsery wygenerowane przez bisona.
105
106 %prep
107 %setup -q
108 %patch0 -p1
109
110 %{__rm} po/stamp-po
111
112 %build
113 %configure \
114         --disable-silent-rules
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT%{_mandir}/pl/man1
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/pl/man1/bison.1
125
126 # provided by byacc (bison is not 100% compatible)
127 %{__rm} $RPM_BUILD_ROOT{%{_bindir}/yacc,%{_mandir}/man1/yacc.1}
128
129 install -d $RPM_BUILD_ROOT%{_examplesdir}
130 %{__mv} $RPM_BUILD_ROOT%{_docdir}/bison/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
131 # the rest is packaged as %doc
132 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/bison
133
134 %find_lang %{name}
135 %find_lang %{name}-gnulib -a %{name}.lang
136 %find_lang %{name}-runtime
137
138 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/postshell
144 -/usr/sbin/fix-info-dir -c %{_infodir}
145
146 %postun -p /sbin/postshell
147 -/usr/sbin/fix-info-dir -c %{_infodir}
148
149 %files -f %{name}.lang
150 %defattr(644,root,root,755)
151 %doc AUTHORS ChangeLog NEWS README THANKS TODO
152 %attr(755,root,root) %{_bindir}/bison
153 %{_libdir}/liby.a
154 %{_datadir}/bison
155 %{_aclocaldir}/bison-i18n.m4
156 %{_mandir}/man1/bison.1*
157 %lang(pl) %{_mandir}/pl/man1/bison.1*
158 %{_infodir}/bison.info*
159 %{_examplesdir}/%{name}-%{version}
160
161 %files runtime -f %{name}-runtime.lang
162 %defattr(644,root,root,755)
This page took 0.061246 seconds and 2 git commands to generate.