]> git.pld-linux.org Git - packages/bash.git/commitdiff
- up to 4.3.28 (which is the same as PLD 4.3.27-1; just now using official patch) auto/th/bash-4.3.28-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 1 Oct 2014 15:14:21 +0000 (17:14 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 1 Oct 2014 15:14:21 +0000 (17:14 +0200)
bash-4.2-cve-2014-7169-2.patch [deleted file]
bash.spec
sources

diff --git a/bash-4.2-cve-2014-7169-2.patch b/bash-4.2-cve-2014-7169-2.patch
deleted file mode 100644 (file)
index 3da05bb..0000000
+++ /dev/null
@@ -1,83 +0,0 @@
---- ../bash-4.2-orig/parse.y   2014-09-25 13:07:59.218209276 +0200
-+++ parse.y    2014-09-25 15:26:52.813159810 +0200
-@@ -264,9 +264,21 @@
- /* Variables to manage the task of reading here documents, because we need to
-    defer the reading until after a complete command has been collected. */
--static REDIRECT *redir_stack[10];
-+static REDIRECT **redir_stack;
- int need_here_doc;
-+/* Pushes REDIR onto redir_stack, resizing it as needed. */
-+static void
-+push_redir_stack (REDIRECT *redir)
-+{
-+  /* Guard against oveflow. */
-+  if (need_here_doc + 1 > INT_MAX / sizeof (*redir_stack))
-+    abort ();
-+  redir_stack = xrealloc (redir_stack,
-+                        (need_here_doc + 1) * sizeof (*redir_stack));
-+  redir_stack[need_here_doc++] = redir;
-+}
-+
- /* Where shell input comes from.  History expansion is performed on each
-    line when the shell is interactive. */
- static char *shell_input_line = (char *)NULL;
-@@ -519,42 +531,42 @@
-                         source.dest = 0;
-                         redir.filename = $2;
-                         $$ = make_redirection (source, r_reading_until, redir, 0);
--                        redir_stack[need_here_doc++] = $$;
-+                        push_redir_stack ($$);
-                       }
-       |       NUMBER LESS_LESS WORD
-                       {
-                         source.dest = $1;
-                         redir.filename = $3;
-                         $$ = make_redirection (source, r_reading_until, redir, 0);
--                        redir_stack[need_here_doc++] = $$;
-+                        push_redir_stack ($$);
-                       }
-       |       REDIR_WORD LESS_LESS WORD
-                       {
-                         source.filename = $1;
-                         redir.filename = $3;
-                         $$ = make_redirection (source, r_reading_until, redir, REDIR_VARASSIGN);
--                        redir_stack[need_here_doc++] = $$;
-+                        push_redir_stack ($$);
-                       }
-       |       LESS_LESS_MINUS WORD
-                       {
-                         source.dest = 0;
-                         redir.filename = $2;
-                         $$ = make_redirection (source, r_deblank_reading_until, redir, 0);
--                        redir_stack[need_here_doc++] = $$;
-+                        push_redir_stack ($$);
-                       }
-       |       NUMBER LESS_LESS_MINUS WORD
-                       {
-                         source.dest = $1;
-                         redir.filename = $3;
-                         $$ = make_redirection (source, r_deblank_reading_until, redir, 0);
--                        redir_stack[need_here_doc++] = $$;
-+                        push_redir_stack ($$);
-                       }
-       |       REDIR_WORD  LESS_LESS_MINUS WORD
-                       {
-                         source.filename = $1;
-                         redir.filename = $3;
-                         $$ = make_redirection (source, r_deblank_reading_until, redir, REDIR_VARASSIGN);
--                        redir_stack[need_here_doc++] = $$;
-+                        push_redir_stack ($$);
-                       }
-       |       LESS_LESS_LESS WORD
-                       {
-@@ -4757,7 +4769,7 @@
-     case CASE:
-     case SELECT:
-     case FOR:
--      if (word_top < MAX_CASE_NEST)
-+      if (word_top + 1 < MAX_CASE_NEST)
-       word_top++;
-       word_lineno[word_top] = line_number;
-       break;
index 0a2b168a91aadce4553dbd7ff2d1c931387098d6..6b7fc2ee9f98615f6e6e708222c4c076c2ad150c 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -6,7 +6,7 @@
 
 # NOTE: when updating patchleve, do not forget to update 'sources' file!
 %define                ver             4.3
-%define                patchlevel      27
+%define                patchlevel      28
 %define                rel             1
 Summary:       GNU Bourne Again Shell (bash)
 Summary(fr.UTF-8):     Le shell Bourne Again de GNU
@@ -36,8 +36,6 @@ Patch9:               %{name}-backup_history.patch
 Patch10:       %{name}-act_like_sh.patch
 Patch11:       %{name}-elinks_cont.patch
 Patch12:       %{name}-pl.po-update.patch
-# from FC
-Patch13:       bash-4.2-cve-2014-7169-2.patch
 %patchset_source -f https://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-%03g 1 %{patchlevel}
 URL:           http://www.gnu.org/software/bash/
 BuildRequires: autoconf
@@ -196,7 +194,6 @@ tym pakiecie jest wersja basha skonsolidowana statycznie.
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
-%patch13 -p0
 
 sed -i -e 's#/usr/bin/printf#/bin/printf#g' tests/intl2.sub
 
diff --git a/sources b/sources
index 7e0de84fa003a504c1287c848991fd1821a62e0e..54b40a54596375b7f17fd3d87f77a53dd6e53afc 100644 (file)
--- a/sources
+++ b/sources
@@ -25,3 +25,4 @@ b5ea5600942acceb4b6f07313d2de74e  bash43-024
 193c06f578d38ffdbaebae9c51a7551f  bash43-025
 922578e2be7ed03729454e92ee8d3f3a  bash43-026
 8ff6948b16f2db5c29b1b9ae1085bbe7  bash43-027
+833e78cf96c647ce0bf7b8a78e6c243c  bash43-028
This page took 0.210851 seconds and 4 git commands to generate.