]> git.pld-linux.org Git - packages/bash.git/commitdiff
- up to 4.0.35 auto/th/bash-4_0_35-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 28 Oct 2009 19:53:34 +0000 (19:53 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    bash.spec -> 1.202
    bash40-034 -> 1.1
    bash40-035 -> 1.1

bash.spec
bash40-034 [new file with mode: 0644]
bash40-035 [new file with mode: 0644]

index ba7f9643be0393935f56bd9ad018b9abb02bd85c..5cf2f0f68c7c286b3401d53cee8c1eb16b11d89a 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -5,7 +5,7 @@
 %bcond_without tests   # do not perform "make test"
 #
 %define                ver             4.0
-%define                patchlevel      33
+%define                patchlevel      35
 %define                rel             1
 Summary:       GNU Bourne Again Shell (bash)
 Summary(fr.UTF-8):     Le shell Bourne Again de GNU
diff --git a/bash40-034 b/bash40-034
new file mode 100644 (file)
index 0000000..bacb33c
--- /dev/null
@@ -0,0 +1,59 @@
+                            BASH PATCH REPORT
+                            =================
+
+Bash-Release:  4.0
+Patch-ID:      bash40-034
+
+Bug-Reported-by:       Anders Kaseorg <andersk@mit.edu>
+Bug-Reference-ID:      <1252856832.991059.8162.nullmailer@balanced-tree.mit.edu>
+Bug-Reference-URL:     http://lists.gnu.org/archive/html/bug-bash/2009-09/msg00043.html
+
+Bug-Description:
+
+When using the globstar option, bash incorrectly interprets wildcarded path
+components between a **/ and the last / as matching any path, even if the
+constructed path does not match any files.
+
+Patch:
+
+*** ../bash-4.0-patched/lib/glob/glob.c        2009-07-22 23:18:50.000000000 -0400
+--- lib/glob/glob.c    2009-09-18 17:53:25.000000000 -0400
+***************
+*** 920,928 ****
+         char **temp_results;
+  
+         /* Scan directory even on a NULL filename.  That way, `*h/'
+            returns only directories ending in `h', instead of all
+            files ending in `h' with a `/' appended. */
+         dname = directories[i];
+!        dflags = flags & ~GX_MARKDIRS;
+         if ((flags & GX_GLOBSTAR) && filename[0] == '*' && filename[1] == '*' && filename[2] == '\0')
+           dflags |= GX_ALLDIRS|GX_ADDCURDIR;
+--- 927,938 ----
+         char **temp_results;
+  
++        /* XXX -- we've recursively scanned any directories resulting from
++           a `**', so turn off the flag.  We turn it on again below if
++           filename is `**' */
+         /* Scan directory even on a NULL filename.  That way, `*h/'
+            returns only directories ending in `h', instead of all
+            files ending in `h' with a `/' appended. */
+         dname = directories[i];
+!        dflags = flags & ~(GX_MARKDIRS|GX_ALLDIRS|GX_ADDCURDIR);
+         if ((flags & GX_GLOBSTAR) && filename[0] == '*' && filename[1] == '*' && filename[2] == '\0')
+           dflags |= GX_ALLDIRS|GX_ADDCURDIR;
+*** ../bash-4.0/patchlevel.h   2009-01-04 14:32:40.000000000 -0500
+--- patchlevel.h       2009-02-22 16:11:31.000000000 -0500
+***************
+*** 26,30 ****
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 33
+  
+  #endif /* _PATCHLEVEL_H_ */
+--- 26,30 ----
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 34
+  
+  #endif /* _PATCHLEVEL_H_ */
diff --git a/bash40-035 b/bash40-035
new file mode 100644 (file)
index 0000000..3b1af75
--- /dev/null
@@ -0,0 +1,62 @@
+                            BASH PATCH REPORT
+                            =================
+
+Bash-Release:  4.0
+Patch-ID:      bash40-035
+
+Bug-Reported-by:       Freddy Vulto <fvulto@gmail.com>
+Bug-Reference-ID:      <e9c463930909171341p7cbe6e43pa3788ebbe3adec4d@mail.gmail.com>
+Bug-Reference-URL:     http://lists.gnu.org/archive/html/bug-bash/2009-09/msg00044.html
+
+Bug-Description:
+
+Bash-4.0 incorrectly treated single and double quotes as delimiters rather
+than introducing quoted strings when splitting the line into words for
+programmable completion functions.
+
+Patch:
+
+*** ../bash-4.0-patched/pcomplete.c    2009-03-08 21:24:31.000000000 -0400
+--- pcomplete.c        2009-09-26 16:30:16.000000000 -0400
+***************
+*** 1176,1186 ****
+    WORD_LIST *ret;
+    char *delims;
+  
+! #if 0
+!   delims = "()<>;&| \t\n";   /* shell metacharacters break words */
+! #else
+!   delims = rl_completer_word_break_characters;
+! #endif
+    ret = split_at_delims (line, llen, delims, sentinel, nwp, cwp);
+    return (ret);
+  }
+--- 1176,1188 ----
+    WORD_LIST *ret;
+    char *delims;
++   int i, j;
+  
+!   delims = xmalloc (strlen (rl_completer_word_break_characters) + 1);
+!   for (i = j = 0; rl_completer_word_break_characters[i]; i++)
+!     if (rl_completer_word_break_characters[i] != '\'' && rl_completer_word_break_characters[i] != '"')
+!       delims[j++] = rl_completer_word_break_characters[i];
+!   delims[j] = '\0';
+    ret = split_at_delims (line, llen, delims, sentinel, nwp, cwp);
++   free (delims);
+    return (ret);
+  }
+*** ../bash-4.0/patchlevel.h   2009-01-04 14:32:40.000000000 -0500
+--- patchlevel.h       2009-02-22 16:11:31.000000000 -0500
+***************
+*** 26,30 ****
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 34
+  
+  #endif /* _PATCHLEVEL_H_ */
+--- 26,30 ----
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 35
+  
+  #endif /* _PATCHLEVEL_H_ */
This page took 1.313868 seconds and 4 git commands to generate.