]> git.pld-linux.org Git - packages/bash.git/commitdiff
- up to 4.1.2 auto/th/bash-4_1_2-3 auto/ti/bash-4_1_2-3
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 3 Feb 2010 12:21:06 +0000 (12:21 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    bash.spec -> 1.206
    bash41-001 -> 1.1
    bash41-002 -> 1.1

bash.spec
bash41-001 [new file with mode: 0644]
bash41-002 [new file with mode: 0644]

index 2730a56600bc4890979f343eedf9dcd4f04a3a25..4bd54772d568b32bafe7fa21fe307efe9adabf78 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -5,7 +5,7 @@
 %bcond_without tests   # do not perform "make test"
 #
 %define                ver             4.1
-%define                patchlevel      0
+%define                patchlevel      2
 %define                rel             3
 Summary:       GNU Bourne Again Shell (bash)
 Summary(fr.UTF-8):     Le shell Bourne Again de GNU
@@ -37,7 +37,7 @@ Patch8:               %{name}-sighup.patch
 Patch9:                %{name}-backup_history.patch
 Patch10:       %{name}-act_like_sh.patch
 Patch11:       %{name}-elinks_cont.patch
-#%%patchset_source -f http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-%03g 1 %{patchlevel}
+%patchset_source -f http://ftp.gnu.org/gnu/bash/bash-4.1-patches/bash41-%03g 1 %{patchlevel}
 URL:           http://www.gnu.org/software/bash/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -182,7 +182,7 @@ tym pakiecie jest wersja basha skonsolidowana statycznie.
 %prep
 %setup -q -n %{name}-%{ver} -a5
 # official patches
-#%%patchset_patch 1 %{patchlevel}
+%patchset_patch 1 %{patchlevel}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
diff --git a/bash41-001 b/bash41-001
new file mode 100644 (file)
index 0000000..758e1fa
--- /dev/null
@@ -0,0 +1,48 @@
+                            BASH PATCH REPORT
+                            =================
+
+Bash-Release:  4.1
+Patch-ID:      bash41-001
+
+Bug-Reported-by:       Yann Rouillard <yann@pleiades.fr.eu.org>
+Bug-Reference-ID:      <4B44A410.4070107@pleiades.fr.eu.org>
+Bug-Reference-URL:     http://lists.gnu.org/archive/html/bug-bash/2010-01/msg00018.html
+
+Bug-Description:
+
+A prototype for vsnprintf was incorrect, and caused compilation failures
+on systems that did not have a suitable vsnprintf, but had a declaration in
+one of the system header files.
+
+Patch (apply with `patch -p0'):
+
+*** ../bash-4.1-patched/builtins/printf.def    2009-11-20 15:31:23.000000000 -0500
+--- builtins/printf.def        2010-01-07 08:50:06.000000000 -0500
+***************
+*** 173,177 ****
+  
+  #if !HAVE_VSNPRINTF
+! extern int vsnprintf __P((char *, size_t, const char *, ...)) __attribute__((__format__ (printf, 3, 4)));
+  #endif
+  
+--- 173,177 ----
+  
+  #if !HAVE_VSNPRINTF
+! extern int vsnprintf __P((char *, size_t, const char *, va_list)) __attribute__((__format__ (printf, 3, 0)));
+  #endif
+  
+*** ../bash-4.1-patched/patchlevel.h   2009-10-01 16:39:22.000000000 -0400
+--- patchlevel.h       2010-01-14 09:38:08.000000000 -0500
+***************
+*** 26,30 ****
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 0
+  
+  #endif /* _PATCHLEVEL_H_ */
+--- 26,30 ----
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 1
+  
+  #endif /* _PATCHLEVEL_H_ */
diff --git a/bash41-002 b/bash41-002
new file mode 100644 (file)
index 0000000..a115198
--- /dev/null
@@ -0,0 +1,65 @@
+                            BASH PATCH REPORT
+                            =================
+
+Bash-Release:  4.1
+Patch-ID:      bash41-002
+
+Bug-Reported-by:       guillaume.outters@free.fr
+Bug-Reference-ID:      <20100105230441.70D171AA7F52@asterix.local>
+Bug-Reference-URL:     http://lists.gnu.org/archive/html/bug-bash/2010-01/msg00017.html
+
+Bug-Description:
+
+Bash-4.1/Readline-6.1 introduced a hook function that allows applications
+to rewrite or modify filenames read from the file system before comparing
+them with a word to be completed.  The converted filename, if it matches,
+needs to be inserted into the line buffer, replacing the original contents.
+
+This fixes a completion bug on Mac OS X involving filenames containing
+UTF-8 characters.
+
+Patch (apply with `patch -p0'):
+
+*** ../bash-4.1-patched/lib/readline/complete.c        2009-11-29 18:39:30.000000000 -0500
+--- lib/readline/complete.c    2010-01-06 08:30:23.000000000 -0500
+***************
+*** 2139,2143 ****
+        if (filename_len == 0)
+       {
+!        if (_rl_match_hidden_files == 0 && HIDDEN_FILE (entry->d_name))
+           continue;
+  
+--- 2139,2143 ----
+        if (filename_len == 0)
+       {
+!        if (_rl_match_hidden_files == 0 && HIDDEN_FILE (convfn))
+           continue;
+  
+***************
+*** 2220,2224 ****
+           }
+  
+!        strcpy (temp + dirlen, entry->d_name);
+       }
+        else
+--- 2220,2224 ----
+           }
+  
+!        strcpy (temp + dirlen, convfn);
+       }
+        else
+*** ../bash-4.1-patched/patchlevel.h   2009-10-01 16:39:22.000000000 -0400
+--- patchlevel.h       2010-01-14 09:38:08.000000000 -0500
+***************
+*** 26,30 ****
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 1
+  
+  #endif /* _PATCHLEVEL_H_ */
+--- 26,30 ----
+     looks for to find the patch level (for the sccs version string). */
+  
+! #define PATCHLEVEL 2
+  
+  #endif /* _PATCHLEVEL_H_ */
This page took 0.105243 seconds and 4 git commands to generate.