]> git.pld-linux.org Git - packages/bash.git/blob - bash.spec
- up to 4.3.42
[packages/bash.git] / bash.spec
1 #
2 # Conditional build:
3 %bcond_without  static          # don't build static version
4 %bcond_with     bash_history    # build with additional history in /var/log/bash_hist ;)
5 %bcond_without  tests   # do not perform "make test"
6
7 # NOTE: when updating patchlevel, do not forget to update 'sources' file:
8 # $ md5sum bash43-??? > sources
9 %define         ver             4.3
10 %define         patchlevel      42
11 %define         rel             1
12 Summary:        GNU Bourne Again Shell (bash)
13 Summary(fr.UTF-8):      Le shell Bourne Again de GNU
14 Summary(pl.UTF-8):      Powłoka GNU Bourne Again Shell (bash)
15 Name:           bash
16 Version:        %{ver}%{?patchlevel:.%{patchlevel}}
17 Release:        %{rel}%{?with_bash_history:inv}
18 License:        GPL
19 Group:          Applications/Shells
20 Source0:        http://ftp.gnu.org/gnu/bash/%{name}-%{ver}.tar.gz
21 # Source0-md5:  81348932d5da294953e15d4814c74dd1
22 Source1:        %{name}rc
23 Source2:        %{name}-skel-.bash_logout
24 Source3:        %{name}-skel-.bash_profile
25 Source4:        %{name}-skel-.bashrc
26 Source5:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
27 # Source5-md5:  d2aacf89c4a444c5da648da69afdb01a
28 Patch0:         %{name}-paths.patch
29 Patch1:         %{name}-security.patch
30 Patch2:         %{name}-autoconf.patch
31 Patch3:         %{name}-info.patch
32 Patch4:         %{name}-profile.patch
33 Patch5:         %{name}-requires.patch
34 Patch6:         %{name}-compat.patch
35 Patch8:         %{name}-sighup.patch
36 Patch9:         %{name}-backup_history.patch
37 Patch10:        %{name}-act_like_sh.patch
38 Patch11:        %{name}-elinks_cont.patch
39 Patch12:        %{name}-pl.po-update.patch
40 %patchset_source -f https://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-%03g 1 %{patchlevel}
41 URL:            http://www.gnu.org/software/bash/
42 BuildRequires:  autoconf
43 BuildRequires:  automake
44 BuildRequires:  bison
45 BuildRequires:  ncurses-devel >= 5.2
46 BuildRequires:  readline-devel >= 6.3
47 BuildRequires:  rpmbuild(macros) >= 1.462
48 BuildRequires:  sed >= 4.0
49 BuildRequires:  texinfo
50 %if %{with static}
51 # Require static library only for static build
52 BuildRequires:  glibc-static >= 2.2
53 BuildRequires:  ncurses-static >= 5.2
54 BuildRequires:  readline-static >= 6.3
55 %endif
56 Requires:       readline >= 6.3
57 Requires:       setup >= 2.4.6-2
58 Obsoletes:      bash-doc
59 Obsoletes:      bash2
60 Obsoletes:      bash2-doc
61 Obsoletes:      etcskel
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 Bash is a GNU project sh-compatible shell or command language
66 interpreter. Bash (Bourne Again shell) incorporates useful features
67 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
68 be run by bash without modification. Bash offers several improvements
69 over sh, including command line editing, unlimited size command
70 history, job control, shell functions and aliases, indexed arrays of
71 unlimited size and integer arithmetic in any base from two to 64. Bash
72 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
73 Shell and Tools standard. Bash is the default shell for Linux
74 Mandrake. You should install bash because of its popularity and power.
75 You'll probably end up using it.
76
77 %description -l es.UTF-8
78 Bash es un interpretador de comandos compatible con sh, que ejecuta
79 comandos leídos de la entrada padrón o de un archivo. Bash también
80 incorpora características útiles de las shells Korn y C (ksh y csh).
81 Bash ha sido desarrollado para ser una adición compatible con la
82 especificación IEEE Posix para shells y herramientas (IEEE Working
83 Group 1003.2).
84
85 %description -l de.UTF-8
86 Bash ist eine sh-kompatible Shell und Kommandosprache aus dem
87 GNU-Projekt. Bash (Bourne Again Shell) vereinigt die nützlichen
88 Features aus der Korn-Shell (ksh) und der C-Shell (csh). Die meisten
89 sh-Skripte laufen ohne Änderungen auf bash. Bash hat viele
90 Erweiterungen im Vergleich zur "normalen" sh, wie z.B.
91 Kommandozeilenbearbeitung, unbeschränkte Größe der command-history,
92 Job-Kontrolle, Shell-Funktionen und -Aliase, unbegrenzt große
93 indizierte Arrays und Integer-Arithmetik in einer Basis von 2 bis 64.
94 Hauptziel von bash ist es, den IEEE POSIX P1003.2/ISO 9945.2 Shell-
95 und Tools-Standard einzuhalten. Bash ist die Standard-Shell für Linux
96 Mandrake.
97
98 %description -l fr.UTF-8
99 Bash est un shell (interpréteur de commande) du projet GNU, compatible
100 avec le shell historique sh. Bash (Bourne Again SHell) comprend de
101 nombreuses fonctionnalités du Korn SHell (ksh) et du C SHell (csh). La
102 plupart des scripts sh sont exécutables sans modifications. Bash
103 comprend nombre d'améliorations par rapport à sh : édition de la ligne
104 de commande, historique illimité, contrôle des processus
105 d'arrière-plan, fonctions de shell, alias, tableaux indexés de taille
106 illimitée et calcul sur des entiers dans n'importe quelle base de 2 à
107 64. Bash est conforme au standard IEEE POSIX P1003.2/ISO 9945.2 Shell
108 and Tools. Bash est le shell par défaut de Mandrake. Vous devriez
109 l'installer du fait de sa puissance et de sa popularité. Vous finirez
110 probablement par l'utiliser.
111
112 %description -l pl.UTF-8
113 Bash (Bourne Again SHell) jest projektem GNU powłoki kompatybilnej z
114 sh oraz interpretera języka poleceń. Posiada użyteczne właściwości
115 powłok Korn (ksh) i C (csh). Większość skryptów sh może być
116 uruchamiana w bashu bez modyfikacji. Oferuje on kilka ulepszeń w
117 stosunku do sh, włączając edycję linii poleceń, nieograniczony rozmiar
118 historii poleceń, funkcje i aliasy, indeksowane tablice
119 nieograniczonych rozmiarów oraz arytmetykę całkowitoliczbową o
120 dowolnej podstawie od 2 do 64. W zamierzeniu ostatecznie ma być zgodny
121 ze standardem IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools.
122
123 %description -l pt_BR.UTF-8
124 Bash é um interpretador de comandos compatível com sh, que executa
125 comandos lidos da entrada padrão ou de um arquivo. Bash também
126 incorpora características úteis das shells Korn e C (ksh e csh). Bash
127 tem sido desenvolvido para ser uma implementação compatível com a
128 especificação IEEE Posix para shells e ferramentas (IEEE Working Group
129 1003.2).
130
131 %description -l ru.UTF-8
132 Bash - это sh-совместимый интерпретатор командного языка (shell),
133 исполняющий команды, поступающие со стандартного ввода или из файла.
134 Bash включает полезные расширения из интерпретаторов Korn и C shell
135 (ksh и csh).
136
137 Bash разрабатывается как реализация, отвечающая IEEE Posix Shell and
138 Tools specification (IEEE Working Group 1003.2).
139
140 %description -l tr.UTF-8
141 Bash standart girişten ya da bir dosyadan komut okuyup çalıştıran sh
142 uyumlu bir komut dili yorumlayıcısıdır. Aynı zamanda Korn ve C
143 kabuklarının (ksh ve csh) kullanışlı özelliklerini de kapsar. Bash,
144 IEEE Posix Kabuk ve Araç ayrıntılarına (IEEE Working Group 1003.2)
145 uyumlu bir uygulama olarak tasarlanmıştır.
146
147 %description -l uk.UTF-8
148 Bash - це sh-сумістний інтерпретатор командної мови (shell),
149 виконуючий команди зі стандартного вводу або з файла. Bash містить
150 користні розширення з інтерпретаторів Korn та C shell (ksh та csh).
151
152 Bash розроблявся як реалізація, що відповідає IEEE Posix Shell and
153 Tools specification (IEEE Working Group 1003.2).
154
155 %package static
156 Summary:        Statically linked GNU Bourne Again Shell (bash)
157 Summary(pl.UTF-8):      Statycznie skonsolidowany GNU Bourne Again Shell (bash)
158 Group:          Applications/Shells
159 Requires:       %{name} = %{version}-%{release}
160
161 %description static
162 Bash is a GNU project sh-compatible shell or command language
163 interpreter. Bash (Bourne Again shell) incorporates useful features
164 from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
165 be run by bash without modification. Bash offers several improvements
166 over sh, including command line editing, unlimited size command
167 history, job control, shell functions and aliases, indexed arrays of
168 unlimited size and integer arithmetic in any base from two to 64. Bash
169 is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
170 Shell and Tools standard. Bash is the default shell for Linux
171 Mandrake. You should install bash because of its popularity and power.
172 You'll probably end up using it. This package contains statically
173 linked version of bash.
174
175 %description static -l pl.UTF-8
176 Bash jest zaawansowaną powłoką, która wykonuje komendy czytane ze
177 standardowego wejścia (stdin) lub z pliku. Posiada właściwości powłok
178 Korn i C (ksh i csh). Bash jest również zaimplementowany IEEE Posix
179 Shell oraz jest zgodny ze specyfikacją - IEEE Working Group 1003.2. W
180 tym pakiecie jest wersja basha skonsolidowana statycznie.
181
182 %prep
183 %setup -q -n %{name}-%{ver} -a5
184 # official patches
185 %{?patchlevel:%patchset_patch 1 %{patchlevel}}
186 %patch0 -p1
187 %patch1 -p1
188 %patch2 -p1
189 %patch3 -p1
190 %patch4 -p1
191 %patch5 -p1
192 %patch6 -p1
193 %patch8 -p1
194 %{?with_bash_history:%patch9 -p1}
195 %patch10 -p1
196 %patch11 -p1
197 %patch12 -p1
198
199 sed -i -e 's#/usr/bin/printf#/bin/printf#g' tests/intl2.sub
200
201 %build
202 cp -f /usr/share/automake/config.* support
203 %{__autoconf}
204 for mode in %{?with_static:static} shared; do
205 %configure \
206         --enable-alias \
207         --enable-help-builtin \
208         --enable-history \
209         --enable-job-control \
210         --enable-restricted \
211         --enable-readline \
212         --with-curses \
213         --enable-extended-glob \
214         --enable-dparen-arithmetic \
215         --enable-separate-helpfiles \
216         --without-bash-malloc \
217         $([ "$mode" = "static" ] && echo "--enable-static-link") \
218         --with-installed-readline
219
220 %{__make} \
221         DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
222
223 [ "$mode" = "static" ] && mv -f bash bash.static
224 done
225
226 %{?with_tests:%{__make} tests}
227
228 %install
229 rm -rf $RPM_BUILD_ROOT
230 install -d $RPM_BUILD_ROOT{/bin,/etc/skel,%{_datadir}/%{name}}
231 %{?with_bash_history:install -d $RPM_BUILD_ROOT/var/log/bash_hist}
232
233 %{__make} install \
234         DESTDIR=$RPM_BUILD_ROOT
235
236 mv -f $RPM_BUILD_ROOT%{_bindir}/bash $RPM_BUILD_ROOT/bin
237 %{?with_static:install bash.static $RPM_BUILD_ROOT/bin}
238
239 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/bashrc
240 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
241
242 for d in es fr it ja ko nl pl ; do
243         install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
244         install man/$d/* $RPM_BUILD_ROOT%{_mandir}/$d/man1
245         echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/$d/man1/rbash.1
246 done
247
248 ln -sf bash $RPM_BUILD_ROOT/bin/rbash
249
250 install %{SOURCE2} $RPM_BUILD_ROOT/etc/skel/.bash_logout
251 install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
252 install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
253 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
254
255 # use our bugtracker, upstream will ignore reports from this anyway
256 rm -f $RPM_BUILD_ROOT%{_bindir}/bashbug
257
258 %find_lang %{name}
259
260 %clean
261 rm -rf $RPM_BUILD_ROOT
262
263 %post   -p <lua>
264 %lua_add_etc_shells /bin/bash /bin/rbash
265 os.execute("/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1")
266
267 %preun  -p <lua>
268 if arg[2] == 0 then
269         %lua_remove_etc_shells /bin/bash /bin/rbash
270 end
271
272 %postun -p      /sbin/postshell
273 -/usr/sbin/fix-info-dir -c %{_infodir}
274
275 %post static -p <lua>
276 %lua_add_etc_shells /bin/bash.static
277
278 %preun static -p <lua>
279 if arg[2] == 0 then
280         %lua_remove_etc_shells /bin/bash.static
281 end
282
283 %files -f %{name}.lang
284 %defattr(644,root,root,755)
285 %doc CHANGES NEWS README doc/{FAQ,INTRO}
286
287 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bashrc
288 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_logout
289 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_profile
290 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bashrc
291
292 %attr(755,root,root) /bin/bash
293 %attr(755,root,root) /bin/rbash
294
295 %{?with_bash_history:%attr(1733,root,root) %dir /var/log/bash_hist}
296 %{_infodir}/bash.info*
297 %{_mandir}/man1/*
298 %lang(es) %{_mandir}/es/man1/*
299 %lang(fr) %{_mandir}/fr/man1/*
300 %lang(it) %{_mandir}/it/man1/*
301 %lang(ja) %{_mandir}/ja/man1/*
302 %lang(ko) %{_mandir}/ko/man1/*
303 %lang(nl) %{_mandir}/nl/man1/*
304 %lang(pl) %{_mandir}/pl/man1/*
305 %dir %{_datadir}/%{name}
306 %doc %{_datadir}/%{name}/*
307
308 %if %{with static}
309 %files static
310 %defattr(644,root,root,755)
311 %attr(755,root,root) /bin/bash.static
312 %endif
This page took 0.064838 seconds and 3 git commands to generate.