]> git.pld-linux.org Git - packages/axis.git/blob - axis.spec
72a692e754767f080844f2fa1169953c89cf3f09
[packages/axis.git] / axis.spec
1 # TODO
2 #  - castor is needed by axis-1.2.1-0.2jpp.1.noarch
3 #  - package axis2, axis is obsolete. see NOTE below.
4 #  - build samples
5 #  - package war app
6 # NOTE
7 #  - it won't compile with java 1.6. see:
8 #    https://fcp.surfsite.org/modules/newbb/viewtopic.php?topic_id=55862&viewmode=flat&order=ASC&start=20
9
10 %bcond_with     java_sun
11 %define archivever %(echo %{version} | tr . _)
12 Summary:        A SOAP implementation in Java
13 Summary(pl.UTF-8):      Implementacja SOAP w Javie
14 Name:           axis
15 Version:        1.4
16 Release:        0.1
17 License:        Apache
18 Group:          Development/Languages/Java
19 Source0:        http://ws.apache.org/axis/dist/%{archivever}/%{name}-src-%{archivever}.tar.gz
20 # Source0-md5:  3dcce3cbd37f52d70ebeb858f90608dc
21 Source1:        %{name}-build.xml
22 Patch0:         %{name}-classpath.patch
23 Patch1:         %{name}-missing_xsd.patch
24 URL:            http://ws.apache.org/axis/
25 BuildRequires:  ant >= 1.6
26 BuildRequires:  ant-nodeps
27 %{!?with_java_sun:BuildRequires:        java-gcj-compat-devel}
28 %{?with_java_sun:BuildRequires: java-sun <= 1.5}
29 # BuildRequires:        jimi
30 # BuildRequires:        jms
31 BuildRequires:  httpunit
32 BuildRequires:  jaf
33 BuildRequires:  java-commons-discovery
34 BuildRequires:  java-commons-httpclient
35 BuildRequires:  java-commons-logging
36 BuildRequires:  java-commons-net
37 BuildRequires:  java-oro
38 BuildRequires:  java-xalan
39 BuildRequires:  java-xerces
40 BuildRequires:  java-xml-commons
41 BuildRequires:  java-xmlbeans
42 BuildRequires:  javamail
43 BuildRequires:  jpackage-utils
44 BuildRequires:  jsse
45 BuildRequires:  junit
46 BuildRequires:  logging-log4j
47 BuildRequires:  rpmbuild(macros) >= 1.300
48 BuildRequires:  servletapi5
49 BuildRequires:  wsdl4j
50 Requires:       httpunit
51 Requires:       jaf
52 Requires:       java-commons-discovery
53 Requires:       java-commons-httpclient
54 Requires:       java-commons-logging
55 Requires:       java-commons-net
56 Requires:       java-oro
57 Requires:       java-xalan
58 Requires:       java-xerces
59 Requires:       java-xml-commons
60 Requires:       java-xmlbeans
61 Requires:       javamail
62 Requires:       jpackage-utils
63 Requires:       jsse
64 Requires:       logging-log4j
65 Requires:       servletapi5
66 Requires:       wsdl4j
67 BuildArch:      noarch
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %description
71 Apache AXIS is an implementation of the SOAP ("Simple Object Access
72 Protocol") submission to W3C.
73
74 From the draft W3C specification:
75
76 SOAP is a lightweight protocol for exchange of information in a
77 decentralized, distributed environment. It is an XML based protocol
78 that consists of three parts: an envelope that defines a framework for
79 describing what is in a message and how to process it, a set of
80 encoding rules for expressing instances of application-defined
81 datatypes, and a convention for representing remote procedure calls
82 and responses.
83
84 This project is a follow-on to the Apache SOAP project.
85
86 %description -l pl.UTF-8
87 Apache AXIS to implementacja SOAP ("Simple Object Access Protocol")
88 przekazanego do W3C.
89
90 Z projektu specyfikacji W3C:
91
92 SOAP to lekki protokół do wymiany informacji w scentralizowanym,
93 rozproszonym środowisku. Jest to protokół oparty na XML-u, składający
94 się z trzech części: koperty definiującej szkielet do opisu zawartości
95 i sposobu przetwarzania komunikatu, zbioru reguł kodowania do
96 wyrażania instancji typów danych zdefiniowanych w aplikacji oraz
97 konwencji reprezentowania zdalnych wywołań procedur i odpowiedzi.
98
99 Ten projekt jest następcą projektu Apache SOAP.
100
101 %package javadoc
102 Summary:        Javadoc for %{name}
103 Summary(pl.UTF-8):      Dokumentacja javadoc dla pakietu %{name}
104 Group:          Documentation
105 Requires:       jpackage-utils
106
107 %description javadoc
108 Javadoc for %{name}.
109
110 %description javadoc -l pl.UTF-8
111 Dokumentacja javadoc dla pakietu %{name}.
112
113 %package manual
114 Summary:        Manual for %{name}
115 Summary(pl.UTF-8):      Podręcznik do pakietu %{name}
116 Group:          Development/Languages/Java
117
118 %description manual
119 Documentation for %{name}.
120
121 %description manual -l pl.UTF-8
122 Podręcznik do pakietu %{name}.
123
124 %prep
125 %setup -q -n %{name}-%{archivever}
126
127 # Remove provided binaries
128 find -name '*.jar' | xargs rm -v
129 find -name '*.class' | xargs rm -v
130
131 %patch0 -p1
132 %patch1 -p1
133
134 cp %{SOURCE1} build.xml
135
136 %build
137 export JAVA_HOME=%{java_home}
138 echo $JAVA_HOME
139
140 activation_jar=$(find-jar activation)
141 commons_logging_jar=$(find-jar commons-logging)
142 commons_discovery_jar=$(find-jar commons-discovery)
143 commons_httpclient_jar=$(find-jar commons-httpclient)
144 commons_net_jar=$(find-jar commons-net)
145 log4j_core_jar=$(find-jar log4j)
146 jsse_jar=$(find-jar jsse)
147 junit_jar=$(find-jar junit)
148 mailapi_jar=$(find-jar mail)
149 regexp_jar=$(find-jar oro)
150 servlet_jar=$(find-jar servletapi5)
151 tools_jar=$(find-jar tools)
152 wsdl4j_jar=$(find-jar wsdl4j)
153 xalan_jar=$(find-jar xalan)
154 xerces_jar=$(find-jar xerces-j2)
155 xercesImpl_jar=$(find-jar xercesImpl)
156 xml_apis_jar=$(find-jar xml-commons-apis)
157 xmlParsersAPIs_jar=$(find-jar xerces-j2)
158 xmlbeans_jar=$(find-jar xmlbeans)
159 %{!?with_java_sun:libgcj_jar=$(find-jar libgcj)}
160
161 #httpunit_jar=$(find-jar httpunit)
162 #xmlunit_jar=$(find-jar xmlunit)
163 #jimi_jar=$(find-jar jimi)
164
165 CLASSPATH=$wsdl4j_jar:$commons_logging_jar:$commons_discovery_jar
166 %{!?with_java_sun:CLASSPATH=$CLASSPATH:$(build-classpath ecj tools)}
167 export CLASSPATH
168
169 %ant dist \
170         -Dactivation.jar=$activation_jar \
171         -Dcommons-logging.jar=$commons_logging_jar \
172         -Dcommons-discovery.jar=$commons_discovery_jar \
173         -Dcommons-httpclient.jar=$commons_httpclient_jar \
174         -Dcommons-net.jar=$commons_net_jar \
175         -Dlog4j-core.jar=$log4j_core_jar \
176         -Djsse.jar=$jsse_jar \
177         -Djunit.jar=$junit_jar \
178         -Dmailapi.jar=$mailapi_jar \
179         -Dregexp.jar=$regexp_jar \
180         -Dservlet.jar=$servlet_jar \
181         -Dtools.jar=$tools_jar \
182         -Dwsdl4j.jar=$wsdl4j_jar \
183         -Dxalan.jar=$xalan_jar \
184         -Dxerces.jar=$xerces_jar \
185         -DxercesImpl.jar=$xercesImpl_jar \
186         -Dxml-apis.jar=$xml_apis_jar \
187         -DxmlParsersAPIs.jar=$xmlParsersAPIs_jar \
188         -Dxmlbeans.jar=$xmlbeans_jar \
189         %{!?with_java_sun:-Dsun.boot.class.path="$libgcj_jar:[-org.w3c.dom/*]"}
190
191 %install
192 rm -rf $RPM_BUILD_ROOT
193
194 install -d $RPM_BUILD_ROOT%{_javadir}/%{name}
195
196 cd build/lib
197 install axis.jar axis-ant.jar saaj.jar jaxrpc.jar \
198         $RPM_BUILD_ROOT%{_javadir}/%{name}
199 cd -
200
201 cd $RPM_BUILD_ROOT%{_javadir}/%{name}
202 for jar in *.jar ; do
203         vjar=$(echo $jar | sed s+.jar+-%{version}.jar+g)
204         mv $jar $vjar
205         ln -fs $vjar $jar
206 done
207 cd -
208
209 ### Javadoc
210 install -d $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
211 cp -a build/javadocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
212 ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name} # ghost symlink
213
214 %clean
215 rm -rf $RPM_BUILD_ROOT
216
217 %post javadoc
218 ln -nfs %{name}-%{version} %{_javadocdir}/%{name}
219
220 %files
221 %defattr(644,root,root,755)
222 %doc LICENSE README release-notes.html changelog.html
223 %dir %{_javadir}/%{name}
224 %{_javadir}/%{name}/*.jar
225
226 %files javadoc
227 %defattr(644,root,root,755)
228 %{_javadocdir}/%{name}-%{version}
229 %ghost %{_javadocdir}/%{name}
230
231 %files manual
232 %defattr(644,root,root,755)
233 %doc docs/*
This page took 0.34319 seconds and 2 git commands to generate.