]> git.pld-linux.org Git - packages/automake.git/blob - automake.spec
d86fb069d2e97949dc9c8067d0cfc0631f04a9ad
[packages/automake.git] / automake.spec
1 #
2 # Conditional build:
3 %bcond_with     bootstrap       # without full regeneration
4
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        GNU automake - Makefile configuration tools
7 Summary(de.UTF-8):      GNU automake - Makefile-Konfigurationstools
8 Summary(es.UTF-8):      GNU automake - herramientas de configuración de Makefile
9 Summary(fr.UTF-8):      automake de GNU - Outils de configuration des makefiles
10 Summary(ko.UTF-8):      스스로 Makefile을 만들어주는 GNU 도구
11 Summary(pl.UTF-8):      GNU Automake - generator plików Makefile
12 Summary(pt_BR.UTF-8):   GNU automake - ferramentas de configuração de Makefile
13 Summary(ru.UTF-8):      GNU automake - инструменты для автоматической генерации Makefile'ов
14 Summary(tr.UTF-8):      Makefile yapılandırma araçları
15 Summary(uk.UTF-8):      GNU automake - інструменти для автоматичної генерації Makefile'ів
16 Name:           automake
17 Version:        1.14
18 Release:        2
19 Epoch:          1
20 License:        GPL v2+
21 Group:          Development/Building
22 Source0:        http://ftp.gnu.org/gnu/automake/%{name}-%{version}.tar.xz
23 # Source0-md5:  cb3fba6d631cddf12e230fd0cc1890df
24 Patch0:         %{name}-info.patch
25 Patch1:         %{name}-man.patch
26 Patch2:         %{name}-no_versioned_dir.patch
27 Patch3:         %{name}-morearchs.patch
28 URL:            http://sources.redhat.com/automake/
29 BuildRequires:  autoconf >= 2.69
30 %if %{without bootstrap}
31 BuildRequires:  automake >= 1:1.14
32 %endif
33 BuildRequires:  help2man
34 BuildRequires:  rpm-perlprov
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  texinfo >= 4.9
37 BuildRequires:  xz
38 Requires(pre):  fileutils
39 Requires:       filesystem >= 3.0-2
40 Requires:       perl(File::Glob)
41 %if %(%{__perl} -le 'use threads; print 1' || echo 0)
42 # required only if perl was built with threads
43 Requires:       perl(Thread::Queue)
44 Requires:       perl(threads)
45 %endif
46 Conflicts:      autoconf < 2.65
47 Conflicts:      libtool < 2:1.5-11
48 Conflicts:      texinfo < 4.9
49 BuildArch:      noarch
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %define         _enable_debug_packages  0
53
54 %description
55 Automake is an experimental Makefile generator. Automake was inspired
56 by the 4.4BSD make and include files, but aims to be portable and to
57 conform to the GNU standards for Makefile variables and targets.
58
59 %description -l de.UTF-8
60 Automake ist ein experimenteller Makefile-Generator, inspiriert durch
61 die 4.4BSD-Make und Include-Dateien, der jedoch auf Portabilität und
62 Konformität mit den GNU-Standards für Makefile-Variable und Targets
63 abzielt.
64
65 %description -l es.UTF-8
66 Automake es un creador experimental de Makefiles. Fue inspirado en el
67 4.4BSD make y incluye archivos, pero visa ser portátil y compatible
68 con los padrones GNU para variables y dianas de Makefile.
69
70 %description -l fr.UTF-8
71 automake est un générateur expérimental de makefiles. Il a été inspiré
72 par le make de BSD 4.4, mais se veut portable et conforme aux
73 standards GNU pour les variables et les cibles des makefiles.
74
75 %description -l pl.UTF-8
76 Automake jest eksperymentalnym generatorem plików Makefile'a.
77 Narzędzie to jest wzorowane na make i plikach nagłówkowych z systemu
78 4.4BSD. Umożliwia ono generowanie plików Makefile w oderwaniu od
79 platformy systemowej będąc jednocześnie zgodnym ze standardami GNU.
80
81 %description -l pt_BR.UTF-8
82 Automake é um gerador experimental de Makefiles. Ele foi inspirado
83 pelo 4.4BSD make e inclui arquivos, mas visa ser portável e compatível
84 com os padrões GNU para variáveis e alvos de Makefile.
85
86 %description -l ru.UTF-8
87 Automake - это экспериментальный генератор Makefile'ов. Идея была
88 навеяна программой make и хедерами из 4.4BSD, но automake претендует
89 на то, чтобы быть портабельной и соответствовать стандартам GNU на
90 переменные и цели Makefile'ов.
91
92 %description -l tr.UTF-8
93 Automake deneysel bir Makefile üreticisidir. 4.4BSD make ve include
94 dosyalarından esinlenilmistir, ama amaç taşınabilir olmak ve Makefile
95 değişkenleri ve hedefleri için GNU standartlarına uyum göstermektir.
96
97 %description -l uk.UTF-8
98 Automake - це експериментальний генератор Makefile'ів. Ідея була
99 навіяна програмою make та хедерами з 4.4BSD, але automake має за ціль
100 мобільність та відповідність стандартам GNU на змінні ті цілі
101 Makefile'ів.
102
103 %prep
104 %setup -q
105 %patch0 -p1
106 %patch1 -p1
107 %patch2 -p1
108 %patch3 -p1
109
110 %if %{without bootstrap}
111 # prepare temporary copy of m4 dir without amversion.m4 (which causes automake version check)
112 mkdir m4-tmp
113 cd m4-tmp
114 ln -s ../m4/[!a]*.m4 ../m4/a[!m]*.m4 .
115 %endif
116
117 %build
118 %if %{without bootstrap}
119 %{__aclocal} -I m4-tmp
120 %endif
121 %{__autoconf}
122 %if %{without bootstrap}
123 %{__automake}
124 %endif
125
126 # NOTE: _target macro becames "noarch" if ./builder passes --target=noarch, so
127 # be sure use plain /usr/bin/rpmbuild.
128 %configure \
129         --host=%{_host} \
130         --build=%{_host}
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 install -d $RPM_BUILD_ROOT%{_mandir}/man1
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT \
139         pkgvdatadir=%{_datadir}/automake
140
141 cp -a aclocal.1 automake.1 $RPM_BUILD_ROOT%{_mandir}/man1
142
143 # not needed when dir/files are handled by package system
144 %{__rm} $RPM_BUILD_ROOT%{_datadir}/aclocal/README
145
146 rm -f $RPM_BUILD_ROOT%{_infodir}/dir*
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post   -p /sbin/postshell
152 -/usr/sbin/fix-info-dir -c %{_infodir}
153
154 %postun -p /sbin/postshell
155 -/usr/sbin/fix-info-dir -c %{_infodir}
156
157 %files
158 %defattr(644,root,root,755)
159 %doc AUTHORS ChangeLog NEWS README THANKS
160 %attr(755,root,root) %{_bindir}/aclocal*
161 %attr(755,root,root) %{_bindir}/automake*
162 %{_infodir}/automake.info*
163 %{_infodir}/automake-history.info*
164 %{_mandir}/man1/aclocal.1*
165 %{_mandir}/man1/aclocal-1.14.1*
166 %{_mandir}/man1/automake.1*
167 %{_mandir}/man1/automake-1.14.1*
168
169 %{_datadir}/aclocal-1.14
170 %dir %{_datadir}/automake
171 %{_datadir}/automake/am
172 %{_datadir}/automake/Automake
173 %{_datadir}/automake/COPYING
174 %{_datadir}/automake/INSTALL
175 %{_datadir}/automake/texinfo.tex
176 %attr(755,root,root) %{_datadir}/automake/ar-lib
177 %attr(755,root,root) %{_datadir}/automake/compile
178 %attr(755,root,root) %{_datadir}/automake/config.guess
179 %attr(755,root,root) %{_datadir}/automake/config.sub
180 %attr(755,root,root) %{_datadir}/automake/depcomp
181 %attr(755,root,root) %{_datadir}/automake/install-sh
182 %attr(755,root,root) %{_datadir}/automake/mdate-sh
183 %attr(755,root,root) %{_datadir}/automake/missing
184 %attr(755,root,root) %{_datadir}/automake/mkinstalldirs
185 %attr(755,root,root) %{_datadir}/automake/py-compile
186 %attr(755,root,root) %{_datadir}/automake/tap-driver.pl
187 %attr(755,root,root) %{_datadir}/automake/tap-driver.sh
188 %attr(755,root,root) %{_datadir}/automake/test-driver
189 %attr(755,root,root) %{_datadir}/automake/ylwrap
This page took 0.054515 seconds and 2 git commands to generate.