]> git.pld-linux.org Git - packages/automake.git/blob - automake.spec
71b575e3726d8065060b88634185ad2853f5a66a
[packages/automake.git] / automake.spec
1 #
2 # Conditional build:
3 %bcond_with     bootstrap       # without full regeneration
4
5 Summary:        GNU automake - Makefile configuration tools
6 Summary(de.UTF-8):      GNU automake - Makefile-Konfigurationstools
7 Summary(es.UTF-8):      GNU automake - herramientas de configuración de Makefile
8 Summary(fr.UTF-8):      automake de GNU - Outils de configuration des makefiles
9 Summary(ko.UTF-8):      스스로 Makefile을 만들어주는 GNU 도구
10 Summary(pl.UTF-8):      GNU Automake - generator plików Makefile
11 Summary(pt_BR.UTF-8):   GNU automake - ferramentas de configuração de Makefile
12 Summary(ru.UTF-8):      GNU automake - инструменты для автоматической генерации Makefile'ов
13 Summary(tr.UTF-8):      Makefile yapılandırma araçları
14 Summary(uk.UTF-8):      GNU automake - інструменти для автоматичної генерації Makefile'ів
15 Name:           automake
16 Version:        1.16.3
17 Release:        1
18 Epoch:          1
19 License:        GPL v2+
20 Group:          Development/Building
21 Source0:        https://ftp.gnu.org/gnu/automake/%{name}-%{version}.tar.xz
22 # Source0-md5:  c27f608a4e1f302ec7ce42f1251c184e
23 Patch0:         %{name}-info.patch
24 Patch1:         %{name}-man.patch
25 Patch2:         %{name}-no_versioned_dir.patch
26
27 Patch4:         revert-debian-python-hacks.patch
28 URL:            http://sources.redhat.com/automake/
29 BuildRequires:  autoconf >= 2.69
30 %if %{without bootstrap}
31 BuildRequires:  automake >= 1:1.14
32 %endif
33 BuildRequires:  help2man
34 BuildRequires:  rpm-perlprov
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  texinfo >= 4.9
37 BuildRequires:  xz
38 Requires(pre):  fileutils
39 Requires:       filesystem >= 3.0-2
40 Requires:       perl(File::Glob)
41 %if %(%{__perl} -le 'use threads; print 1' || echo 0)
42 # required only if perl was built with threads
43 Requires:       perl(Thread::Queue)
44 Requires:       perl(threads)
45 %endif
46 Conflicts:      autoconf < 2.65
47 Conflicts:      libtool < 2:1.5-11
48 Conflicts:      texinfo < 4.9
49 BuildArch:      noarch
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %define         ver_maj         %(echo %{version} | cut -d. -f1-2)
53 %define         _enable_debug_packages  0
54
55 %description
56 Automake is an experimental Makefile generator. Automake was inspired
57 by the 4.4BSD make and include files, but aims to be portable and to
58 conform to the GNU standards for Makefile variables and targets.
59
60 %description -l de.UTF-8
61 Automake ist ein experimenteller Makefile-Generator, inspiriert durch
62 die 4.4BSD-Make und Include-Dateien, der jedoch auf Portabilität und
63 Konformität mit den GNU-Standards für Makefile-Variable und Targets
64 abzielt.
65
66 %description -l es.UTF-8
67 Automake es un creador experimental de Makefiles. Fue inspirado en el
68 4.4BSD make y incluye archivos, pero visa ser portátil y compatible
69 con los padrones GNU para variables y dianas de Makefile.
70
71 %description -l fr.UTF-8
72 automake est un générateur expérimental de makefiles. Il a été inspiré
73 par le make de BSD 4.4, mais se veut portable et conforme aux
74 standards GNU pour les variables et les cibles des makefiles.
75
76 %description -l pl.UTF-8
77 Automake jest eksperymentalnym generatorem plików Makefile'a.
78 Narzędzie to jest wzorowane na make i plikach nagłówkowych z systemu
79 4.4BSD. Umożliwia ono generowanie plików Makefile w oderwaniu od
80 platformy systemowej będąc jednocześnie zgodnym ze standardami GNU.
81
82 %description -l pt_BR.UTF-8
83 Automake é um gerador experimental de Makefiles. Ele foi inspirado
84 pelo 4.4BSD make e inclui arquivos, mas visa ser portável e compatível
85 com os padrões GNU para variáveis e alvos de Makefile.
86
87 %description -l ru.UTF-8
88 Automake - это экспериментальный генератор Makefile'ов. Идея была
89 навеяна программой make и хедерами из 4.4BSD, но automake претендует
90 на то, чтобы быть портабельной и соответствовать стандартам GNU на
91 переменные и цели Makefile'ов.
92
93 %description -l tr.UTF-8
94 Automake deneysel bir Makefile üreticisidir. 4.4BSD make ve include
95 dosyalarından esinlenilmistir, ama amaç taşınabilir olmak ve Makefile
96 değişkenleri ve hedefleri için GNU standartlarına uyum göstermektir.
97
98 %description -l uk.UTF-8
99 Automake - це експериментальний генератор Makefile'ів. Ідея була
100 навіяна програмою make та хедерами з 4.4BSD, але automake має за ціль
101 мобільність та відповідність стандартам GNU на змінні ті цілі
102 Makefile'ів.
103
104 %prep
105 %setup -q
106 %patch0 -p1
107 %patch1 -p1
108 %patch2 -p1
109
110 %patch4 -p1
111
112 %if %{without bootstrap}
113 # prepare temporary copy of m4 dir without amversion.m4 (which causes automake version check)
114 mkdir m4-tmp
115 cd m4-tmp
116 ln -s ../m4/[!a]*.m4 ../m4/a[!m]*.m4 .
117 %endif
118
119 %build
120 %if %{without bootstrap}
121 %{__aclocal} -I m4-tmp
122 %endif
123 %{__autoconf}
124 %if %{without bootstrap}
125 %{__automake}
126 %endif
127
128 %configure \
129 %if "%{_host_cpu}" != "x32"
130         --host=%{_host} \
131         --build=%{_host} \
132 %endif
133         --disable-silent-rules
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 install -d $RPM_BUILD_ROOT%{_mandir}/man1
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT \
142         pkgvdatadir=%{_datadir}/automake
143
144 cp -a aclocal.1 automake.1 $RPM_BUILD_ROOT%{_mandir}/man1
145
146 # not needed when dir/files are handled by package system
147 %{__rm} $RPM_BUILD_ROOT%{_datadir}/aclocal/README
148
149 rm -f $RPM_BUILD_ROOT%{_infodir}/dir*
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post   -p /sbin/postshell
155 -/usr/sbin/fix-info-dir -c %{_infodir}
156
157 %postun -p /sbin/postshell
158 -/usr/sbin/fix-info-dir -c %{_infodir}
159
160 %files
161 %defattr(644,root,root,755)
162 %doc AUTHORS ChangeLog NEWS README THANKS
163 %attr(755,root,root) %{_bindir}/aclocal*
164 %attr(755,root,root) %{_bindir}/automake*
165 %{_infodir}/automake.info*
166 %{_infodir}/automake-history.info*
167 %{_mandir}/man1/aclocal.1*
168 %{_mandir}/man1/aclocal-%{ver_maj}.1*
169 %{_mandir}/man1/automake.1*
170 %{_mandir}/man1/automake-%{ver_maj}.1*
171
172 %{_datadir}/aclocal-%{ver_maj}
173 %dir %{_datadir}/automake
174 %{_datadir}/automake/am
175 %{_datadir}/automake/Automake
176 %{_datadir}/automake/COPYING
177 %{_datadir}/automake/INSTALL
178 %{_datadir}/automake/texinfo.tex
179 %attr(755,root,root) %{_datadir}/automake/ar-lib
180 %attr(755,root,root) %{_datadir}/automake/compile
181 %attr(755,root,root) %{_datadir}/automake/config.guess
182 %attr(755,root,root) %{_datadir}/automake/config.sub
183 %attr(755,root,root) %{_datadir}/automake/depcomp
184 %attr(755,root,root) %{_datadir}/automake/install-sh
185 %attr(755,root,root) %{_datadir}/automake/mdate-sh
186 %attr(755,root,root) %{_datadir}/automake/missing
187 %attr(755,root,root) %{_datadir}/automake/mkinstalldirs
188 %attr(755,root,root) %{_datadir}/automake/py-compile
189 %attr(755,root,root) %{_datadir}/automake/tap-driver.sh
190 %attr(755,root,root) %{_datadir}/automake/test-driver
191 %attr(755,root,root) %{_datadir}/automake/ylwrap
This page took 0.054271 seconds and 2 git commands to generate.