]> git.pld-linux.org Git - packages/autoconf-archive.git/commitdiff
- add support for python 3.10, rel 2 auto/th/autoconf-archive-2022.02.11-2
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 5 Apr 2022 14:42:18 +0000 (16:42 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 5 Apr 2022 14:42:18 +0000 (16:42 +0200)
autoconf-archive.spec
python-3.10.patch [new file with mode: 0644]

index e0fe800c230a4c81c79ab764851076ba2c7ccf39..4df32b7b4c35f1b63610aad0a7c9566951826576 100644 (file)
@@ -2,12 +2,13 @@ Summary:      The Autoconf Macro Archive
 Summary(pl.UTF-8):     Archiwum makr Autoconfa
 Name:          autoconf-archive
 Version:       2022.02.11
-Release:       1
+Release:       2
 License:       GPL v3+ with exceptions
 Group:         Development/Tools
 Source0:       http://ftp.gnu.org/gnu/autoconf-archive/%{name}-%{version}.tar.xz
 # Source0-md5: d140e95be64f0aa7369f82e3caae4730
 Patch0:                %{name}-info.patch
+Patch1:                python-3.10.patch
 URL:           http://www.gnu.org/software/autoconf-archive/
 BuildRequires: tar >= 1:1.22
 BuildRequires: texinfo
@@ -30,6 +31,7 @@ przypadkowych wspierających z całego Internetu.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %configure
diff --git a/python-3.10.patch b/python-3.10.patch
new file mode 100644 (file)
index 0000000..f9f1f8d
--- /dev/null
@@ -0,0 +1,39 @@
+diff --git a/m4/ax_python_devel.m4 b/m4/ax_python_devel.m4
+--- a/m4/ax_python_devel.m4
++++ b/m4/ax_python_devel.m4
+@@ -116,9 +116,11 @@
+       #
+       if test -n "$1"; then
+               AC_MSG_CHECKING([for a version of Python $1])
+-              ac_supports_python_ver=`$PYTHON -c "import sys; \
+-                      ver = sys.version.split ()[[0]]; \
+-                      print (ver $1)"`
++              read -r op ver <<< "$1"
++              script="m4_join([;], [import sys], [ver = sys.version_info[:3]],
++                             [minver = tuple(map(int, ${ver}.split('.')))],
++                             [print (ver ${op} minver)])"
++              ac_supports_python_ver=`$PYTHON -c "$script"`
+               if test "$ac_supports_python_ver" = "True"; then
+                  AC_MSG_RESULT([yes])
+               else
+@@ -208,7 +208,7 @@
+                               ac_python_version=$PYTHON_VERSION
+                       else
+                               ac_python_version=`$PYTHON -c "import sys; \
+-                                      print (sys.version[[:3]])"`
++                                      print ("%d.%d" % sys.version_info[[:2]])"`
+                       fi
+               fi
+diff --git a/m4/ax_python.m4 b/m4/ax_python.m4
+--- a/m4/ax_python.m4
++++ b/m4/ax_python.m4
+@@ -55,7 +55,7 @@
+ AC_DEFUN([AX_PYTHON],
+ [AC_MSG_CHECKING(for python build information)
+ AC_MSG_RESULT([])
+-for python in python3.9 python3.8 python3.7 python3.6 python3.5 python3.4 python3.3 python3.2 python3.1 python3.0 python2.7 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python; do
++for python in python3.11 python3.10 python3.9 python3.8 python3.7 python3.6 python3.5 python3.4 python3.3 python3.2 python3.1 python3.0 python2.7 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python; do
+ AC_CHECK_PROGS(PYTHON_BIN, [$python])
+ ax_python_bin=$PYTHON_BIN
+ if test x$ax_python_bin != x; then
This page took 0.089856 seconds and 4 git commands to generate.