]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- cut off Vendor
[packages/arts.git] / arts.spec
1 Summary:        aRts sound server
2 Summary(pl):    Serwer d¼wiêku
3 Summary(pt_BR): Servidor de sons usado pelo KDE
4 Name:           arts
5 %define _kdever 3.0.4
6 Version:        1.0.4
7 Release:        3
8 Epoch:          11
9 License:        LGPL
10 Group:          Libraries
11 Source0:        ftp://ftp.kde.org/pub/kde/stable/%{_kdever}/src/%{name}-%{version}.tar.bz2
12 %ifnarch sparc sparcv9 sparc64
13 BuildRequires:  alsa-lib-devel
14 %endif
15 BuildRequires:  audiofile-devel
16 BuildRequires:  glib2-devel >= 2.0.0
17 BuildRequires:  libjpeg-devel
18 BuildRequires:  libpng-devel
19 # not needed, only ./configure check for this
20 #BuildRequires: libvorbis-devel
21 #BuildRequires: mad-devel
22 BuildRequires:  pkgconfig
23 BuildRequires:  qt-devel >= 3.0.5
24 URL:            http://www.kde.org/
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _prefix         /usr/X11R6
28 %define         _htmldir        /usr/share/doc/kde/HTML
29
30 %description
31 aRts sound server.
32
33 %description -l pl
34 Serwer d¼wiêku aRts.
35
36 %description -l pt_BR
37 O aRts é um sintetizador analógico em tempo real que é completamente
38 modular. Você pode criar sons e músicas (síntese em tempo real de
39 midi) usando pequenos módulos como oscilador para criar waveforms,
40 vários filtros, mixers, faders, etc. Você pode configurar tudo através
41 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
42 design foi escolhido para permitir que outras aplicações usem o aRts
43 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
44 outros.
45
46 %package X11
47 Summary:        X11 dependent part of aRts
48 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
49 Group:          X11/Libraries
50
51 %description X11
52 X11 dependent part of aRts.
53
54 %description X11 -l pl
55 Czê¶æ aRts wymagaj±ca X11.
56
57 %package qt
58 Summary:        QT dependend part of aRts
59 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
60 Group:          X11/Libraries
61 Requires:       %{name} >= %{version}
62 Requires:       qt >= 3.0.5
63
64 %description qt
65 QT dependend part of aRts.
66
67 %description qt -l pl
68 Czê¶æ aRts wymagaj±ca QT.
69
70 %package devel
71 Summary:        Sound server - header files
72 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
73 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
74 Group:          Development/Libraries
75 Requires:       qt-devel >= 3.0.3
76 Requires:       %{name} >= %{version}
77
78 %description devel
79 Header files required to compile programs using arts.
80
81 %description devel -l pl
82 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
83 arts.
84
85 %description devel -l pt_BR
86 Arquivos para desenvolvimento com o o aRts.
87
88 %package glib
89 Summary:        GLib dependend part of aRts
90 Summary(pl):    Czê¶æ aRts wymagaj±ca GLib
91 Group:          X11/Libraries
92
93 %description glib
94 GLib dependend part of aRts.
95
96 %description glib -l pl
97 Czê¶æ aRts wymagaj±ca GLib.
98
99 %prep
100 %setup -q
101
102 %build
103 kde_htmldir="%{_htmldir}"; export kde_htmldir
104 kde_icondir="%{_pixmapsdir}"; export kde_icondir
105
106 #%{__make} -f Makefile.cvs
107
108 %configure \
109         --%{?debug:en}%{!?debug:dis}able-debug \
110         --enable-final \
111 %ifnarch sparc sparcv9 sparc64
112         --with-alsa \
113 %endif
114         --disable-rpath \
115         --with-xinerama
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install DESTDIR=$RPM_BUILD_ROOT
123
124 %post   -p /sbin/ldconfig
125 %postun -p /sbin/ldconfig
126
127 %post   X11 -p /sbin/ldconfig
128 %postun X11 -p /sbin/ldconfig
129
130 %post   qt -p /sbin/ldconfig
131 %postun qt -p /sbin/ldconfig
132
133 %post   glib -p /sbin/ldconfig
134 %postun glib -p /sbin/ldconfig
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %files
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_bindir}/artscat
142 %attr(755,root,root) %{_bindir}/artsd
143 %attr(755,root,root) %{_bindir}/artsdsp
144 %attr(755,root,root) %{_bindir}/artsplay
145 %attr(755,root,root) %{_bindir}/artsrec
146 %attr(755,root,root) %{_bindir}/artsshell
147 %attr(755,root,root) %{_bindir}/artswrapper
148 %attr(755,root,root) %{_libdir}/lib[am]*.so.*.*
149 %attr(755,root,root) %{_libdir}/libs[!h]*.so.*.*
150 %{_libdir}/lib[ams]*.la
151 %attr(755,root,root) %{_libdir}/libkmedia*.so.*.*
152 %{_libdir}/libkmedia*.la
153 %{_libdir}/mcop
154
155 %files X11
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
158 %{_libdir}/libx11globalcomm.la
159
160 %files qt
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
163 %{_libdir}/libqtmcop.la
164
165 %files glib
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
168 %{_libdir}/libgmcop.la
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_bindir}/artsc-config
173 %attr(755,root,root) %{_bindir}/mcopidl
174 %{_libdir}/lib[mqsxg]*.so
175 %{_libdir}/libarts[!k]*.so
176 %{_libdir}/libkmedia*.so
177 %{_includedir}/arts
178 %{_includedir}/artsc
This page took 0.064878 seconds and 4 git commands to generate.