]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- fixed epoch:version issue
[packages/arts.git] / arts.spec
1 #
2 # _with_nas             - enable NAS audio support
3 # _without_alsa         - disable ALSA support
4 #
5 %ifarch sparc sparcv9 sparc64
6 %define         _without_alsa   1
7 %endif
8 Summary:        aRts sound server
9 Summary(pl):    Serwer d¼wiêku
10 Summary(pt_BR): Servidor de sons usado pelo KDE
11 Name:           arts
12 Version:        1.1.2
13 Release:        1
14 Epoch:          12
15 License:        LGPL
16 Vendor:         The KDE Team
17 Group:          Libraries
18 Source0:        ftp://ftp.kde.org/pub/kde/stable/3.1.2/src/%{name}-%{version}.tar.bz2
19 # Source0-md5:  5d5a1858f8dcf0d88600291899dff75b
20 %{!?_without_alsa:BuildRequires:        alsa-lib-devel}
21 BuildRequires:  audiofile-devel
22 BuildRequires:  glib2-devel >= 2.0.0
23 BuildRequires:  libjpeg-devel
24 BuildRequires:  libpng-devel
25 # not needed, only ./configure check for this
26 #BuildRequires: libvorbis-devel
27 #BuildRequires: mad-devel
28 %{?_with_nas:BuildRequires:     nas-devel}
29 BuildRequires:  pkgconfig
30 BuildRequires:  qt-devel >= 3.1
31 URL:            http://www.kde.org/
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _htmldir        /usr/share/doc/kde/HTML
35
36 %description
37 aRts sound server.
38
39 %description -l pl
40 Serwer d¼wiêku aRts.
41
42 %description -l pt_BR
43 O aRts é um sintetizador analógico em tempo real que é completamente
44 modular. Você pode criar sons e músicas (síntese em tempo real de
45 midi) usando pequenos módulos como oscilador para criar waveforms,
46 vários filtros, mixers, faders, etc. Você pode configurar tudo através
47 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
48 design foi escolhido para permitir que outras aplicações usem o aRts
49 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
50 outros.
51
52 %package X11
53 Summary:        X11 dependent part of aRts
54 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
55 Group:          X11/Libraries
56
57 %description X11
58 X11 dependent part of aRts.
59
60 %description X11 -l pl
61 Czê¶æ aRts wymagaj±ca X11.
62
63 %package qt
64 Summary:        QT dependend part of aRts
65 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
66 Group:          X11/Libraries
67 Requires:       %{name} >= %{epoch}:%{version}
68 Requires:       qt >= 3.1
69
70 %description qt
71 QT dependend part of aRts.
72
73 %description qt -l pl
74 Czê¶æ aRts wymagaj±ca QT.
75
76 %package devel
77 Summary:        Sound server - header files
78 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
79 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
80 Group:          Development/Libraries
81 Requires:       qt-devel >= 3.1
82 Requires:       %{name} >= %{epoch}:%{version}
83 %{?_with_nas:Requires:  nas-devel}
84
85 %description devel
86 Header files required to compile programs using arts.
87
88 %description devel -l pl
89 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
90 arts.
91
92 %description devel -l pt_BR
93 Arquivos para desenvolvimento com o o aRts.
94
95 %package glib
96 Summary:        GLib dependend part of aRts
97 Summary(pl):    Czê¶æ aRts wymagaj±ca GLib
98 Group:          X11/Libraries
99 Requires:       glib >= 1.2.6
100
101 %description glib
102 GLib dependend part of aRts.
103
104 %description glib -l pl
105 Czê¶æ aRts wymagaj±ca GLib.
106
107 %prep
108 %setup -q
109
110 %build
111 kde_htmldir="%{_htmldir}"; export kde_htmldir
112 kde_icondir="%{_pixmapsdir}"; export kde_icondir
113
114 %configure \
115         --%{?debug:en}%{!?debug:dis}able-debug \
116         --disable-rpath \
117         --enable-final \
118         --with-xinerama \
119         --with%{?_without_alsa:out}-alsa
120
121 %if %{!?_with_nas:1}0
122 # Cannot patch configure.in because it does not rebuild correctly on ac25
123 sed -e 's@#define HAVE_LIBAUDIONAS 1@/* #undef HAVE_LIBAUDIONAS */@' \
124         < config.h \
125         > config.h.tmp
126 mv -f config.h{.tmp,}
127 %endif
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} install DESTDIR=$RPM_BUILD_ROOT
134
135 %post   -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %post   X11 -p /sbin/ldconfig
139 %postun X11 -p /sbin/ldconfig
140
141 %post   qt -p /sbin/ldconfig
142 %postun qt -p /sbin/ldconfig
143
144 %post   glib -p /sbin/ldconfig
145 %postun glib -p /sbin/ldconfig
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %files
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_bindir}/artscat
153 %attr(755,root,root) %{_bindir}/artsd
154 %attr(755,root,root) %{_bindir}/artsdsp
155 %attr(755,root,root) %{_bindir}/artsplay
156 %attr(755,root,root) %{_bindir}/artsrec
157 %attr(755,root,root) %{_bindir}/artsshell
158 %attr(755,root,root) %{_bindir}/artswrapper
159 %attr(755,root,root) %{_bindir}/testdhandle
160 %{_libdir}/lib[!gqx]*.la
161 %attr(755,root,root) %{_libdir}/lib[!gqx]*.so.*.*.*
162 %{_libdir}/mcop
163
164 %files devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_bindir}/artsc-config
167 %attr(755,root,root) %{_bindir}/mcopidl
168 %{_libdir}/*.so
169 %{_includedir}/arts
170 %{_includedir}/artsc
171
172 %files X11
173 %defattr(644,root,root,755)
174 %{_libdir}/libx11globalcomm.la
175 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
176
177 %files glib
178 %defattr(644,root,root,755)
179 %{_libdir}/libgmcop.la
180 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
181
182 %files qt
183 %defattr(644,root,root,755)
184 %{_libdir}/libqtmcop.la
185 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
This page took 0.039442 seconds and 4 git commands to generate.