]> git.pld-linux.org Git - packages/arts.git/blob - arts.spec
- 040104
[packages/arts.git] / arts.spec
1 #
2 # TODO: consider:
3 # - separating artsc and its -devel? (but what are artsc deps?)
4 #
5 # Conditional build:
6 %bcond_without  alsa    # disable ALSA support
7 %bcond_with     nas     # enable NAS support
8 #
9
10 %define         _state          snapshots
11 %define         _ver            1.2.0
12 %define         _snap           040104
13
14 Summary:        aRts sound server
15 Summary(pl):    Serwer d¼wiêku
16 Summary(pt_BR): Servidor de sons usado pelo KDE
17 Name:           arts
18 Version:        %{_ver}.%{_snap}
19 Release:        3
20 Epoch:          12
21 License:        LGPL
22 Group:          Libraries
23 #Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/%{name}-%{_ver}.tar.bz2
24 Source0:        http://www.kernel.pl/~adgor/kde/%{name}-%{_snap}.tar.bz2
25 # Source0-md5:  36606412608b4c1683d0f583dfd8e3c6
26 Patch0:         kde-common-am18.patch
27 URL:            http://www.kde.org/
28 %{?with_alsa:BuildRequires:     alsa-lib-devel}
29 BuildRequires:  audiofile-devel
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 BuildRequires:  docbook-dtd41-sgml
33 BuildRequires:  docbook-utils >= 0.6.13-3
34 BuildRequires:  esound-devel
35 BuildRequires:  glib2-devel >= 2.0.0
36 BuildRequires:  libmad-devel
37 BuildRequires:  libtool >= 2:1.5-2
38 BuildRequires:  libvorbis-devel
39 %{?with_nas:BuildRequires:      nas-devel}
40 BuildRequires:  pkgconfig
41 BuildRequires:  qt-devel >= 6:3.2.1-4
42 Obsoletes:      arts-glib
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 aRts sound server.
47
48 %description -l pl
49 Serwer d¼wiêku aRts.
50
51 %description -l pt_BR
52 O aRts é um sintetizador analógico em tempo real que é completamente
53 modular. Você pode criar sons e músicas (síntese em tempo real de
54 midi) usando pequenos módulos como oscilador para criar waveforms,
55 vários filtros, mixers, faders, etc. Você pode configurar tudo através
56 de uma interface no KDE. O Servidor aRts é controlado via CORBA. Este
57 design foi escolhido para permitir que outras aplicações usem o aRts
58 como um sintetizador (ou fornecedor de filtros). Usado pelo KDE, entre
59 outros.
60
61 %package devel
62 Summary:        Sound server - header files
63 Summary(pl):    Serwer d¼wiêku - pliki nag³ówkowe
64 Summary(pt_BR): Arquivos para desenvolvimento com o o aRts
65 Group:          Development/Libraries
66 Requires:       %{name} = %{epoch}:%{version}-%{release}
67 # not necessary for all libs (e.g. mcop), but propagated by artsflow
68 %{?with_alsa:Requires:  alsa-lib-devel}
69 Requires:       audiofile-devel
70 Requires:       esound-devel
71 Requires:       glib2-devel >= 2.0.0
72 Requires:       libmad-devel
73 Requires:       libvorbis-devel
74 %{?with_nas:Requires:   nas-devel}
75
76 %description devel
77 Header files required to compile programs using arts.
78
79 %description devel -l pl
80 Pliki nag³ówkowe niezbêdne do budowania aplikacji korzystaj±cych z
81 arts.
82
83 %description devel -l pt_BR
84 Arquivos para desenvolvimento com o o aRts.
85
86 # separate from arts-devel because they are mostly independent and have very
87 # different deps
88 # there is no artsc base - it would be small and would require arts - so there
89 # is no reason to separate
90 %package -n artsc-devel
91 Summary:        Development files for artsc libraries
92 Summary(pl):    Pliki programistyczne bibliotek artsc
93 Group:          Development/Libraries
94 Requires:       %{name} = %{epoch}:%{version}-%{release}
95 Requires:       glib2-devel >= 2.0.0
96 Conflicts:      arts-devel < 12:1.2.0.031126-2
97
98 %description -n artsc-devel
99 Development files for artsc libraries (C interface to aRts sound
100 system).
101
102 %description -n artsc-devel -l pl
103 Pliki programistyczne bibliotek artsc (interfejsu w C do systemu
104 d¼wiêku aRts).
105
106 %package X11
107 Summary:        X11 dependent part of aRts
108 Summary(pl):    Czê¶æ aRts wymagaj±ca X11
109 Group:          X11/Libraries
110 Requires:       %{name} = %{epoch}:%{version}-%{release}
111
112 %description X11
113 X11 dependent part of aRts (x11globalcomm module).
114
115 %description X11 -l pl
116 Czê¶æ aRts wymagaj±ca X11 (modu³ x11globalcomm).
117
118 %package qt
119 Summary:        QT dependend part of aRts
120 Summary(pl):    Czê¶æ aRts wymagaj±ca QT
121 Group:          X11/Libraries
122 Requires:       %{name} = %{epoch}:%{version}-%{release}
123 Requires:       qt >= 6:3.2.1-4
124
125 %description qt
126 QT dependend part of aRts (qtmcop library).
127
128 %description qt -l pl
129 Czê¶æ aRts wymagaj±ca QT (biblioteka qtmcop).
130
131 %package qt-devel
132 Summary:        Development files for qtmcop library
133 Summary(pl):    Pliki programistyczne dla biblioteki qtmcop
134 Group:          X11/Development/Libraries
135 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
136 Requires:       %{name}-qt = %{epoch}:%{version}-%{release}
137 Requires:       qt-devel >= 6:3.2.1-4
138
139 %description qt-devel
140 Development files for qtmcop library.
141
142 %description qt-devel -l pl
143 Pliki programistyczne dla biblioteki qtmcop.
144
145 %prep
146 %setup -q -n %{name}-%{_snap}
147 %patch0 -p0
148
149 %build
150 cp /usr/share/automake/config.sub admin
151 %{__make} -f admin/Makefile.common cvs
152
153 %configure \
154         %{!?with_nas:ac_cv_header_audio_audiolib_h=no} \
155         --%{?debug:en}%{!?debug:dis}able-debug \
156         --disable-rpath \
157         --enable-final \
158         --with-qt-libraries=%{_libdir} \
159         --with%{!?with_alsa:out}-alsa
160
161 %{__make}
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165
166 %{__make} install \
167         DESTDIR=$RPM_BUILD_ROOT
168
169 # Debian manpages
170 install -d $RPM_BUILD_ROOT%{_mandir}/man1
171 cd debian
172 for f in *.sgml ; do
173         base="$(basename $f .sgml)"
174         upper="$(echo ${base} | tr a-z A-Z)"
175         db2man $f
176         install ${upper}.1 $RPM_BUILD_ROOT%{_mandir}/man1/${base}.1
177 done
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %post   -p /sbin/ldconfig
183 %postun -p /sbin/ldconfig
184
185 %post   X11 -p /sbin/ldconfig
186 %postun X11 -p /sbin/ldconfig
187
188 %post   qt -p /sbin/ldconfig
189 %postun qt -p /sbin/ldconfig
190
191 %files
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_bindir}/artscat
194 %attr(755,root,root) %{_bindir}/artsd
195 %attr(755,root,root) %{_bindir}/artsdsp
196 %attr(755,root,root) %{_bindir}/artsplay
197 %attr(755,root,root) %{_bindir}/artsrec
198 %attr(755,root,root) %{_bindir}/artsshell
199 %attr(755,root,root) %{_bindir}/artswrapper
200 # shared libraries
201 %attr(755,root,root) %{_libdir}/libartsc.so.*.*.*
202 %attr(755,root,root) %{_libdir}/libartsflow.so.*.*.*
203 %attr(755,root,root) %{_libdir}/libartsflow_idl.so.*.*.*
204 %attr(755,root,root) %{_libdir}/libgmcop.so.*.*.*
205 %attr(755,root,root) %{_libdir}/libkmedia2.so.*.*.*
206 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so.*.*.*
207 %attr(755,root,root) %{_libdir}/libmcop.so.*.*.*
208 %attr(755,root,root) %{_libdir}/libmcop_mt.so.*.*.*
209 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so.*.*.*
210 # lt_dlopened modules (*.la needed)
211 %attr(755,root,root) %{_libdir}/libartscbackend.so.*.*.*
212 %{_libdir}/libartscbackend.la
213 %attr(755,root,root) %{_libdir}/libartsdsp.so.*.*.*
214 %{_libdir}/libartsdsp.la
215 %attr(755,root,root) %{_libdir}/libartsdsp_st.so.*.*.*
216 %{_libdir}/libartsdsp_st.la
217 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so.*.*.*
218 %{_libdir}/libartsgslplayobject.la
219 %attr(755,root,root) %{_libdir}/libartswavplayobject.so.*.*.*
220 %{_libdir}/libartswavplayobject.la
221 #
222 %{_libdir}/mcop
223 %{_mandir}/man1/artscat.1*
224 %{_mandir}/man1/artsd.1*
225 %{_mandir}/man1/artsdsp.1*
226 %{_mandir}/man1/artsplay.1*
227 %{_mandir}/man1/artsrec.1*
228 %{_mandir}/man1/artsshell.1*
229 %{_mandir}/man1/artswrapper.1*
230
231 %files devel
232 %defattr(644,root,root,755)
233 %attr(755,root,root) %{_bindir}/mcopidl
234 %attr(755,root,root) %{_libdir}/libartsflow.so
235 %attr(755,root,root) %{_libdir}/libartsflow_idl.so
236 %attr(755,root,root) %{_libdir}/libartsgslplayobject.so
237 %attr(755,root,root) %{_libdir}/libartswavplayobject.so
238 %attr(755,root,root) %{_libdir}/libgmcop.so
239 %attr(755,root,root) %{_libdir}/libkmedia2.so
240 %attr(755,root,root) %{_libdir}/libkmedia2_idl.so
241 %attr(755,root,root) %{_libdir}/libmcop.so
242 %attr(755,root,root) %{_libdir}/libmcop_mt.so
243 %attr(755,root,root) %{_libdir}/libsoundserver_idl.so
244 # it seems to be only (lt_)dlopened, nothing links with it - so not needed
245 # %attr(755,root,root) %{_libdir}/libx11globalcomm.so
246 # shared libraries
247 %{_libdir}/libartsflow.la
248 %{_libdir}/libartsflow_idl.la
249 %{_libdir}/libgmcop.la
250 %{_libdir}/libkmedia2.la
251 %{_libdir}/libkmedia2_idl.la
252 %{_libdir}/libmcop.la
253 %{_libdir}/libmcop_mt.la
254 %{_libdir}/libsoundserver_idl.la
255 #
256 %{_includedir}/arts
257 %exclude %{_includedir}/arts/qiomanager.h
258 %{_mandir}/man1/mcopidl.1*
259
260 %files -n artsc-devel
261 %defattr(644,root,root,755)
262 %attr(755,root,root) %{_bindir}/artsc-config
263 %attr(755,root,root) %{_libdir}/libartsc.so
264 %attr(755,root,root) %{_libdir}/libartscbackend.so
265 %attr(755,root,root) %{_libdir}/libartsdsp.so
266 %attr(755,root,root) %{_libdir}/libartsdsp_st.so
267 %{_libdir}/libartsc.la
268 %{_includedir}/artsc
269 %{_mandir}/man1/artsc-config.1*
270
271 %files X11
272 %defattr(644,root,root,755)
273 # lt_dlopened module (.la needed)
274 %attr(755,root,root) %{_libdir}/libx11globalcomm.so.*.*.*
275 %{_libdir}/libx11globalcomm.la
276
277 %files qt
278 %defattr(644,root,root,755)
279 # shared library
280 %attr(755,root,root) %{_libdir}/libqtmcop.so.*.*.*
281
282 %files qt-devel
283 %defattr(644,root,root,755)
284 %attr(755,root,root) %{_libdir}/libqtmcop.so
285 %{_libdir}/libqtmcop.la
286 %{_includedir}/arts/qiomanager.h
This page took 0.063661 seconds and 3 git commands to generate.