]> git.pld-linux.org Git - packages/apache1-mod_snake.git/commitdiff
- added %{apxs} local macro to avoid adapter problems
authorankry <ankry@pld-linux.org>
Sun, 17 Feb 2002 18:52:20 +0000 (18:52 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fix use of %{apxs} and %{_sbindir}/apxs
- added BR %{apxs} & Prereq %{_sbindir}/apxs (if necessary); removed BR apache
- adapterized

Changed files:
    apache1-mod_snake.spec -> 1.3

apache1-mod_snake.spec

index 66a505eec313f2b5193c989e9ae90d0bafea30db..7f84df3a46f8e199262fb2e5fa47351567304569 100644 (file)
@@ -1,4 +1,5 @@
 %define                mod_name        snake
+%define        apxs            /usr/sbin/apxs
 Summary:       An Apache module to allow for Python plugins and control
 Summary(pl):   Modu³ do Apache pozwalaj±cy na kontrolê i wtyczki Pythona
 Name:          apache-mod_%{mod_name}
@@ -6,18 +7,30 @@ Version:      0.5.0
 Release:       1
 License:       GPL
 Group:         Networking/Daemons
+Group(cs):     Sí»ové/Démoni
+Group(da):     Netværks/Dæmoner
 Group(de):     Netzwerkwesen/Server
+Group(es):     Red/Servidores
+Group(fr):     Réseau/Serveurs
+Group(is):     Net/Púkar
+Group(it):     Rete/Demoni
+Group(no):     Nettverks/Daemoner
 Group(pl):     Sieciowe/Serwery
+Group(pt):     Rede/Servidores
+Group(ru):     óÅÔØ/äÅÍÏÎÙ
+Group(sl):     Omre¾ni/Stre¾niki
+Group(sv):     Nätverk/Demoner
+Group(uk):     íÅÒÅÖÁ/äÅÍÏÎÉ
 Source0:       http://prdownloads.sourceforge.net/mod_%{mod_name}/mod_%{mod_name}-%{version}.tar.gz
 URL:           http://modsnake.sourceforge.net/
-BuildRequires: /usr/sbin/apxs
+BuildRequires: %{apxs}
 BuildRequires: apache-devel >= 1.3.15
 BuildRequires: python-devel >= 1.5
-Prereq:                /usr/sbin/apxs
+Prereq:                %{_sbindir}/apxs
 Requires:      apache
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR)
 
 %description
 mod_snake is an Apache module which allows for execution of Python
@@ -38,7 +51,7 @@ kontrolowa
 
 %build
 %configure2_13 \
-       --with-apxs=%{_sbindir}/apxs \
+       --with-apxs=%{apxs} \
        --enable-dso
 %{__make}
 
@@ -52,14 +65,14 @@ install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
 rm -rf $RPM_BUILD_ROOT
 
 %post
-/usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+%{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 fi
 
 %preun
 if [ "$1" = "0" ]; then
-       /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
+       %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
This page took 0.050096 seconds and 4 git commands to generate.