]> git.pld-linux.org Git - packages/apache1-mod_snake.git/blob - apache1-mod_snake.spec
- release 2
[packages/apache1-mod_snake.git] / apache1-mod_snake.spec
1 %define         mod_name        snake
2 %define         apxs            /usr/sbin/apxs
3 Summary:        An Apache module to allow for Python plugins and control
4 Summary(pl):    Modu³ do Apache pozwalaj±cy na kontrolê i wtyczki Pythona
5 Name:           apache-mod_%{mod_name}
6 Version:        0.5.0
7 Release:        2
8 License:        GPL
9 Group:          Networking/Daemons
10 Group(cs):      Sí»ové/Démoni
11 Group(da):      Netværks/Dæmoner
12 Group(de):      Netzwerkwesen/Server
13 Group(es):      Red/Servidores
14 Group(fr):      Réseau/Serveurs
15 Group(is):      Net/Púkar
16 Group(it):      Rete/Demoni
17 Group(no):      Nettverks/Daemoner
18 Group(pl):      Sieciowe/Serwery
19 Group(pt):      Rede/Servidores
20 Group(ru):      óÅÔØ/äÅÍÏÎÙ
21 Group(sl):      Omre¾ni/Stre¾niki
22 Group(sv):      Nätverk/Demoner
23 Group(uk):      íÅÒÅÖÁ/äÅÍÏÎÉ
24 Source0:        http://prdownloads.sourceforge.net/mod_%{mod_name}/mod_%{mod_name}-%{version}.tar.gz
25 URL:            http://modsnake.sourceforge.net/
26 BuildRequires:  %{apxs}
27 BuildRequires:  apache-devel >= 1.3.15
28 BuildRequires:  python-devel >= 1.5
29 Prereq:         %{_sbindir}/apxs
30 Requires:       apache
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
34
35 %description
36 mod_snake is an Apache module which allows for execution of Python
37 code directly within the Apache server process. By including an
38 interpreter in the Apache process, Python CGIs are accelerated, Python
39 can be embedded within HTML and Python written modules can control the
40 internals of the webserver.
41
42 %description -l pl
43 mod_snake to modu³ Apache pozwalaj±cy na wykonywanie kodu Pythona
44 bezpo¶rednio w procesie serwera Apache. W³±czaj±c interpreter do
45 procesu Apache skrypty CGI w Pythonie s± znacznie przyspieszone.
46 Python mo¿e byæ umieszczany w HTMLu oraz modu³y Pythona mog±
47 kontrolowaæ wewnêtrzne sprawy serwera www.
48
49 %prep 
50 %setup -q -n mod_%{mod_name}-%{version}
51
52 %build
53 %configure2_13 \
54         --with-apxs=%{apxs} \
55         --enable-dso
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{_pkglibdir}
61
62 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post
68 %{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
69 if [ -f /var/lock/subsys/httpd ]; then
70         /etc/rc.d/init.d/httpd restart 1>&2
71 fi
72
73 %preun
74 if [ "$1" = "0" ]; then
75         %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
76         if [ -f /var/lock/subsys/httpd ]; then
77                 /etc/rc.d/init.d/httpd restart 1>&2
78         fi
79 fi
80
81 %files
82 %defattr(644,root,root,755)
83 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.047268 seconds and 3 git commands to generate.