]> git.pld-linux.org Git - packages/apache1-mod_gunzip.git/blob - apache1-mod_gunzip.spec
- cosmetics.
[packages/apache1-mod_gunzip.git] / apache1-mod_gunzip.spec
1 %define         mod_name        gunzip
2 Summary:        Apache module: On-the-fly decompression of HTML documents
3 Summary(pl):    Modu³ do apache: dekompresuje dokumenty HTML w locie
4 Name:           apache-mod_%{mod_name}
5 Version:        1
6 Release:        0.1
7 Copyright:      GPL
8 Group:          Networking/Daemons
9 Group(pl):      Sieciowe/Serwery
10 Source0:        http://sep.hamburg.com/mod_%{mod_name}.tar.gz
11 BuildRequires:  /usr/sbin/apxs
12 BuildRequires:  apache-devel
13 BuildRequires:  zlib-devel
14 Prereq:         /usr/sbin/apxs
15 Requires:       apache
16 BuildRoot:      /tmp/%{name}-%{version}-root
17
18 %define         _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
19
20 %description
21 Apache module: On-the-fly decompression of HTML documents.
22
23 %description -l pl
24 Modu³ do apache: dekompresuje dokumenty HTML w locie.
25
26 %prep 
27 %setup -q -n mod_%{mod_name}
28
29 %build
30 /usr/sbin/apxs -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lz
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34
35
36 install -d $RPM_BUILD_ROOT%{_pkglibdir}
37
38 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
39
40 strip --strip-unneeded $RPM_BUILD_ROOT%{_pkglibdir}/* 
41
42 %post
43 /usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
44 if [ -f /var/lock/subsys/httpd ]; then
45         /etc/rc.d/init.d/httpd restart 1>&2
46 fi
47
48 %preun
49 if [ "$1" = "0" ]; then
50         /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
51         if [ -f /var/lock/subsys/httpd ]; then
52                 /etc/rc.d/init.d/httpd restart 1>&2
53         fi
54 fi
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.050909 seconds and 3 git commands to generate.