]> git.pld-linux.org Git - packages/apache-mod_sdch.git/blob - apache-mod_sdch.spec
- initial, but appears no code yet checked in
[packages/apache-mod_sdch.git] / apache-mod_sdch.spec
1 %define         svnrev  9
2 %define         rel             0.1
3 %define         mod_name        sdch
4 %define         apxs            %{_sbindir}/apxs
5 Summary:        Apache implementation of shared dictionary comrpession over HTTP
6 Name:           apache-mod_%{mod_name}
7 Version:        0
8 Release:        %{svnrev}.%{rel}
9 License:        Apache v2.0
10 Group:          Networking/Daemons/HTTP
11 # revno=
12 # svn co http://mod-sdch.googlecode.com/svn/trunk${revno:+@$revno} mod-sdch
13 # tar -cjf mod-sdch-$(svnversion mod-sdch).tar.bz2 --exclude-vcs mod-sdch
14 # ../dropin mod-sdch-$(svnversion mod-sdch).tar.bz2
15 Source0:        mod-sdch-9.tar.bz2
16 # Source0-md5:  -
17 #Source1:       apache.conf
18 URL:            http://code.google.com/p/mod-sdch/
19 BuildRequires:  %{apxs}
20 BuildRequires:  apache-devel >= 2.2
21 BuildRequires:  rpmbuild(macros) >= 1.268
22 Requires:       apache(modules-api) = %apache_modules_api
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
26 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
27
28 %description
29 Shared Dictionary Compression over HTTP is a proposed modification to
30 RFC 2616.
31
32 This Apache module will initially attempt to prototype a reference
33 implementation.
34
35 %prep
36 %setup -qn mod-%{mod_name}
37
38 %build
39 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
44 install -p mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
45
46 # module configuration
47 # - should contain LoadModule line
48 # - and directives must be between IfModule (so user could disable the module easily)
49 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
50
51 # or, if no directives needed, put just LoadModule line
52 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
53         $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 %service -q httpd restart
60
61 %postun
62 if [ "$1" = "0" ]; then
63         %service -q httpd restart
64 fi
65
66 %files
67 %defattr(644,root,root,755)
68 %doc README
69 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
70 %attr(755,root,root) %{_pkglibdir}/mod_%{mod_name}.so
This page took 0.072223 seconds and 3 git commands to generate.