]> git.pld-linux.org Git - packages/apache-mod_pagespeed.git/blob - apache-mod_pagespeed.spec
cleanup more unneeded files for build
[packages/apache-mod_pagespeed.git] / apache-mod_pagespeed.spec
1 #
2 # Conditional build:
3 %bcond_without  verbose         # verbose build (V=1)
4
5 # NOTE
6 # - relase notes: https://developers.google.com/speed/pagespeed/module/release_notes
7 # - http://code.google.com/p/modpagespeed/wiki/HowToBuild
8 # - http://wiki.mediatemple.net/w/(dv)_HOWTO:_Install_mod_pagespeed
9 # TODO
10 # - add unit tests running
11 # - possible sysdeps (uses release tags)
12 #  "serf_src": "http://serf.googlecode.com/svn/tags/0.3.1",
13 #  "gflags_root": "http://google-gflags.googlecode.com/svn/tags/gflags-1.3/src",
14 #  "google_sparsehash_root": "http://google-sparsehash.googlecode.com/svn/tags/sparsehash-1.8.1/src",
15 #  protobuf_lite
16
17 %define         mod_name        pagespeed
18 %define         apxs            %{_sbindir}/apxs
19 Summary:        Apache module for rewriting web pages to reduce latency and bandwidth
20 Name:           apache-mod_%{mod_name}
21 # beta: 1.9.32.2-beta
22 # stable: 1.8.31.5
23 Version:        1.8.31.5
24 Release:        0.10
25 License:        Apache v2.0
26 Group:          Networking/Daemons/HTTP
27 Source0:        modpagespeed-%{version}.tar.xz
28 # Source0-md5:  9aefd5719a9b7946106b625dc7ecd2aa
29 Source1:        get-source.sh
30 Source2:        gclient.conf
31 Patch0:         system-libs.patch
32 Patch2:         bug-632.patch
33 Patch4:         no-dev-stdout.patch
34 URL:            https://developers.google.com/speed/pagespeed/module
35 BuildRequires:  %{apxs}
36 BuildRequires:  apache-devel >= 2.2
37 BuildRequires:  bash
38 BuildRequires:  glib2-devel
39 BuildRequires:  gperf
40 BuildRequires:  libicu-devel
41 BuildRequires:  libselinux-devel
42 BuildRequires:  libstdc++-devel >= 5:4.1
43 BuildRequires:  opencv-devel >= 2.3.1
44 BuildRequires:  openssl-devel
45 BuildRequires:  pkgconfig
46 BuildRequires:  python-devel >= 1:2.6
47 BuildRequires:  yasm
48 # This version of gyp is new enough that it knows to use make for Linux 3.x
49 # and FreeBSD, but old enough that 'type': 'settings' works and
50 # LINKER_SUPPORTS_ICF hasn't been removed yet.
51 BuildRequires:  python-gyp >= 0.1-0.svn1602.1
52 BuildRequires:  rpmbuild(macros) >= 1.268
53 BuildRequires:  tar >= 1:1.22
54 BuildRequires:  util-linux
55 BuildRequires:  xz
56 BuildRequires:  zlib-devel
57 Requires:       apache(modules-api) = %apache_modules_api
58 Requires:       apache-mod_authz_host
59 Requires:       apache-mod_headers
60 Suggests:       apache-mod_deflate
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
64 %define         _pkgrootdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
65 %define         _sysconfdir     %{_pkgrootdir}/conf.d
66 %define         htdocsdir       %(%{apxs} -q htdocsdir 2>/dev/null)
67 %define         cachedir        %(%{apxs} -q proxycachedir 2>/dev/null)/mod_%{mod_name}
68
69 %description
70 mod_pagespeed automates the application of those rules in an Apache
71 server. HTML, CSS, JavaScript, and images are changed dynamically
72 during the web serving process, so that the best practices recommended
73 by Page Speed can be used without having to change the way the web
74 site is maintained.
75
76 %prep
77 %setup -q -n modpagespeed-%{version}
78 %patch0 -p2
79 %patch2 -p1
80 %patch4 -p1
81
82 rm -r third_party/icu/source
83 rm -r third_party/icu/genfiles
84 install -d third_party/icu/source/{common,i18n}
85 ln -s %{_includedir}/unicode third_party/icu/source/i18n/unicode
86 ln -s %{_includedir}/unicode third_party/icu/source/common/unicode
87
88 %build
89 # re-gen makefiles
90 CC="%{__cc}" \
91 CXX="%{__cxx}" \
92 %{__python} build/gyp_chromium \
93         --format=make \
94         --depth=. \
95         build/all.gyp \
96         -Duse_openssl=1 \
97         -Duse_system_apache_dev=1 \
98         -Duse_system_icu=1 \
99         -Duse_system_libjpeg=1 \
100         -Duse_system_libpng=1 \
101         -Duse_system_opencv=1 \
102         -Duse_system_openssl=1 \
103         -Duse_system_yasm=1 \
104         -Duse_system_zlib=1 \
105         -Dsystem_include_path_apr=%{_includedir}/apr \
106         -Dsystem_include_path_aprutil=%{_includedir}/apr-util \
107         -Dsystem_include_path_httpd=%{_includedir}/apache \
108         %{nil}
109
110 %{__make} mod_pagespeed js_minify css_minify_main \
111         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
112         %{?with_verbose:V=1} \
113         CC="%{__cc}" \
114         CXX="%{__cxx}" \
115         CC.host="%{__cc}" \
116         CXX.host="%{__cxx}" \
117         LINK.host="%{__cxx}" \
118         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
119         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
120         %{nil}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir},%{_bindir},%{cachedir}}
125
126 %{__make} -j1 -C install staging_except_module \
127         APACHE_ROOT=%{_pkgrootdir} \
128         APACHE_MODULES=modules \
129         APACHE_DOC_ROOT=%{htdocsdir} \
130         MOD_PAGESPEED_CACHE=%{cachedir} \
131         MOD_PAGESPEED_STATS_LOG=/var/log/httpd/mod_pagespeed_stats.log \
132         STAGING_DIR=staging
133
134 out=out/%{!?debug:Release}%{?debug:Debug}
135 install -p $out/libmod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
136 install -p $out/js_minify $RPM_BUILD_ROOT%{_bindir}/pagespeed_js_minify
137 install -p $out/css_minify_main $RPM_BUILD_ROOT%{_bindir}/pagespeed_css_minify
138
139 cd install/staging
140 cat > $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf <<EOF
141 LoadModule %{mod_name}_module   modules/mod_%{mod_name}.so
142
143 $(cat pagespeed.conf)
144 EOF
145
146 cp -p pagespeed_libraries.conf $RPM_BUILD_ROOT%{_sysconfdir}/91_mod_%{mod_name}_libraries.conf
147
148 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
149 cp -a mod_pagespeed_example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post
155 %service -q httpd restart
156
157 %postun
158 if [ "$1" = "0" ]; then
159         %service -q httpd restart
160 fi
161
162 %files
163 %defattr(644,root,root,755)
164 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
165 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}_libraries.conf
166 %attr(755,root,root) %{_bindir}/pagespeed_css_minify
167 %attr(755,root,root) %{_bindir}/pagespeed_js_minify
168 %attr(755,root,root) %{_pkglibdir}/mod_%{mod_name}.so
169 %{_examplesdir}/%{name}-%{version}
170 %dir %attr(770,root,http) %{cachedir}
This page took 0.517958 seconds and 3 git commands to generate.