]> git.pld-linux.org Git - packages/apache-mod_mono.git/commitdiff
- fix building with automake 1.13
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 5 May 2013 19:48:08 +0000 (21:48 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 5 May 2013 19:48:08 +0000 (21:48 +0200)
- build with apache 2.4
- rel 2

apache-mod_mono-ac.patch
apache-mod_mono.spec
mod_mono-apache24.patch [new file with mode: 0644]

index 834991e632f7db8e37487144f3a4c5f6ebd2c475..0c11cb67d474519ad60513e4dcffadec1b24e46f 100644 (file)
@@ -1,6 +1,14 @@
 diff -uNr mod_mono-2.4.orig/configure.in mod_mono-2.4/configure.in
 --- mod_mono-2.4.orig/configure.in     2009-03-09 18:02:00.000000000 +0100
 +++ mod_mono-2.4/configure.in  2009-04-21 07:07:43.000000000 +0200
+@@ -1,6 +1,6 @@
+ AC_INIT(src/mod_mono.c)
+ AM_INIT_AUTOMAKE(mod_mono, 2.10)
+-AM_CONFIG_HEADER(include/mod_mono_config.h:config.in)
++AC_CONFIG_HEADERS(include/mod_mono_config.h:config.in)
+ AC_PROG_CC
+ AM_PROG_LIBTOOL
 @@ -15,6 +15,7 @@
          AC_MSG_ERROR([You need to install pkg-config])
  fi
index d567c9b1b6d56eec5e637b5a09507f3ac1041be8..743ad4efd1c7f93c34e10f635286848ca473eace 100644 (file)
@@ -1,12 +1,12 @@
 # TODO:
 # - figure out how to kill mod-mono-server.exe process when apache is restarted
 %define                mod_name        mod_mono
-%define        apxs            /usr/sbin/apxs
+%define                apxs            /usr/sbin/apxs
 Summary:       Mono module for Apache 2
 Summary(pl.UTF-8):     Moduł Mono dla serwera Apache 2
 Name:          apache-%{mod_name}
 Version:       2.10
-Release:       1
+Release:       2
 Epoch:         1
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
diff --git a/mod_mono-apache24.patch b/mod_mono-apache24.patch
new file mode 100644 (file)
index 0000000..300f248
--- /dev/null
@@ -0,0 +1,84 @@
+diff -ur mod_mono-2.10/configure.in mod_mono-2.10-apache24/configure.in
+--- mod_mono-2.10/configure.in 2013-05-05 21:17:12.794820781 +0200
++++ mod_mono-2.10-apache24/configure.in        2013-05-05 21:14:23.924822003 +0200
+@@ -330,7 +330,7 @@
+       #include <ap_release.h>
+       int main ()
+       {
+-              return (AP_SERVER_MAJORVERSION_NUMBER == 2 && AP_SERVER_MINORVERSION_NUMBER == 2) ? 0 : 1;
++              return (AP_SERVER_MAJORVERSION_NUMBER == 2 && AP_SERVER_MINORVERSION_NUMBER >= 2) ? 0 : 1;
+       }
+ ], [
+       APACHE_VER=2.2
+diff -ur mod_mono-2.10/src/mod_mono.c mod_mono-2.10-apache24/src/mod_mono.c
+--- mod_mono-2.10/src/mod_mono.c       2011-01-13 23:32:35.000000000 +0100
++++ mod_mono-2.10-apache24/src/mod_mono.c      2013-05-05 21:16:46.081487640 +0200
+@@ -386,7 +386,7 @@
+ apache_get_userid ()
+ {
+ #ifdef HAVE_UNIXD
+-      return unixd_config.user_id;
++      return ap_unixd_config.user_id;
+ #else
+       return ap_user_id;
+ #endif
+@@ -396,7 +396,7 @@
+ apache_get_groupid ()
+ {
+ #ifdef HAVE_UNIXD
+-      return unixd_config.group_id;
++      return ap_unixd_config.group_id;
+ #else
+       return ap_group_id;
+ #endif
+@@ -406,7 +406,7 @@
+ apache_get_username ()
+ {
+ #ifdef HAVE_UNIXD
+-      return unixd_config.user_name;
++      return ap_unixd_config.user_name;
+ #else
+       return ap_user_name;
+ #endif
+@@ -485,7 +485,7 @@
+ #if defined (AP_NEED_SET_MUTEX_PERMS) && defined (HAVE_UNIXD)
+               DEBUG_PRINT (1, "Setting mutex permissions for %s", xsp->dashboard_lock_file);
+-              rv = unixd_set_global_mutex_perms (xsp->dashboard_mutex);
++              rv = ap_unixd_set_global_mutex_perms (xsp->dashboard_mutex);
+               if (rv != APR_SUCCESS) {
+                       ap_log_error (APLOG_MARK, APLOG_CRIT, STATCODE_AND_SERVER (rv),
+                                     "Failed to set mutex permissions for %s",
+@@ -845,10 +845,10 @@
+ }
+ static int
+-connection_get_remote_port (conn_rec *c)
++connection_get_remote_port (request_rec *r)
+ {
+ #if defined(APACHE22)
+-      return c->remote_addr->port;
++      return r->useragent_addr->port;
+ #else
+       apr_port_t port;
+       apr_sockaddr_port_get (&port, c->remote_addr);
+@@ -1978,7 +1978,7 @@
+       size += sizeof (int32_t);
+-      info.remote_ip_len = strlen (r->connection->remote_ip);
++      info.remote_ip_len = strlen (r->connection->client_ip);
+       size += info.remote_ip_len + sizeof (int32_t);
+       size += sizeof (int32_t);
+@@ -2026,8 +2026,8 @@
+       i = LE_FROM_INT (i);
+       memcpy (ptr, &i, sizeof (i));
+       ptr += sizeof (int32_t);
+-      ptr += write_string_to_buffer (ptr, 0, r->connection->remote_ip, info.remote_ip_len);
+-      i = connection_get_remote_port (r->connection);
++      ptr += write_string_to_buffer (ptr, 0, r->connection->client_ip, info.remote_ip_len);
++      i = connection_get_remote_port (r);
+       i = LE_FROM_INT (i);
+       memcpy (ptr, &i, sizeof (i));
+       ptr += sizeof (int32_t);
This page took 0.05702 seconds and 4 git commands to generate.