]> git.pld-linux.org Git - packages/apache-mod_mono.git/commitdiff
- updated for 1.2.1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 17 Feb 2007 17:03:30 +0000 (17:03 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    apache-mod_mono-apu-config.patch -> 1.3

apache-mod_mono-apu-config.patch

index 9ec00dc9fed0a4f47f28aa1d5eb0b547ad16b740..310d90fb0b2ef7a68ea0d6fadbf533c08f9df2e2 100644 (file)
@@ -1,14 +1,13 @@
-diff -Nuard mod_mono-1.0.orig/configure.in mod_mono-1.0/configure.in
---- mod_mono-1.0.orig/configure.in     2004-06-29 18:01:53.000000000 +0200
-+++ mod_mono-1.0/configure.in  2004-07-05 22:41:23.299809912 +0200
-@@ -52,6 +52,29 @@
- ],
- AC_MSG_RESULT(not specified))
+--- mod_mono-1.2.1/configure.in.orig   2006-11-21 23:24:50.000000000 +0100
++++ mod_mono-1.2.1/configure.in        2007-02-17 17:55:31.519007163 +0100
+@@ -82,6 +82,28 @@
+   fi
+ ],)
  
-+AC_MSG_CHECKING(for --with-apu-config)
++# check for --with-apu-config
 +AC_ARG_WITH(apu-config,
-+[  --with-apu-config=PATH  Path to apu-config (apache 2.0). You may use
-+                          this option when apr-config is not in the same
++[  --with-apu-config=PATH  Path to apr-config (apache 2.0). You may use
++                          this option when apu-config is not in the same
 +                        directory as apxs and the output of
 +                        'apu-config --includes' is different from
 +                        'apxs -q INCLUDEDIR'.
@@ -25,101 +24,74 @@ diff -Nuard mod_mono-1.0.orig/configure.in mod_mono-1.0/configure.in
 +        AC_MSG_ERROR([$withval not found or not executable])
 +    fi
 +  fi
-+],
-+AC_MSG_RESULT(not specified))
++],)
 +
- # if no apxs found yet, check /usr/local/apache/sbin
- # since it's the default Apache location
  if test -z "$APXS"; then
-@@ -76,6 +99,9 @@
-   if test -z "$APRCONFIG" ; then
-     APRCONFIG=`dirname ${APXS}`/apr-config
-   fi
-+  if test -z "$APUCONFIG" ; then
-+    APUCONFIG=`dirname ${APXS}`/apu-config
-+  fi
- fi
- if test -z "$APRCONFIG"; then
-@@ -89,6 +115,17 @@
-   fi
+   for mydir in /usr/local/apache2/sbin        \
+               /usr/local/apache2/bin  \
+@@ -169,6 +191,48 @@
+   AC_PATH_PROG(APRCONFIG, apr-config)
  fi
  
 +if test -z "$APUCONFIG"; then
-+  AC_MSG_CHECKING(for apu-config in /usr/local/apache/sbin)
-+  if test -x /usr/local/apache/sbin/apu-config; then
-+    APUCONFIG=/usr/local/apache/sbin/apu-config
-+    AC_MSG_RESULT([found, we'll use this. Use --with-apu-config to specify another.])    
-+  else
-+    AC_MSG_RESULT(no)
-+    APUCONFIG=""
-+  fi
-+fi
++  for mydir in `dirname ${APXS}` \
++              /usr/local/apache2/sbin \
++              /usr/local/apache2/bin  \
++              /usr/local/apache/sbin  \
++              /usr/local/apache/bin   \
++              /usr/sbin               \
++              /usr/bin
++  do
++      AC_MSG_CHECKING(for apu-1-config in $mydir)
++      A1="$mydir/apu-1-config"
++      if test -x "$A1" ; then
++              APUCONFIG="$A1"
++              AC_MSG_RESULT(found.)
++              break
++      else
++              AC_MSG_RESULT(no)
++      fi
 +
- if test -z "$APXS"; then
-   AC_MSG_CHECKING(for apxs2 in /usr/local/apache2/bin)
-   if test -x /usr/local/apache/bin/apxs2; then
-@@ -120,6 +157,17 @@
-   fi
- fi
-+if test -z "$APUCONFIG"; then
-+  AC_MSG_CHECKING(for apu-config in /usr/local/apache2/bin)
-+  if test -x /usr/local/apache2/bin/apu-config; then
-+    APUCONFIG=/usr/local/apache2/bin/apu-config
-+    AC_MSG_RESULT([found, we'll use this. Use --with-apu-config to specify another.])
-+  else
-+    AC_MSG_RESULT(no)
-+    APUCONFIG=""
-+  fi
++      AC_MSG_CHECKING(for apu-config in $mydir)
++      A2="$mydir/apu-config"
++      if test -x "$A2" ; then
++              APUCONFIG="$A2"
++              AC_MSG_RESULT(found.)
++              break
++      else
++              AC_MSG_RESULT(no)
++      fi
++
++  done
 +fi
 +
- if test -z "$APXS"; then
-   AC_MSG_CHECKING(for apxs2 in /usr/sbin)
-   if test -x /usr/sbin/apxs2; then
-@@ -151,6 +199,17 @@
-   fi
- fi
++# last resort 1
 +if test -z "$APUCONFIG"; then
-+  AC_MSG_CHECKING(for apu-config in /usr/sbin)
-+  if test -x /usr/sbin/apu-config; then
-+    APUCONFIG=/usr/sbin/apu-config
-+    AC_MSG_RESULT([found, we'll use this. Use --with-apu-config to specify another.])
-+  else
-+    AC_MSG_RESULT(no)
-+    APUCONFIG=""
-+  fi
++  AC_PATH_PROG(APUCONFIG, apu-1-config)
 +fi
 +
- # last resort
- if test -z "$APXS"; then
-   AC_PATH_PROG(APXS, apxs2)
-@@ -168,6 +227,10 @@
-   AC_PATH_PROG(APRCONFIG, apr-config)
- fi
++# last resort 2
 +if test -z "$APUCONFIG"; then
-+  AC_PATH_PROG(APUCONFIG, apr-config)
++  AC_PATH_PROG(APUCONFIG, apu-config)
 +fi
 +
- # determine LIBEXEC
- AC_MSG_CHECKING(for Apache libexec directory)
  APXS_LIBEXECDIR=`${APXS} -q LIBEXECDIR`
-@@ -205,8 +268,8 @@
+ APXS_SYSCONFDIR=`${APXS} -q SYSCONFDIR`
+ AP_INCLUDES="-I`${APXS} -q INCLUDEDIR`"
+@@ -183,6 +247,10 @@
+       CFLAGS="$CFLAGS `$APRCONFIG --includes --cflags`"
+       CPPFLAGS="$CFLAGS $CPPFLAGS `$APRCONFIG --includes --cflags --cppflags`"
  fi
- # Try apr-config
--if test "$APACHE_VER" = "retry" -a -x "$APRCONFIG"; then
--      CFLAGS="$CFLAGS `$APRCONFIG --includes`"
-+if test "$APACHE_VER" = "retry" -a -x "$APRCONFIG" -a -x "$APUCONFIG"; then
-+      CFLAGS="$CFLAGS `$APRCONFIG --includes` `$APUCONFIG --includes`"
-       AC_TRY_COMPILE([
-               #include <apr.h>
-       ], [
-@@ -370,6 +433,7 @@
++if test -x "$APUCONFIG" ; then
++      CFLAGS="$CFLAGS `$APUCONFIG --includes`"
++      CPPFLAGS="$CFLAGS $CPPFLAGS `$APUCONFIG --includes`"
++fi
+ AC_MSG_CHECKING([Apache version])
+ AC_TRY_COMPILE([
+       #include <ap_release.h>
+@@ -354,6 +422,7 @@
  echo "   * apxs = $APXS"
- test "$APACHE_VER" = "2.0" -a -x "$APRCONFIG" && \
+ test ! "$APACHE_VER" = "1.3" -a -x "$APRCONFIG" && \
  echo "   * apr-config = $APRCONFIG"
 +echo "   * apu-config = $APUCONFIG"
  echo "   * Verbose logging (debug) = $enable_debug"
This page took 0.929602 seconds and 4 git commands to generate.