]> git.pld-linux.org Git - packages/apache-mod_mono.git/commitdiff
- updated to 3.12 auto/th/apache-mod_mono-3.12-1
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 26 Jan 2015 20:41:17 +0000 (21:41 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 26 Jan 2015 20:41:17 +0000 (21:41 +0100)
- updated ac patch
- removed obsolete apache24 patch

apache-mod_mono-ac.patch
apache-mod_mono.spec
mod_mono-apache24.patch [deleted file]

index 0c11cb67d474519ad60513e4dcffadec1b24e46f..012f82224fe6819dc5ca582c1808f888e9d9d156 100644 (file)
@@ -1,9 +1,8 @@
-diff -uNr mod_mono-2.4.orig/configure.in mod_mono-2.4/configure.in
---- mod_mono-2.4.orig/configure.in     2009-03-09 18:02:00.000000000 +0100
-+++ mod_mono-2.4/configure.in  2009-04-21 07:07:43.000000000 +0200
+--- mod_mono-3.12/configure.in.orig    2015-01-12 18:50:02.000000000 +0100
++++ mod_mono-3.12/configure.in 2015-01-26 21:20:57.164211692 +0100
 @@ -1,6 +1,6 @@
  AC_INIT(src/mod_mono.c)
- AM_INIT_AUTOMAKE(mod_mono, 2.10)
+ AM_INIT_AUTOMAKE(mod_mono, 3.12)
 -AM_CONFIG_HEADER(include/mod_mono_config.h:config.in)
 +AC_CONFIG_HEADERS(include/mod_mono_config.h:config.in)
  
index 511c464c2a224ace5c73d8ce39ba1b976f032326..5b816f98f49146f6d5ffe5ee4bd140cce97d17f3 100644 (file)
@@ -5,26 +5,24 @@
 Summary:       Mono module for Apache 2
 Summary(pl.UTF-8):     ModuĊ‚ Mono dla serwera Apache 2
 Name:          apache-%{mod_name}
-Version:       2.10
-Release:       2
+Version:       3.12
+Release:       1
 Epoch:         1
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
-# latest downloads summary at http://ftp.novell.com/pub/mono/sources-stable/
-Source0:       http://ftp.novell.com/pub/mono/sources/mod_mono/%{mod_name}-%{version}.tar.bz2
-# Source0-md5: 422c533a0dfbd699eb6339234261150a
+Source0:       http://download.mono-project.com/sources/mod_mono/%{mod_name}-%{version}.tar.gz
+# Source0-md5: bb99d807ce32040370360fae4996f967
 Patch0:                apache-mod_mono-ac.patch
-Patch1:                mod_mono-apache24.patch
 URL:           http://www.mono-project.com/
 BuildRequires: %{apxs}
 BuildRequires: apache-devel >= 2.0.52-2
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: libtool
-BuildRequires: mono-csharp >= 2.10
+BuildRequires: mono-csharp >= 3.12
 BuildRequires: pkgconfig
 Requires:      apache(modules-api) = %apache_modules_api
-Requires:      mono-csharp >= 2.10
+Requires:      mono-csharp >= 3.12
 Requires:      xsp >= 2.10
 Obsoletes:     mod_mono
 ExcludeArch:   i386
@@ -45,7 +43,6 @@ Uniksie z serwerem Apache i Mono.
 %prep
 %setup -q -n %{mod_name}-%{version}
 %patch0 -p1
-%patch1 -p1
 
 %build
 # Build Apache Module
diff --git a/mod_mono-apache24.patch b/mod_mono-apache24.patch
deleted file mode 100644 (file)
index 300f248..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
-diff -ur mod_mono-2.10/configure.in mod_mono-2.10-apache24/configure.in
---- mod_mono-2.10/configure.in 2013-05-05 21:17:12.794820781 +0200
-+++ mod_mono-2.10-apache24/configure.in        2013-05-05 21:14:23.924822003 +0200
-@@ -330,7 +330,7 @@
-       #include <ap_release.h>
-       int main ()
-       {
--              return (AP_SERVER_MAJORVERSION_NUMBER == 2 && AP_SERVER_MINORVERSION_NUMBER == 2) ? 0 : 1;
-+              return (AP_SERVER_MAJORVERSION_NUMBER == 2 && AP_SERVER_MINORVERSION_NUMBER >= 2) ? 0 : 1;
-       }
- ], [
-       APACHE_VER=2.2
-diff -ur mod_mono-2.10/src/mod_mono.c mod_mono-2.10-apache24/src/mod_mono.c
---- mod_mono-2.10/src/mod_mono.c       2011-01-13 23:32:35.000000000 +0100
-+++ mod_mono-2.10-apache24/src/mod_mono.c      2013-05-05 21:16:46.081487640 +0200
-@@ -386,7 +386,7 @@
- apache_get_userid ()
- {
- #ifdef HAVE_UNIXD
--      return unixd_config.user_id;
-+      return ap_unixd_config.user_id;
- #else
-       return ap_user_id;
- #endif
-@@ -396,7 +396,7 @@
- apache_get_groupid ()
- {
- #ifdef HAVE_UNIXD
--      return unixd_config.group_id;
-+      return ap_unixd_config.group_id;
- #else
-       return ap_group_id;
- #endif
-@@ -406,7 +406,7 @@
- apache_get_username ()
- {
- #ifdef HAVE_UNIXD
--      return unixd_config.user_name;
-+      return ap_unixd_config.user_name;
- #else
-       return ap_user_name;
- #endif
-@@ -485,7 +485,7 @@
- #if defined (AP_NEED_SET_MUTEX_PERMS) && defined (HAVE_UNIXD)
-               DEBUG_PRINT (1, "Setting mutex permissions for %s", xsp->dashboard_lock_file);
--              rv = unixd_set_global_mutex_perms (xsp->dashboard_mutex);
-+              rv = ap_unixd_set_global_mutex_perms (xsp->dashboard_mutex);
-               if (rv != APR_SUCCESS) {
-                       ap_log_error (APLOG_MARK, APLOG_CRIT, STATCODE_AND_SERVER (rv),
-                                     "Failed to set mutex permissions for %s",
-@@ -845,10 +845,10 @@
- }
- static int
--connection_get_remote_port (conn_rec *c)
-+connection_get_remote_port (request_rec *r)
- {
- #if defined(APACHE22)
--      return c->remote_addr->port;
-+      return r->useragent_addr->port;
- #else
-       apr_port_t port;
-       apr_sockaddr_port_get (&port, c->remote_addr);
-@@ -1978,7 +1978,7 @@
-       size += sizeof (int32_t);
--      info.remote_ip_len = strlen (r->connection->remote_ip);
-+      info.remote_ip_len = strlen (r->connection->client_ip);
-       size += info.remote_ip_len + sizeof (int32_t);
-       size += sizeof (int32_t);
-@@ -2026,8 +2026,8 @@
-       i = LE_FROM_INT (i);
-       memcpy (ptr, &i, sizeof (i));
-       ptr += sizeof (int32_t);
--      ptr += write_string_to_buffer (ptr, 0, r->connection->remote_ip, info.remote_ip_len);
--      i = connection_get_remote_port (r->connection);
-+      ptr += write_string_to_buffer (ptr, 0, r->connection->client_ip, info.remote_ip_len);
-+      i = connection_get_remote_port (r);
-       i = LE_FROM_INT (i);
-       memcpy (ptr, &i, sizeof (i));
-       ptr += sizeof (int32_t);
This page took 0.047427 seconds and 4 git commands to generate.