]> git.pld-linux.org Git - packages/apache-mod_mono.git/blob - apache-mod_mono.spec
f49fcbc2e566d99de52582fc54ce4f8027fb72ea
[packages/apache-mod_mono.git] / apache-mod_mono.spec
1 %define pkg_version 0.3
2 %define xsp_version 0.3
3 Summary:        Mono module for Apache 2
4 Summary(pl):    Modu³ Mono dla serwera Apache 2
5 Name:           mod_mono
6 Version:        0.3.6
7 Release:        1
8 License:        The Apache License
9 Group:          Networking/Daemons
10 Source0:        http://www.apacheworld.org/modmono/%{name}-%{pkg_version}.tar.gz
11 Source1:        xsp-%{xsp_version}.tar.gz
12 Source2:        mono.conf
13 BuildRequires:  autoconf
14 BuildRequires:  apache-devel
15 BuildRequires:  mono
16 Requires:       apache
17 #Requires:      httpd-mmn = %(cat %{_includedir}/httpd/.mmn)
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         httpdir         /home/services/httpd
21 %define         htmldir         %{httpdir}/html
22 %define         moddir          /usr/lib/apache
23
24 %description
25 This module allows you to run ASP.NET pages on Unix with Apache and
26 Mono.
27
28 %description -l pl
29 Ten modu³ umo¿liwia uruchamianie stron ASP.NET na Uniksie z serwerem
30 Apache i Mono.
31
32 %prep
33 %setup -q -n %{name}-%{pkg_version} -a 1
34
35 %build
36 # Build sample ASP.NET pages from xsp distribution
37 cd xsp-%{xsp_version}
38 %{__make}
39 %{__make} install
40 cd ..
41
42 # Build Apache Module
43 %{__autoconf}
44 %configure \
45         --with-apxs=%{_sbindir}/apxs
46 %{__make}
47
48 # Build Mono DLL
49 %{__make} -C src -f makedll.mak
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d
54 install -d $RPM_BUILD_ROOT%{moddir}
55 install -d $RPM_BUILD_ROOT%{htmldir}/mono
56 install -d $RPM_BUILD_ROOT%{httpdir}/.wapi
57
58 cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d
59 install src/.libs/libmod_mono.so $RPM_BUILD_ROOT%{moddir}
60 install src/ModMono.dll $RPM_BUILD_ROOT%{_libdir}
61 cp -r xsp-%{xsp_version}/server/test/* $RPM_BUILD_ROOT%{htmldir}/mono
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc ChangeLog COPYING INSTALL NEWS README
69 %attr(755,root,root) %{moddir}/libmod_mono.so
70 %{_libdir}/ModMono.dll
71 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/conf.d/mono.conf
72 # FIXME
73 %defattr(-,http,http)
74 %{htmldir}/mono
75 %{httpdir}/.wapi
This page took 0.06083 seconds and 2 git commands to generate.