]> git.pld-linux.org Git - packages/apache-mod_mono.git/blob - apache-mod_mono.spec
- ExcludeArch: alpha
[packages/apache-mod_mono.git] / apache-mod_mono.spec
1
2 # TODO : figure out how to kill mod-mono-server.exe process 
3 #        when apache is restarted
4
5 %define         mod_name mod_mono
6 Summary:        Mono module for Apache 2
7 Summary(pl):    Modu³ Mono dla serwera Apache 2
8 Name:           apache-mod_mono
9 Version:        1.0.1
10 Release:        0.9
11 Epoch:          1
12 License:        Apache
13 Group:          Networking/Daemons
14 Source0:        http://mono2.ximian.com/archive/%{version}/%{mod_name}-%{version}.tar.gz
15 # Source0-md5:  5adb398b270865c484cea53b79e3def4
16 Patch0:         %{name}-apu-config.patch
17 URL:            http://www.mono-project.com/
18 BuildRequires:  apache-devel >= 2.0
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  libtool
22 BuildRequires:  mono-csharp >= 1.0
23 Requires:       xsp
24 Requires:       apache >= 2.0
25 Requires:       mono-csharp >= 1.0
26 Obsoletes:      mod_mono
27 ExcludeArch:    alpha
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         apxs            %{_sbindir}/apxs
31 %define         _httpdir        /home/services/httpd
32 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
33
34 %description
35 This is an experimental module that allows you to run ASP.NET pages on
36 Unix with Apache and Mono.
37
38 %description -l pl
39 Ten eksperymentalny modu³ umo¿liwia uruchamianie stron ASP.NET na
40 Uniksie z serwerem Apache i Mono.
41
42 %package -n dotnet-xsp
43 Summary:        Mono ASP.NET Standalone Web Server
44 Summary(pl):    Server HTTP obs³uguj±cy ASP.NET
45 Group:          Networking/Daemons
46 Requires:       %{name} = %{epoch}:%{version}-%{release}
47 Requires:       mono-csharp >= 1.0
48
49 %description -n dotnet-xsp
50 Provides a minimalistic web server which hosts the ASP.NET runtime and 
51 can be used to test and debug web applications that use the System.Web
52 facilities in  Mono.
53
54 %prep
55 %setup -q -n %{mod_name}-%{version}
56 %patch0 -p1
57
58 %build
59 rm -rf $RPM_BUILD_ROOT
60 # Build Apache Module
61 %{__libtoolize}
62 %{__aclocal}
63 %{__autoconf}
64 %{__automake}
65
66 %configure \
67         --with-apxs=%{apxs} \
68         --with-apr-config=%{_bindir}/apr-config \
69         --with-apu-config=%{_bindir}/apu-config
70         
71 %{__make} \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 # Build Mono DLL
75 %{__make} -C src -f makedll.mak
76
77 %install
78 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_pkglibdir},%{_mandir}/man8}
79
80 install src/.libs/libmod_mono.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_mono.so
81 install src/ModMono.dll $RPM_BUILD_ROOT%{_libdir}
82 install man/mod_mono.8 $RPM_BUILD_ROOT%{_mandir}/man8
83
84 cat > $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/70_mod_mono.conf <<EOF
85 LoadModule mono_module modules/mod_mono.so
86 MonoApplications "/asp_net:%{_httpdir}/asp_net"
87 Alias /asp_net "%{_httpdir}/asp_net"
88 <Location /asp_net>
89     SetHandler mono
90 </Location>
91 EOF
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %files
97 %defattr(644,root,root,755)
98 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*
99 %doc ChangeLog INSTALL NEWS README
100 %attr(755,root,root) %{_pkglibdir}/mod_mono.so
101 %attr(755,root,root) %{_libdir}/ModMono.dll
102 %{_mandir}/man8/*
This page took 0.048999 seconds and 3 git commands to generate.