]> git.pld-linux.org Git - packages/apache-mod_gnutls.git/blob - apache-mod_gnutls.spec
eabdc9de17a1b445066d8db7448d9387b1848f63
[packages/apache-mod_gnutls.git] / apache-mod_gnutls.spec
1 # TODO
2 # - with apr_memcache: http://www.outoforder.cc/projects/libs/apr_memcache
3 # - make tries to make cert using /dev/random (slow! and perhaps unneccessary)
4 %define         mod_name        gnutls
5 %define         apxs            /usr/sbin/apxs
6 Summary:        SSL v3, TLS 1.0 and TLS 1.1 encryption for Apache HTTPD
7 Summary(pl):    Szyfrowanie SSL v3, TLS 1.0 i TLS 1.1 dla serwera HTTP Apache
8 Name:           apache-mod_%{mod_name}
9 Version:        0.2.0
10 Release:        0.1
11 License:        Apache Group License
12 Group:          Networking/Daemons
13 Source0:        http://www.outoforder.cc/downloads/mod_gnutls/mod_gnutls-%{version}.tar.bz2
14 # Source0-md5:  80ab766a7b9cfbb730e789032ff26d68
15 URL:            http://www.outoforder.cc/projects/apache/mod_gnutls/
16 BuildRequires:  apache-devel >= 2.0.42
17 BuildRequires:  gnutls-devel >= 1.2.0
18 Requires:       apache(modules-api) = %apache_modules_api
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 mod_gnutls uses the GnuTLS library to provide SSL v3, TLS 1.0 and TLS
23 1.1 encryption for Apache HTTPD. It is similar to mod_ssl in purpose,
24 but does not use OpenSSL.
25
26 Features:
27 - Support for SSL v3, TLS 1.0 and TLS 1.1.
28 - Support for Server Name Indication
29 - Distributed SSL Session Cache via Memcached
30 - Local SSL Session Cache using DBM
31
32 %description -l pl
33 mod_gnutls u¿ywa biblioteki GnuTLS do obs³ugi szyfrowania SSL v3, TLS
34 1.0 i TLS 1.1 dla serwera HTTP Apache. Pod wzglêdem przeznaczenia jest
35 podobny do mod_ssl, ale nie u¿ywa biblioteki OpenSSL.
36
37 Mo¿liwo¶ci:
38 - obs³uga SSL v3, TLS 1.0 i TLS 1.1
39 - obs³uga identyfikacji nazwy serwera (Server Name Indication)
40 - rozproszona pamiêæ podrêczna sesji SSL poprzez Memcached
41 - lokalna pamiêæ podrêczna sesji SSL korzystaj±ca z DBM
42
43 %prep
44 %setup -q -n mod_%{mod_name}-%{version}
45
46 %build
47 %configure \
48         --with-apxs=%{apxs} \
49         --with-libgnutls=%{_prefix} \
50         --without-apr-memcache
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
This page took 0.132366 seconds and 2 git commands to generate.