]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
80c415559e41e0d06dd96f6e430592fb1d06a9e6
[packages/amarok.git] / amarok.spec
1 #
2 # TODO
3 # - use mysql-embedded in the future and try not to link with static mysqld lib
4 # - amarok now requires his own database which is not automaticly created
5 # Add spec:
6 # libmygpo-qt (1.0.5 or higher)  <http://wiki.gpodder.org/wiki/Libmygpo-qt>
7 #     Enable gpodder.net service
8 # -- Performing Test COMPLEX_TAGLIB_FILENAME - Failed
9 # /home/users/builder/rpm/BUILD/amarok-2.5.0/build/CMakeFiles/CMakeTmp/src.cxx:5:38: error: cannot convert 'const wchar_t*' to 'TagLib::FileName {aka const char*}' in initialization
10 %define         state   stable
11 %define         qtver   4.7.1
12 %define         kdever  4.5.5
13
14 Summary:        A KDE audio player
15 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
16 Name:           amarok
17 Version:        2.8.0
18 Release:        3
19 License:        GPL v2+ and LGPL v2.1+
20 Group:          X11/Applications/Multimedia
21 Source0:        ftp://ftp.kde.org/pub/kde/%{state}/amarok/%{version}/src/%{name}-%{version}.tar.bz2
22 # Source0-md5:  53cfcb4819668b10e13b061478c7b32a
23 Patch0:         %{name}-upnp-dep.patch
24 URL:            http://amarok.kde.org/
25 BuildRequires:  QtNetwork-devel >= %{qtver}
26 BuildRequires:  QtSql-devel >= %{qtver}
27 BuildRequires:  automoc4 >= 0.9.88
28 BuildRequires:  cmake >= 2.8.0
29 BuildRequires:  curl-devel
30 BuildRequires:  ffmpeg-devel >= 0.7.1
31 BuildRequires:  gettext-devel
32 BuildRequires:  glib2-devel
33 BuildRequires:  herqq-devel
34 BuildRequires:  kde4-kdelibs-devel >= %{kdever}
35 BuildRequires:  libaio-devel
36 BuildRequires:  libgpod-devel >= 0.7.0
37 BuildRequires:  liblastfm-devel
38 BuildRequires:  libmtp-devel >= 1.0.4
39 BuildRequires:  libofa-devel
40 BuildRequires:  libwrap-devel
41 BuildRequires:  loudmouth-devel
42 BuildRequires:  mysql-devel >= 5.1.31-3
43 BuildRequires:  pcre-devel
44 BuildRequires:  pkgconfig
45 BuildRequires:  qca-devel
46 BuildRequires:  qjson-devel >= 0.5
47 BuildRequires:  qt4-build >= %{qtver}
48 BuildRequires:  qt4-qmake >= %{qtver}
49 BuildRequires:  qtscriptbindings
50 BuildRequires:  rpmbuild(macros) >= 1.600
51 BuildRequires:  soprano-devel
52 BuildRequires:  strigi-devel >= 0.7.0
53 BuildRequires:  taglib-devel >= 1.7
54 BuildRequires:  taglib-extras-devel >= 1.0.0
55 BuildRequires:  xorg-lib-libXpm-devel
56 Requires(post,postun):  /sbin/ldconfig
57 Requires:       kde4-phonon
58 Requires:       qtscriptbindings
59 Suggests:       libvisual-plugin-actor-JESS
60 Suggests:       libvisual-plugin-actor-bumpscope
61 Suggests:       libvisual-plugin-actor-corona
62 Suggests:       libvisual-plugin-actor-flower
63 Suggests:       libvisual-plugin-actor-gdkpixbuf
64 Suggests:       libvisual-plugin-actor-gforce
65 Suggests:       libvisual-plugin-actor-gstreamer
66 Suggests:       libvisual-plugin-actor-infinite
67 Suggests:       libvisual-plugin-actor-jakdaw
68 Suggests:       libvisual-plugin-actor-lv_analyzer
69 Suggests:       libvisual-plugin-actor-lv_gltest
70 Suggests:       libvisual-plugin-actor-lv_scope
71 Suggests:       libvisual-plugin-actor-madspin
72 Suggests:       libvisual-plugin-actor-nastyfft
73 Suggests:       libvisual-plugin-actor-oinksie
74 Suggests:       libvisual-plugin-input-alsa
75 Suggests:       libvisual-plugin-input-jack
76 Suggests:       libvisual-plugin-input-mplayer
77 Suggests:       libvisual-plugin-morph-alphablend
78 Suggests:       libvisual-plugin-morph-flash
79 Suggests:       libvisual-plugin-morph-slide
80 Suggests:       libvisual-plugin-morph-tentacle
81 Obsoletes:      amarok-arts
82 Obsoletes:      amarok-xmms
83 # It should require mysql-embeded
84 Requires:       mysql >= 5.1.31-3
85 Conflicts:      mysql < 5.1.31-3
86 # sr@Latn vs. sr@latin
87 Conflicts:      glibc-misc < 6:2.7
88 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
90 %description
91 A KDE audio player.
92
93 %description -l pl.UTF-8
94 Odtwarzacz audio dla KDE.
95
96 %package scripts
97 Summary:        amaroK scripts
98 Summary(pl.UTF-8):      Skrypty amaroKa
99 Group:          X11/Applications/Multimedia
100 Requires:       %{name} = %{version}-%{release}
101 Requires:       kde4-kdebase-kdialog
102
103 %description scripts
104 amaroK scripts allow you extend amaroK functionality.
105
106 You can learn more about scripts in amaroK from here:
107 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
108
109 %description scripts -l pl.UTF-8
110 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
111
112 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
113 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
114
115 %prep
116 %setup -q
117 %patch0 -p1
118
119 %build
120 install -d build
121 cd build
122 %cmake \
123         -DKDE4_BUILD_TESTS=OFF \
124         -DWITH_MYSQL_EMBEDDED=OFF \
125         ../
126
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131
132 %{__make} -C build install \
133         DESTDIR=$RPM_BUILD_ROOT \
134         kde_htmldir=%{_kdedocdir} \
135         kde_libs_htmldir=%{_kdedocdir}
136
137 # remove unsupported locale
138 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/sr@ijekavian*
139
140 # remove .so symlinks so that noone gets the stupid idea to package them
141 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libamarok*.so
142
143 %find_lang %{name} --all-name --with-kde
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post           -p /sbin/ldconfig
149 %postun         -p /sbin/ldconfig
150
151 %files -f %{name}.lang
152 %defattr(644,root,root,755)
153 %doc AUTHORS ChangeLog README
154 %attr(755,root,root) %{_bindir}/amarok
155 %attr(755,root,root) %{_bindir}/amarokpkg
156 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
157 %attr(755,root,root) %{_bindir}/amarokmp3tunesharmonydaemon
158 %attr(755,root,root) %{_bindir}/amarok_afttagger
159 %attr(755,root,root) %{_bindir}/amzdownloader
160 %attr(755,root,root) %ghost %{_libdir}/libamarok-sqlcollection.so.?
161 %attr(755,root,root) %{_libdir}/libamarok-sqlcollection.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libamarokocsclient.so.?
163 %attr(755,root,root) %{_libdir}/libamarokocsclient.so.*.*.*
164 %attr(755,root,root) %ghost %{_libdir}/libamaroklib.so.?
165 %attr(755,root,root) %{_libdir}/libamaroklib.so.*.*.*
166 %attr(755,root,root) %ghost %{_libdir}/libamarokpud.so.?
167 %attr(755,root,root) %{_libdir}/libamarokpud.so.*.*.*
168 %attr(755,root,root) %ghost %{_libdir}/libamarokcore.so.?
169 %attr(755,root,root) %{_libdir}/libamarokcore.so.*.*.*
170 %attr(755,root,root) %ghost %{_libdir}/libamarokshared.so.?
171 %attr(755,root,root) %{_libdir}/libamarokshared.so.*.*.*
172 %attr(755,root,root) %ghost %{_libdir}/libamarok-transcoding.so.?
173 %attr(755,root,root) %{_libdir}/libamarok-transcoding.so.*.*.*
174 #%%attr(755,root,root) %ghost %{_libdir}/libamarokqtjson.so.?
175 #%%attr(755,root,root) %{_libdir}/libamarokqtjson.so.*.*.*
176 %attr(755,root,root) %{_libdir}/libampache_account_login.so
177 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-audiocdcollection.so
178 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-daapcollection.so
179 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-ipodcollection.so
180 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mtpcollection.so
181 #%%attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlecollection.so
182 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-mysqlservercollection.so
183 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-umscollection.so
184 %attr(755,root,root) %{_libdir}/kde4/amarok_containment_vertical.so
185 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_analyzer.so
186 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_albums.so
187 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_currenttrack.so
188 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_info.so
189 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_labels.so
190 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_lyrics.so
191 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_photos.so
192 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_wikipedia.so
193 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_current.so
194 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_info.so
195 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_labels.so
196 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_lyrics.so
197 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_photos.so
198 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_wikipedia.so
199 %attr(755,root,root) %{_libdir}/kde4/amarok_service_ampache.so
200 %attr(755,root,root) %{_libdir}/kde4/amarok_service_jamendo.so
201 %attr(755,root,root) %{_libdir}/kde4/amarok_service_magnatunestore.so
202 %attr(755,root,root) %{_libdir}/kde4/amarok_service_mp3tunes.so
203 %attr(755,root,root) %{_libdir}/kde4/amarok_service_opmldirectory.so
204 %attr(755,root,root) %{_libdir}/kde4/amarok_service_amazonstore.so
205 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_ampache.so
206 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_magnatunestore.so
207 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_mp3tunes.so
208 %attr(755,root,root) %{_libdir}/kde4/kcm_amarok_service_amazonstore.so
209 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-playdarcollection.so
210 %attr(755,root,root) %{_libdir}/kde4/amarok_collection-upnpcollection.so
211 %attr(755,root,root) %{_libdir}/kde4/amarok_context_applet_tabs.so
212 %attr(755,root,root) %{_libdir}/kde4/amarok_data_engine_tabs.so
213 %dir %{_datadir}/apps/amarok
214 %dir %{_datadir}/apps/amarok/scripts
215 %{_datadir}/apps/amarok/data
216 %{_datadir}/apps/amarok/icons
217 %{_datadir}/apps/amarok/images
218 %{_datadir}/apps/amarok/amarok.notifyrc
219 %{_datadir}/apps/desktoptheme
220 %{_datadir}/apps/solid/actions/amarok-play-audiocd.desktop
221 %{_datadir}/config.kcfg/amarokconfig.kcfg
222 %{_datadir}/config/amarok.knsrc
223 %{_datadir}/config/amarokapplets.knsrc
224 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.player.xml
225 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.root.xml
226 %{_datadir}/dbus-1/interfaces/org.freedesktop.MediaPlayer.tracklist.xml
227 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Collection.xml
228 %{_datadir}/dbus-1/interfaces/org.kde.amarok.App.xml
229 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris1Extensions.Player.xml
230 %{_datadir}/dbus-1/interfaces/org.kde.amarok.Mpris2Extensions.Player.xml
231 %{_desktopdir}/kde4/amarok_containers.desktop
232 %{_desktopdir}/kde4/amzdownloader.desktop
233 %{_datadir}/kde4/services/amarok.protocol
234 %{_datadir}/kde4/services/amarokitpc.protocol
235 %{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
236 %{_datadir}/kde4/services/amarok_collection-audiocdcollection.desktop
237 %{_datadir}/kde4/services/amarok_collection-daapcollection.desktop
238 %{_datadir}/kde4/services/amarok_collection-ipodcollection.desktop
239 %{_datadir}/kde4/services/amarok_collection-mtpcollection.desktop
240 #%%{_datadir}/kde4/services/amarok_collection-mysqlecollection.desktop
241 %{_datadir}/kde4/services/amarok_collection-mysqlservercollection.desktop
242 %{_datadir}/kde4/services/amarok_collection-umscollection.desktop
243 %{_datadir}/kde4/services/amarok-containment-vertical.desktop
244 %{_datadir}/kde4/services/amarok-context-applet-analyzer.desktop
245 %{_datadir}/kde4/services/amarok-context-applet-albums.desktop
246 %{_datadir}/kde4/services/amarok-context-applet-currenttrack.desktop
247 %{_datadir}/kde4/services/amarok-context-applet-info.desktop
248 %{_datadir}/kde4/services/amarok-context-applet-labels.desktop
249 %{_datadir}/kde4/services/amarok-context-applet-lyrics.desktop
250 %{_datadir}/kde4/services/amarok-context-applet-photos.desktop
251 %{_datadir}/kde4/services/amarok-context-applet-wikipedia.desktop
252 %{_datadir}/kde4/services/amarok-data-engine-current.desktop
253 %{_datadir}/kde4/services/amarok-data-engine-info.desktop
254 %{_datadir}/kde4/services/amarok-data-engine-labels.desktop
255 %{_datadir}/kde4/services/amarok-data-engine-lyrics.desktop
256 %{_datadir}/kde4/services/amarok-data-engine-photos.desktop
257 %{_datadir}/kde4/services/amarok-data-engine-wikipedia.desktop
258 %{_datadir}/kde4/services/amarok_service_amazonstore.desktop
259 %{_datadir}/kde4/services/amarok_service_amazonstore_config.desktop
260 %{_datadir}/kde4/services/amarok_service_ampache.desktop
261 %{_datadir}/kde4/services/amarok_service_ampache_config.desktop
262 %{_datadir}/kde4/services/amarok_service_jamendo.desktop
263 %{_datadir}/kde4/services/amarok_service_magnatunestore.desktop
264 %{_datadir}/kde4/services/amarok_service_magnatunestore_config.desktop
265 %{_datadir}/kde4/services/amarok_service_mp3tunes.desktop
266 %{_datadir}/kde4/services/amarok_service_mp3tunes_config.desktop
267 %{_datadir}/kde4/services/amarok_service_opmldirectory.desktop
268 %{_datadir}/kde4/services/amarok-context-applet-tabs.desktop
269 %{_datadir}/kde4/services/amarok-data-engine-tabs.desktop
270 %{_datadir}/kde4/services/amarok_collection-playdarcollection.desktop
271 %{_datadir}/kde4/services/amarok_collection-upnpcollection.desktop
272 %{_datadir}/kde4/servicetypes/amarok_codecinstall.desktop
273 %{_datadir}/kde4/servicetypes/amarok_context_applet.desktop
274 %{_datadir}/kde4/servicetypes/amarok_data_engine.desktop
275 %{_datadir}/kde4/servicetypes/amarok_plugin.desktop
276 %{_desktopdir}/kde4/amarok.desktop
277 %{_iconsdir}/*/*/apps/amarok.*
278 %{_datadir}/config/amarok_homerc
279 %attr(755,root,root) %{_datadir}/apps/kconf_update/*.pl
280 %{_datadir}/apps/kconf_update/amarok.upd
281 %{_datadir}/mime/packages/amzdownloader.xml
282
283 %files scripts
284 %defattr(644,root,root,755)
285 %dir %{_datadir}/apps/amarok/scripts/radio_station_service
286 %{_datadir}/apps/amarok/scripts/radio_station_service/main.js
287 %{_datadir}/apps/amarok/scripts/radio_station_service/script.spec
288 %dir %{_datadir}/apps/amarok/scripts/script_console
289 %{_datadir}/apps/amarok/scripts/script_console/main.js
290 %{_datadir}/apps/amarok/scripts/script_console/script.spec
291 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki
292 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/main.js
293 %{_datadir}/apps/amarok/scripts/lyrics_lyricwiki/script.spec
294 %dir %{_datadir}/apps/amarok/scripts/librivox_service
295 %{_datadir}/apps/amarok/scripts/librivox_service/main.js
296 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxLogo.png
297 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxScalableEmblem.svgz
298 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxService.html
299 %{_datadir}/apps/amarok/scripts/librivox_service/script.spec
300 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxEmblem.png
301 %{_datadir}/apps/amarok/scripts/librivox_service/LibrivoxIcon.png
302 %{_datadir}/apps/amarok/scripts/librivox_service/audio_book128.png
303 %dir %{_datadir}/apps/amarok/scripts/free_music_charts_service
304 %{_datadir}/apps/amarok/scripts/free_music_charts_service/FMCEmblem.png
305 %{_datadir}/apps/amarok/scripts/free_music_charts_service/FMCIcon.png
306 %{_datadir}/apps/amarok/scripts/free_music_charts_service/FMCShow.png
307 %{_datadir}/apps/amarok/scripts/free_music_charts_service/main.js
308 %{_datadir}/apps/amarok/scripts/free_music_charts_service/script.spec
This page took 0.064277 seconds and 2 git commands to generate.