]> git.pld-linux.org Git - packages/aircrack-ng.git/blob - aircrack-ng.spec
ext_scripts bcond needs more work
[packages/aircrack-ng.git] / aircrack-ng.spec
1 #
2 # TODO:
3 # - PLD it more
4 # - Find more deps
5 # - optflags
6 # - cflags
7 # - sbin/bin - change to bin?
8 # - package airdrop-ng and airgraph-ng
9 #
10 # Conditional build:
11 %bcond_without  sqlite                  # build without sqlite support
12 %bcond_without  pcre                    # build without pcre support
13 %bcond_without  experimental
14 %bcond_with     ext_scripts             # build with extra scripts (NFY)
15 #
16 Summary:        Reliable 802.11 (wireless) sniffer and WEP/WPA-PSK key cracker
17 Summary(pl.UTF-8):      Pewny sniffer 802.11 (sieci bezprzewodowe) i łamacz kluczy WEP/WPA-PSK
18 Name:           aircrack-ng
19 Version:        1.2
20 %define subver  rc2
21 %define rel     0.1
22 Release:        %{subver}.%{rel}
23 License:        GPL
24 Group:          Applications/Networking
25 Source0:        http://download.aircrack-ng.org/%{name}-%{version}-%{subver}.tar.gz
26 # Source0-md5:  ebe9d537f06f4d6956213af09c4476da
27 URL:            http://www.aircrack-ng.org/
28 Patch0:         install.patch
29 BuildRequires:  libnl-devel
30 BuildRequires:  openssl-devel
31 BuildRequires:  pkgconfig
32 %{?with_pcre:BuildRequires:     pcre-devel}
33 %{?with_sqlite:BuildRequires:   sqlite3-devel}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 aircrack-ng is a set of tools for auditing wireless networks. It's an
38 enhanced/reborn version of aircrack. It consists of airodump-ng (an
39 802.11 packet capture program), aireplay-ng (an 802.11 packet
40 injection program), aircrack (static WEP and WPA-PSK cracking),
41 airdecap-ng (decrypts WEP/WPA capture files), and some tools to handle
42 capture files (merge, convert, etc.).
43
44 %description -l pl.UTF-8
45 aircrack-ng jest zestawem narzędzi do audytów sieci bezprzewodowych.
46 Jest to ulepszona/odnowiona wersja aircracka. Składa sie z programów
47 airodump-ng (do przechwytywania pakietów 802.11), aireplay-ng (do
48 wstrzykiwania pakietów 802.11), aircrack (do statycznego łamania WEP i
49 WPA-PSK), airdecap-ng (do odszyfrowywania przechwyconych plików
50 WEP/WPA) i paru narzędzi do obsługi plików przechwytów (merge,
51 convert, etc.).
52
53 %prep
54 %setup -q -n %{name}-%{version}-%{subver}
55 %patch0 -p1
56
57 sed -i -e 's#-Werror -O3#$(PLDFLAGS)#g' common.mak
58
59 %build
60 %{__make} -j1 \
61         %{?with_experimental: experimental=true} \
62         %{?with_ext_scripts: ext_scripts=true} \
63         %{?with_pcre: pcre=true} \
64         %{?with_sqlite: sqlite=true} \
65         CC="%{__cc}" \
66         PLDFLAGS="%{rpmcppflags} %{rpmcflags}"
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
71
72 %{__make} install \
73         %{?with_experimental: experimental=true} \
74         %{?with_ext_scripts: ext_scripts=true} \
75         %{?with_pcre: pcre=true} \
76         %{?with_sqlite: sqlite=true} \
77         prefix=%{_prefix} \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc AUTHORS ChangeLog README test patches
86 %attr(755,root,root) %{_bindir}/aircrack-ng
87 %attr(755,root,root) %{_bindir}/airdecap-ng
88 %attr(755,root,root) %{_bindir}/airdecloak-ng
89 %{?with_sqlite:%attr(755,root,root) %{_bindir}/airolib-ng}
90 %attr(755,root,root) %{_bindir}/ivstools
91 %attr(755,root,root) %{_bindir}/kstats
92 %attr(755,root,root) %{_bindir}/makeivs-ng
93 %attr(755,root,root) %{_bindir}/packetforge-ng
94 %attr(755,root,root) %{_bindir}/wpaclean
95 %attr(755,root,root) %{_sbindir}/airbase-ng
96 %attr(755,root,root) %{_sbindir}/aireplay-ng
97 %attr(755,root,root) %{_sbindir}/airmon-ng
98 %attr(755,root,root) %{_sbindir}/airodump-ng
99 %attr(755,root,root) %{_sbindir}/airodump-ng-oui-update
100 %attr(755,root,root) %{_sbindir}/airserv-ng
101 %attr(755,root,root) %{_sbindir}/airtun-ng
102 %{_mandir}/man1/aircrack-ng.1*
103 %{_mandir}/man1/airdecap-ng.1*
104 %{_mandir}/man1/airdecloak-ng.1*
105 %{?with_sqlite:%{_mandir}/man1/airolib-ng.1*}
106 %{_mandir}/man1/besside-ng-crawler.1*
107 %{_mandir}/man1/ivstools.1*
108 %{_mandir}/man1/kstats.1*
109 %{_mandir}/man1/makeivs-ng.1*
110 %{_mandir}/man1/packetforge-ng.1*
111 %{_mandir}/man1/wpaclean.1*
112 %{_mandir}/man8/airbase-ng.8*
113 %{_mandir}/man8/aireplay-ng.8*
114 %{_mandir}/man8/airmon-ng.8*
115 %{_mandir}/man8/airodump-ng-oui-update.8*
116 %{_mandir}/man8/airodump-ng.8*
117 %{_mandir}/man8/airserv-ng.8*
118 %{_mandir}/man8/airtun-ng.8*
119 %{_mandir}/man8/besside-ng.8*
120
121 %if %{with experimental}
122 %attr(755,root,root) %{_bindir}/buddy-ng
123 %attr(755,root,root) %{_sbindir}/besside-ng
124 %attr(755,root,root) %{_sbindir}/easside-ng
125 %attr(755,root,root) %{_sbindir}/tkiptun-ng
126 %attr(755,root,root) %{_sbindir}/wesside-ng
127 %{_mandir}/man1/buddy-ng.1*
128 %{_mandir}/man8/easside-ng.8*
129 %{_mandir}/man8/tkiptun-ng.8*
130 %{_mandir}/man8/wesside-ng.8*
131 %endif
This page took 0.083732 seconds and 3 git commands to generate.