]> git.pld-linux.org Git - packages/acl.git/blob - acl.spec
9647a72c2f1d1a65af1b0bf7f0175c5a6a99db1e
[packages/acl.git] / acl.spec
1 Summary:        Command and library for manipulating access control lists
2 Summary(pl):    Polecenie i biblioteka do manipulacji listami kontroli dostêpu (ACL)
3 Name:           acl
4 Version:        2.2.27
5 Release:        1
6 License:        GPL v2 (chacl utility), LGPL v2+ (library and the rest)
7 Group:          Applications/System
8 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
9 # Source0-md5:  973c63cea7402345d834ceb0049a1f86
10 Patch0:         %{name}-miscfix.patch
11 URL:            http://oss.sgi.com/projects/xfs/
12 BuildRequires:  attr-devel >= 2.4.16-3
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  gettext-devel
16 BuildRequires:  sed >= 4.0
17 Requires:       attr >= 2.4.15
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _bindir         /bin
21 %define         _libdir         /%{_lib}
22 %define         _libexecdir     /usr/%{_lib}
23
24 %description
25 A command (chacl) and a library (libacl) to manipulate POSIX access
26 control lists under Linux.
27
28 %description -l pl
29 Polecenie (chacl) i biblioteka (libacl) do manipulowania zgodnymi z
30 POSIX listami kontroli dostêpu (ACL) pod Linuksem.
31
32 %package devel
33 Summary:        Header files for acl library
34 Summary(pl):    Pliki nag³ówkowe biblioteki acl
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       attr-devel >= 2.4.16-3
38
39 %description devel
40 Header files to develop software which manipulate access control
41 lists.
42
43 %description devel -l pl
44 Pliki nag³ówkowe potrzebne do rozwoju oprogramowania manipuluj±cego
45 listami kontroli dostêpu (ACL).
46
47 %package static
48 Summary:        Static acl library
49 Summary(pl):    Statyczna biblioteka acl
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static acl library.
55
56 %description static -l pl
57 Statyczna biblioteka acl.
58
59 %prep
60 %setup -q
61 %patch0 -p1
62
63 %build
64 rm -f aclocal.m4
65 %{__aclocal} -I m4
66 %{__autoconf}
67 %configure \
68         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
69         OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
70
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT{%{_includedir}/acl,%{_mandir}/man3}
76
77 DIST_ROOT=$RPM_BUILD_ROOT
78 DIST_INSTALL=`pwd`/install.manifest
79 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
80 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
81 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
82
83 %{__make} install \
84         DIST_MANIFEST=$DIST_INSTALL
85 %{__make} install-dev \
86         DIST_MANIFEST=$DIST_INSTALL_DEV
87 %{__make} install-lib \
88         DIST_MANIFEST=$DIST_INSTALL_LIB
89
90 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{acl_copy_int,acl_set_fd,acl_set_file}.3
91 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{acl_to_short_text,acl_to_text}.3
92 echo ".so acl_copy_ext.3"       > $RPM_BUILD_ROOT%{_mandir}/man3/acl_copy_int.3
93 echo ".so acl_get_fd.3" > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_fd.3
94 echo ".so acl_get_file.3"       > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_file.3
95 echo ".so acl_from_text.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_short_text.3
96 echo ".so acl_from_text.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_text.3
97
98 rm -f $RPM_BUILD_ROOT%{_libexecdir}/lib*.so
99 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir} ; echo libacl.so.*.*.*) \
100         $RPM_BUILD_ROOT%{_libexecdir}/libacl.so
101 %{__sed} -i "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
102         $RPM_BUILD_ROOT%{_libexecdir}/libacl.la
103
104 %find_lang %{name}
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files -f %{name}.lang
113 %defattr(644,root,root,755)
114 %doc README doc/{CHANGES,TODO}
115 %attr(755,root,root) %{_bindir}/*
116 %attr(755,root,root) %{_libdir}/lib*.so.*.*
117 %{_mandir}/man[15]/*
118
119 %files devel
120 %defattr(644,root,root,755)
121 %doc doc/{extensions.txt,libacl.txt}
122 %attr(755,root,root) %{_libexecdir}/lib*.so
123 %{_libexecdir}/lib*.la
124 %{_includedir}/acl
125 %{_includedir}/sys/*
126 %{_mandir}/man[23]/*
127
128 %files static
129 %defattr(644,root,root,755)
130 %{_libexecdir}/lib*.a
This page took 0.057524 seconds and 2 git commands to generate.