]> git.pld-linux.org Git - packages/Zope3-psycopgda.git/commitdiff
- new spec: PostgreSQL database adapter for Zope 3
authorJacek Konieczny <jajcus@pld-linux.org>
Tue, 30 Aug 2005 12:30:55 +0000 (12:30 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    Zope3-psycopgda.spec -> 1.1

Zope3-psycopgda.spec [new file with mode: 0644]

diff --git a/Zope3-psycopgda.spec b/Zope3-psycopgda.spec
new file mode 100644 (file)
index 0000000..ac9f895
--- /dev/null
@@ -0,0 +1,73 @@
+%define                zope_subname    psycopgda
+Summary:       PostgreSQL database adapter for Zope 3
+Summary(pl):   Adapter bazy danych PostgreSQL dla Zope 3
+Name:          Zope3-%{zope_subname}
+Version:       1.0.0
+Release:       1
+License:       ZPL 2.1
+Group:         Development/Tools
+Source0:       http://www.zope.org/Products/Zope3-Packages/%{zope_subname}/%{version}/%{zope_subname}-%{version}.tgz
+# Source0-md5: da55609e4612f2c6d431b00dfa57c369
+Patch0:                %{name}-python_2_4_1.patch
+URL:           http://www.zope.org/Products/Zope3-Packages/psycopgda/view
+BuildRequires: python
+%pyrequires_eq python-modules
+Requires:      Zope3
+Requires(post,postun): /usr/sbin/installzope3package
+Requires(post,postun): rc-scripts
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%define                zope_libdir /usr/lib/zope3
+%define                zope_pyscriptdir /usr/share/zope3/lib/python
+
+%description
+PostgreSQL database adapter for Zope 3.
+
+%description -l pl
+Adapter bazy danych PostgreSQL dla Zope 3
+
+%prep
+%setup -q -n %{zope_subname}-%{version}
+%patch0 -p1
+
+%build
+./configure
+%{__make}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/zope3
+
+python install.py install \
+       --root="$RPM_BUILD_ROOT" \
+       --install-purelib="%{zope_pyscriptdir}"
+
+mv $RPM_BUILD_ROOT%{_prefix}/zopeskel $RPM_BUILD_ROOT%{_sysconfdir}/zope3
+
+%py_comp $RPM_BUILD_ROOT%{zope_pyscriptdir}
+%py_ocomp $RPM_BUILD_ROOT%{zope_pyscriptdir}
+
+find $RPM_BUILD_ROOT -type f -name "*.py" | xargs rm
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+/usr/sbin/installzope3package %{zope_subname}
+if [ -f /var/lock/subsys/zope3 ]; then
+       /etc/rc.d/init.d/zope3 restart >&2
+fi
+
+%postun
+if [ "$1" = "0" ]; then
+       /usr/sbin/installzope3package -d %{zope_subname}
+       if [ -f /var/lock/subsys/zope3 ]; then
+               /etc/rc.d/init.d/zope3 restart >&2
+       fi
+fi
+
+%files
+%defattr(644,root,root,755)
+%{zope_pyscriptdir}
+%{_sysconfdir}/zope3/zopeskel%{_sysconfdir}/package-includes/*.zcml
This page took 0.062044 seconds and 4 git commands to generate.