]> git.pld-linux.org Git - packages/ZendFramework.git/commitdiff
disable pear generated deps, use the manually defined ones
authorElan Ruusamäe <glen@delfi.ee>
Tue, 28 Apr 2015 20:23:55 +0000 (23:23 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 28 Apr 2015 20:23:55 +0000 (23:23 +0300)
ZendFramework.spec

index e11d9703898adb3e828de11241358481acfab48b..bc836fc11975293ac43b1e5c25ca80e15f31a6b7 100644 (file)
@@ -1,5 +1,5 @@
-# TODO
-# - drop pear autogenerated deps and fill deps based on official doc:
+# NOTE
+# - dependencies are filled according to official doc:
 #   http://framework.zend.com/manual/1.12/en/requirements.introduction.html
 #
 # Conditional build:
@@ -9,7 +9,6 @@
 # - check Zend/Pdf/FileParser/Image/Jpeg.php and Zend/Pdf/FileParser/Image/Tiff.php
 #   presence in Zend/Pdf/Image.php after update [not implemented in 1.10.2)
 %define                php_min_version 5.2.11
-%include       /usr/lib/rpm/macros.php
 Summary:       Zend Framework
 Summary(pl.UTF-8):     Szkielet Zend
 Name:          ZendFramework
@@ -26,7 +25,6 @@ Patch0:               %{name}-additional-locales.patch
 Patch1:                %{name}-deps.patch
 URL:           http://framework.zend.com/manual/1.12/en/manual.html
 BuildRequires: /usr/bin/php
-BuildRequires: rpm-php-pearprov >= 4.4.2-11
 BuildRequires: rpmbuild(macros) >= 1.654
 BuildRequires: sed >= 4.0
 Requires:      php(core) >= %{php_min_version}
@@ -36,20 +34,11 @@ Obsoletes:  ZendFramework-doc
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# bad depsolver
-%define                _noautopear     pear(../application/bootstrap.php)
-
-# bad code
-%define                _bad_deps_1_10 Zend/Pdf/FileParser/Image/Jpeg.php Zend/Pdf/FileParser/Image/Tiff.php
-%define                _bad_deps_1_10_2 Zend/Serializer/Excception.php Zend/Services/DeveloperGarden/Response/Exception.php
-%define                _bad_deps_1_12_1 Zend/Service/Rackspace/Exception.php Zend/Service/Rackspace/Files.php Exception/InvalidArgumentException.php Zend/Loader/Exception/../Exception.php Zend/Service/Console/Command.php Zend/Service/Console/Exception.php Zend/Service/Log/Exception.php Zend/Service/Log/Formatter/Interface.php Zend/Service/Log/Writer/Abstract.php Zend/Service/Management/Exception.php
-%define                _noautoreq_pear %{?_bad_deps_1_10} %{?_bad_deps_1_10_2} %{?_bad_deps_1_12_1}
-
 # exclude optional php dependencies
 %define                _noautophp      php-oci8 php-bitset
 
 # put it together for rpmbuild
-%define                _noautoreq      %{?_noautophp} %{?_noautopear} %{?_noautodeps}
+%define                _noautoreq      %{?_noautophp}
 
 %description
 Zend Framework is a high quality and open source framework for
@@ -1723,8 +1712,7 @@ lint_php
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{php_pear_dir}/bin}
-install -d $RPM_BUILD_ROOT%{_bindir}
+install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{_bindir},%{php_pear_dir}/bin}
 cp -a demos/Zend/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 # library should be in include_path if used, so we use already defined %{php_pear_dir}
This page took 0.061349 seconds and 4 git commands to generate.