]> git.pld-linux.org Git - packages/ZendFramework.git/commitdiff
- up to 1.12.4
authorElan Ruusamäe <glen@delfi.ee>
Mon, 19 May 2014 19:40:14 +0000 (22:40 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 19 May 2014 19:40:14 +0000 (22:40 +0300)
- new packages: Zend_EventManager, Zend_Mobile_Push, Zend_Service_Rackspace, Zend_Service_SqlAzure
- packages dropped: Zend_InfoCard, Zend_Service_Nirvanix

ZendFramework-additional-locales.patch
ZendFramework-find-lang.sh [changed mode: 0644->0755]
ZendFramework.spec

index 36b8e41cc613957291c6b2fff37e71f981aa97e3..440db66a817b25ec6619bfd91b8791fa2cdbd76d 100644 (file)
@@ -1,12 +1,39 @@
---- ZendFramework-1.7.2/library/Zend/Locale.php~       2009-01-07 18:56:02.000000000 +0200
-+++ ZendFramework-1.7.2/library/Zend/Locale.php        2009-01-07 18:56:05.377026299 +0200
-@@ -111,7 +111,8 @@
-         'wal_ET'=> true, 'wal'   => true, 'wo_SN' => true, 'wo'    => true, 'xh_ZA' => true,
-         'xh'    => true, 'yo_NG' => true, 'yo'    => true, 'zh_CN' => true, 'zh_HK' => true,
-         'zh_MO' => true, 'zh_SG' => true, 'zh_TW' => true, 'zh'    => true, 'zu_ZA' => true,
--        'zu'    => true
-+        'zu'    => true, 'en_EE' => true, 'en_LV' => true, 'en_LT' => true, 'en_UA' => true,
-+        'ru_EE' => true, 'ru_LV' => true, 'ru_LT' => true,
-     );
-     /**
+--- ZendFramework-1.12.4/library/Zend/Locale.php~      2014-05-19 13:01:33.000000000 +0300
++++ ZendFramework-1.12.4/library/Zend/Locale.php       2014-05-19 13:13:40.339899571 +0300
+@@ -162,6 +162,7 @@
+         'en_CA'   => true,
+         'en_CM'   => true,
+         'en_DM'   => true,
++        'en_EE'   => true,
+         'en_FJ'   => true,
+         'en_FM'   => true,
+         'en_GB'   => true,
+@@ -185,6 +186,8 @@
+         'en_LC'   => true,
+         'en_LR'   => true,
+         'en_LS'   => true,
++        'en_LT'   => true,
++        'en_LV'   => true,
+         'en_MG'   => true,
+         'en_MH'   => true,
+         'en_MP'   => true,
+@@ -209,6 +212,7 @@
+         'en_TO'   => true,
+         'en_TT'   => true,
+         'en_TZ'   => true,
++        'en_UA'   => true,
+         'en_UG'   => true,
+         'en_UM'   => true,
+         'en_US'   => true,
+@@ -522,8 +526,11 @@
+         'rof_TZ'  => true,
+         'rof'     => true,
+         'ru_BY'   => true,
++        'ru_EE'   => true,
+         'ru_KG'   => true,
+         'ru_KZ'   => true,
++        'ru_LT'   => true,
++        'ru_LV'   => true,
+         'ru_MD'   => true,
+         'ru_RU'   => true,
+         'ru_UA'   => true,
old mode 100644 (file)
new mode 100755 (executable)
index 05a03d0..ce503d1
@@ -1,28 +1,43 @@
 #!/bin/sh
+
 dir=$RPM_BUILD_ROOT/usr/share/pear/Zend/Locale/Data
 langfile=${1:-ZendFramework.lang}
 
 > $langfile
 find $dir -type f -name '*.xml' | while read file; do
        case "${file##*/}" in
-       supplementalData.xml|telephoneCodeData.xml|plurals.xml|characters.xml|root.xml|likelySubtags.xml|postalCodeData.xml|metazoneInfo.xml|numberingSystems.xml)
+       characters.xml|\
+       coverageLevels.xml|\
+       dayPeriods.xml|\
+       enderList.xml|\
+       languageInfo.xml|\
+       likelySubtags.xml|\
+       metaZones.xml|\
+       metazoneInfo.xml|\
+       numberingSystems.xml|\
+       ordinals.xml|\
+       plurals.xml|\
+       postalCodeData.xml|\
+       root.xml|\
+       supplementalData.xml|\
+       supplementalMetadata.xml|\
+       telephoneCodeData.xml|\
+       -boo-\
+       )
                # skip - no lang tag for this one
                continue
                ;;
        esac
 
+       echo >&2 "Inspect $file"
        language=$(sed -ne 's/<language type="\(.*\)"\/>/\1/p' $file | xargs)
        script=$(sed -ne 's/<script type="\(.*\)"\/>/\1/p' $file | xargs)
        territory=$(sed -ne 's/<territory type="\(.*\)"\/>/\1/p' $file | xargs)
-
-       #<language type="sr"/>
-       #<script type="Latn"/>
-       #<territory type="BA"/>
-       # sr_Latn_BA.xml -> sr_BA@Latn
-
-       # TODO: <variant type="SAAHO"/>
+       echo >&2 "${file%*/} language=$language; script=$script; territory=$territory"
 
        lang=$language${territory:+_$territory}${script:+@$script}
        file=${file#$RPM_BUILD_ROOT}
-       echo "%lang($lang) ${file#$RPM_BUILD_ROOT}" >> $langfile
+       if [ -n "$lang" ]; then
+               echo "%lang($lang) ${file#$RPM_BUILD_ROOT}" >> $langfile
+       fi
 done
index 1a26e986528287e3a6a0d7f75edec121fcb53f03..85305d293aaa39111429d69cd91b355ddddf3d6b 100644 (file)
@@ -5,18 +5,19 @@
 # TODO
 # - check Zend/Pdf/FileParser/Image/Jpeg.php and Zend/Pdf/FileParser/Image/Tiff.php
 #   presence in Zend/Pdf/Image.php after update [not implemented in 1.10.2)
+%define                php_min_version 5.2.4
 %include       /usr/lib/rpm/macros.php
 Summary:       Zend Framework
 Summary(pl.UTF-8):     Szkielet Zend
 Name:          ZendFramework
-Version:       1.12.1
-Release:       2
+Version:       1.12.4
+Release:       1
 License:       New BSD License
 Group:         Development/Languages/PHP
 Source0:       http://framework.zend.com/releases/%{name}-%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: ec978ad8890b65661e8e33ca99a3b3f4
+# Source0-md5: 4b21fe3cf729edb822347a10f99aa1b4
 Source1:       http://framework.zend.com/releases/%{name}-%{version}/%{name}-%{version}-manual-en.tar.gz
-# Source1-md5: 8ee82279a241a814b8f362bb8e9344af
+# Source1-md5: 865d52ef096db1d92cc310059372ad44
 Source2:       %{name}-find-lang.sh
 Patch0:                %{name}-additional-locales.patch
 Patch1:                %{name}-deps.patch
@@ -25,7 +26,7 @@ BuildRequires:        /usr/bin/php
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
 BuildRequires: rpmbuild(macros) >= 1.654
 BuildRequires: sed >= 4.0
-Requires:      php(core) >= 5.2.4
+Requires:      php(core) >= %{php_min_version}
 Requires:      php-pear
 Requires:      rpm-whiteout >= 1.32
 Obsoletes:     ZendFramework-doc
@@ -405,6 +406,18 @@ Zend_Exception is a base exception class. All exceptions thrown by
 Zend Framework classes should throw an exception that derives from the
 base class Zend_Exception.
 
+%package Zend_EventManager
+Summary:       Zend_EventManager
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.event-manager.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_EventManager
+Zend_EventManager is a component designed for the following use cases:
+- Implementing simple subject/observer patterns.
+- Implementing Aspect-Oriented designs.
+- Implementing event-driven architectures.
+
 %package Zend_Feed
 Summary:       Zend_Feed
 Group:         Development/Languages/PHP
@@ -702,6 +715,18 @@ Requires:  php(iconv)
 %description Zend_Mime
 Zend_Mime is a support class for handling multipart MIME messages.
 
+%package Zend_Mobile_Push
+Summary:       Zend_Mobile_Push
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.mobile.push.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Mobile_Push
+Zend_Mobile_Push provides the ability for sending push notifications
+to the vendor specific notification servers. Currently this list
+includes APNS (iTouch/iPad/iPhone), GCM (Google Android) and MPNS
+(Windows Phone).
+
 %package Zend_Navigation
 Summary:       Zend_Navigation - manage trees of pointers to web page
 Group:         Development/Languages/PHP
@@ -1097,6 +1122,16 @@ register for an account (https://www.nirvanix.com/signUpSingle.aspx).
 After registering, you will receive a Username, Password, and
 Application Key. All three are required to use Zend_Service_Nirvanix.
 
+%package Zend_Service_Rackspace
+Summary:       Zend_Service_Rackspace
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.service.rackspace.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Service_Rackspace
+The Zend_Service_Rackspace is a class that provides a simple API to
+manage the Rackspace services Cloud Files and Cloud Servers.
+
 %package Zend_Service_ReCaptcha
 Summary:       Zend_Service_ReCaptcha
 Group:         Development/Languages/PHP
@@ -1166,6 +1201,13 @@ create an account on the slideshare.net servers in order to receive an
 API key, username, password and shared secret value -- all of which
 are needed in order to use the Zend_Service_SlideShare component.
 
+%package Zend_Service_SqlAzure
+Summary:       Zend_Service_
+Group:         Development/Languages/PHP
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Service_SqlAzure
+
 %package Zend_Service_StrikeIron
 Summary:       Zend_Service_StrikeIron
 Group:         Development/Languages/PHP
@@ -1530,7 +1572,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc LICENSE.txt README.txt
+%doc LICENSE.txt README.md
 %dir %{php_pear_dir}/Zend
 
 %files Zend_Acl
@@ -1583,6 +1625,7 @@ rm -rf $RPM_BUILD_ROOT
 
 # subpackages?
 %{php_pear_dir}/Zend/Cloud/DocumentService
+%{php_pear_dir}/Zend/Cloud/Infrastructure
 %{php_pear_dir}/Zend/Cloud/QueueService
 %{php_pear_dir}/Zend/Cloud/StorageService
 
@@ -1642,6 +1685,13 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Exception.php
 
+%files Zend_EventManager
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/EventManager
+
+# package here, as for now only EventManager uses Stdlib classes
+%{php_pear_dir}/Zend/Stdlib
+
 %files Zend_Feed
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Feed
@@ -1675,10 +1725,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Http
 
+%if 0
 %files Zend_InfoCard
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/InfoCard
 %{php_pear_dir}/Zend/InfoCard.php
+%endif
 
 %files Zend_Json
 %defattr(644,root,root,755)
@@ -1713,13 +1765,21 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{php_pear_dir}/Zend/Locale/Data
 %{php_pear_dir}/Zend/Locale/Data/Translation.php
 %{php_pear_dir}/Zend/Locale/Data/characters.xml
+%{php_pear_dir}/Zend/Locale/Data/coverageLevels.xml
+%{php_pear_dir}/Zend/Locale/Data/dayPeriods.xml
+%{php_pear_dir}/Zend/Locale/Data/genderList.xml
+%{php_pear_dir}/Zend/Locale/Data/languageInfo.xml
 %{php_pear_dir}/Zend/Locale/Data/likelySubtags.xml
-%{php_pear_dir}/Zend/Locale/Data/metazoneInfo.xml
+%{php_pear_dir}/Zend/Locale/Data/metaZones.xml
 %{php_pear_dir}/Zend/Locale/Data/numberingSystems.xml
+%{php_pear_dir}/Zend/Locale/Data/ordinals.xml
+%{php_pear_dir}/Zend/Locale/Data/plurals.xml
 %{php_pear_dir}/Zend/Locale/Data/postalCodeData.xml
 %{php_pear_dir}/Zend/Locale/Data/root.xml
 %{php_pear_dir}/Zend/Locale/Data/supplementalData.xml
+%{php_pear_dir}/Zend/Locale/Data/supplementalMetadata.xml
 %{php_pear_dir}/Zend/Locale/Data/telephoneCodeData.xml
+%{php_pear_dir}/Zend/Locale/Data/windowsZones.xml
 
 %files Zend_Log
 %defattr(644,root,root,755)
@@ -1750,6 +1810,12 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Mime
 %{php_pear_dir}/Zend/Mime.php
 
+%files Zend_Mobile_Push
+%defattr(644,root,root,755)
+%dir %{php_pear_dir}/Zend/Mobile
+%{php_pear_dir}/Zend/Mobile/Exception.php
+%{php_pear_dir}/Zend/Mobile/Push
+
 %files Zend_Navigation
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Navigation
@@ -1865,10 +1931,16 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Service/LiveDocx
 %{php_pear_dir}/Zend/Service/LiveDocx.php
 
+%if 0
 %files Zend_Service_Nirvanix
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Service/Nirvanix
 %{php_pear_dir}/Zend/Service/Nirvanix.php
+%endif
+
+%files Zend_Service_Rackspace
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Service/Rackspace
 
 %files Zend_Service_ReCaptcha
 %defattr(644,root,root,755)
@@ -1891,6 +1963,10 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Service/SlideShare
 %{php_pear_dir}/Zend/Service/SlideShare.php
 
+%files Zend_Service_SqlAzure
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Service/SqlAzure
+
 %files Zend_Service_StrikeIron
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Service/StrikeIron
@@ -1979,6 +2055,10 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/XmlRpc
 
+%dir %{php_pear_dir}/Zend/Xml
+%{php_pear_dir}/Zend/Xml/Exception.php
+%{php_pear_dir}/Zend/Xml/Security.php
+
 %files demos
 %defattr(644,root,root,755)
 %{_examplesdir}/%{name}-%{version}
This page took 0.049544 seconds and 4 git commands to generate.