]> git.pld-linux.org Git - packages/Thunar.git/blob - Thunar.spec
- up to 0.4.0rc1
[packages/Thunar.git] / Thunar.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         _pre            rc1
6 %define         xfce_version    4.3.99.1
7 Summary:        Xfce file manager
8 Summary(pl):    Zarz±dca plików Xfce
9 Name:           Thunar
10 Version:        0.4.0
11 Release:        0.%{_pre}.1
12 License:        GPL v2 / LGPL v2
13 Group:          X11/Applications
14 Source0:        http://www.xfce.org/archive/xfce-%{xfce_version}/src/%{name}-%{version}%{_pre}.tar.bz2
15 # Source0-md5:  b07ae97a69964112e0af84ba2f63585d
16 URL:            http://thunar.xfce.org/
17 BuildRequires:  GConf2-devel >= 2.14.0
18 BuildRequires:  dbus-glib-devel >= 0.62
19 # XXX: gamin (>= 0.1.0) is preferred over fam
20 BuildRequires:  fam-devel
21 BuildRequires:  gettext-devel
22 BuildRequires:  glib2-devel >= 1:2.12.0
23 BuildRequires:  gtk+2-devel >= 2:2.10.0
24 BuildRequires:  hal-devel >= 0.5.7
25 BuildRequires:  intltool
26 BuildRequires:  libexif-devel >= 0.6.13
27 BuildRequires:  libexo-devel >= 0.3.1.10
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  libpng-devel >= 1.2.12
30 BuildRequires:  libxfce4util-devel >= %{xfce_version}
31 BuildRequires:  pcre-devel >= 6.0
32 BuildRequires:  perl-base
33 BuildRequires:  pkgconfig
34 BuildRequires:  rpmbuild(macros) >= 1.311
35 BuildRequires:  startup-notification-devel >= 0.8
36 Requires:       %{name}-libs = %{version}-%{release}
37 Requires(post,postun):  gtk+2 >= 2:2.10.0
38 Requires:       hal >= 0.5.7
39 Requires(post,postun):  hicolor-icon-theme
40 Requires:       libexo >= 0.3.1.10
41 Requires:       shared-mime-info >= 0.15
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Thunar is a modern file manager, aiming to be easy-to-use and fast.
46
47 %description -l pl
48 Thunar jest nowoczesnym zarz±dc± plików, nakierowanym na ³atwo¶æ i
49 szybko¶æ u¿ycia.
50
51 %package libs
52 Summary:        Thunar libraries
53 Summary(pl):    Biblioteki Thunar
54 Group:          Libraries
55
56 %description libs
57 Thunar libraries.
58
59 %description libs -l pl
60 Biblioteki Thunar.
61
62 %package devel
63 Summary:        Header files for Thunar libraries
64 Summary(pl):    Pliki nag³ówkowe bibliotek Thunar
65 Group:          Development/Libraries
66 Requires:       %{name}-libs = %{version}-%{release}
67 Requires:       GConf2-devel >= 2.14.0
68 Requires:       dbus-glib-devel >= 0.62
69 Requires:       fam-devel
70 Requires:       hal-devel >= 0.5.7
71 Requires:       libjpeg-devel
72
73 %description devel
74 This is the package containing the header files for Thunar libraries.
75
76 %description devel -l pl
77 Ten pakiet zawiera pliki nag³ówkowe biblioteki Thunar.
78
79 %package static
80 Summary:        Static Thunar library
81 Summary(pl):    Statyczna biblioteka libraries
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 Static Thunar libraries.
87
88 %description static -l pl
89 Statyczna biblioteki Thunar
90
91 %prep
92 %setup -qn %{name}-%{version}%{_pre}
93
94 %build
95 %configure \
96         %{?with_static_libs:--enable-static}
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 rm -f $RPM_BUILD_ROOT%{_libdir}/thunarx-1/*.{a,la}
107
108 %find_lang %{name} --all-name
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post
114 %update_icon_cache hicolor
115
116 %postun
117 %update_icon_cache hicolor
118
119 %post   libs -p /sbin/ldconfig
120 %postun libs -p /sbin/ldconfig
121
122 %files -f %{name}.lang
123 %defattr(644,root,root,755)
124 %doc AUTHORS ChangeLog NEWS README THANKS TODO
125 %attr(755,root,root) %{_bindir}/*
126 %dir %{_sysconfdir}/xdg/Thunar
127 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/Thunar/*.xml
128 %attr(755,root,root) %{_libdir}/ThunarBulkRename
129 %attr(755,root,root) %{_libdir}/ThunarHelp
130 %attr(755,root,root) %{_libdir}/thunar-vfs-*
131 %attr(755,root,root) %{_libdir}/thunar-sendto-email
132 %dir %{_libdir}/thunarx-1
133 %attr(755,root,root) %{_libdir}/thunarx-1/*.so
134 %attr(755,root,root) %{_libdir}/xfce4/panel-plugins/thunar-tpa
135
136 %{_datadir}/Thunar
137 %{_datadir}/xfce4/panel-plugins/*.desktop
138 %{_datadir}/dbus-1/services/*.service
139 %{_desktopdir}/*.desktop
140 %{_iconsdir}/hicolor/*/*/*
141 %{_pixmapsdir}/Thunar
142 %{_mandir}/man1/Thunar*
143
144 %dir %{_docdir}/Thunar
145 # move it to proper place
146 %{_docdir}/Thunar/README*
147
148 %dir %{_docdir}/Thunar/html
149 %{_docdir}/Thunar/*.txt
150 %{_docdir}/Thunar/html/C
151 %{_docdir}/Thunar/html/*.css
152 %lang(es) %{_docdir}/Thunar/html/es
153 %lang(fr) %{_docdir}/Thunar/html/fr
154 %lang(ja) %{_docdir}/Thunar/html/ja
155 %lang(ru) %{_docdir}/Thunar/html/ru
156 %lang(zh_TW) %{_docdir}/Thunar/html/zh_TW
157
158 %files libs
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/lib*.so.*.*
161
162 %files devel
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/lib*.so
165 %{_libdir}/lib*.la
166 %{_includedir}/thunar*
167 %{_pkgconfigdir}/*.pc
168
169 %if %{with static_libs}
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/*.a
173 %endif
This page took 0.953956 seconds and 4 git commands to generate.