]> git.pld-linux.org Git - packages/Thunar.git/blob - Thunar.spec
bef0b9c32e51d5bd45bec51d3d8c69d8d8f17887
[packages/Thunar.git] / Thunar.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 %define         xfce_version    4.10.0
6 Summary:        Xfce file manager
7 Summary(pl.UTF-8):      Zarządca plików Xfce
8 Name:           Thunar
9 Version:        1.6.2
10 Release:        2
11 License:        GPL v2 / LGPL v2
12 Group:          X11/Applications
13 Source0:        http://archive.xfce.org/src/xfce/thunar/1.6/%{name}-%{version}.tar.bz2
14 # Source0-md5:  a446103ab90855cc8ba484dfeedb82d8
15 Patch0:         %{name}-desktop.patch
16 URL:            http://thunar.xfce.org/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake >= 1:1.8
19 BuildRequires:  dbus-glib-devel >= 0.62
20 BuildRequires:  docbook-dtd412-xml
21 BuildRequires:  exo-devel >= 0.10.0
22 BuildRequires:  gettext-devel
23 BuildRequires:  glib2-devel >= 1:2.18.0
24 BuildRequires:  gtk+2-devel >= 2:2.14.0
25 BuildRequires:  gtk-doc >= 1.7
26 BuildRequires:  intltool
27 BuildRequires:  libexif-devel >= 0.6.0
28 BuildRequires:  libnotify-devel >= 0.4.0
29 BuildRequires:  libtool
30 BuildRequires:  libxfce4ui-devel >= %{xfce_version}
31 BuildRequires:  libxfce4util-devel >= %{xfce_version}
32 BuildRequires:  pcre-devel >= 6.0
33 BuildRequires:  perl-base
34 BuildRequires:  pkgconfig
35 BuildRequires:  rpmbuild(macros) >= 1.601
36 BuildRequires:  startup-notification-devel >= 0.8
37 BuildRequires:  udev-glib-devel >= 145
38 BuildRequires:  xfce4-dev-tools >= %{xfce_version}
39 BuildRequires:  xfce4-panel-devel >= %{xfce_version}
40 Requires(post,postun):  desktop-file-utils
41 Requires:       %{name}-libs = %{version}-%{release}
42 Requires:       exo >= 0.8.0
43 Requires:       gtk-update-icon-cache
44 Requires:       hicolor-icon-theme
45 Requires:       shared-mime-info >= 0.15
46 Requires:       xfconf >= %{xfce_version}
47 Suggests:       tumbler
48 Obsoletes:      Thunar-thumbnailers
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Thunar is a modern file manager, aiming to be easy-to-use and fast.
53
54 %description -l pl.UTF-8
55 Thunar jest nowoczesnym zarządcą plików, nakierowanym na łatwość i
56 szybkość użycia.
57
58 %package apidocs
59 Summary:        Thunar API documentation
60 Summary(pl.UTF-8):      Dokumentacja API Thunar
61 Group:          Documentation
62 Requires:       gtk-doc-common
63 Obsoletes:      thunar-vfs-apidocs
64
65 %description apidocs
66 Thunar API documentation.
67
68 %description apidocs -l pl.UTF-8
69 Dokumentacja API Thunar.
70
71 %package libs
72 Summary:        Thunar libraries
73 Summary(pl.UTF-8):      Biblioteki Thunar
74 Group:          X11/Libraries
75 Obsoletes:      thunar-vfs
76
77 %description libs
78 Thunar libraries.
79
80 %description libs -l pl.UTF-8
81 Biblioteki Thunar.
82
83 %package devel
84 Summary:        Header files for Thunar libraries
85 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Thunar
86 Group:          X11/Development/Libraries
87 Requires:       %{name}-libs = %{version}-%{release}
88 Requires:       exo-devel >= 0.6.0
89 Requires:       gtk+2-devel >= 2:2.14.0
90 Obsoletes:      thunar-vfs-devel
91
92 %description devel
93 This is the package containing the header files for Thunar libraries.
94
95 %description devel -l pl.UTF-8
96 Ten pakiet zawiera pliki nagłówkowe biblioteki Thunar.
97
98 %package static
99 Summary:        Static Thunar libraries
100 Summary(pl.UTF-8):      Statyczne biblioteki Thunar
101 Group:          X11/Development/Libraries
102 Requires:       %{name}-devel = %{version}-%{release}
103 Obsoletes:      thunar-vfs-static
104
105 %description static
106 Static Thunar libraries.
107
108 %description static -l pl.UTF-8
109 Statyczne biblioteki Thunar.
110
111 %prep
112 %setup -q
113 %patch0 -p1
114
115 %{__sed} -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac
116
117 %build
118 %{__gtkdocize}
119 %{__intltoolize}
120 %{__libtoolize}
121 %{__aclocal}
122 %{__automake}
123 %{__autoheader}
124 %{__autoconf}
125 %configure \
126         --enable-dbus \
127         --enable-exif \
128         --enable-gtk-doc \
129         --enable-pcre \
130         --enable-startup-notification \
131         --with-html-dir=%{_gtkdocdir} \
132         %{?with_static_libs:--enable-static} \
133         --disable-silent-rules
134
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 %{__rm} $RPM_BUILD_ROOT%{_libdir}/thunarx-2/*.{a,la}
143 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xfce4/panel/plugins/*.{a,la}
144 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
145
146 # duplicate of ur
147 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/ur_PK
148
149 %find_lang %{name} --all-name
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post
155 %update_desktop_database_post
156 %update_icon_cache hicolor
157
158 %postun
159 %update_desktop_database_postun
160 %update_icon_cache hicolor
161
162 %post   libs -p /sbin/ldconfig
163 %postun libs -p /sbin/ldconfig
164
165 %files -f %{name}.lang
166 %defattr(644,root,root,755)
167 %doc AUTHORS ChangeLog NEWS README THANKS TODO
168 %attr(755,root,root) %{_bindir}/*
169 %dir %{_sysconfdir}/xdg/Thunar
170 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/Thunar/*.xml
171 %dir %{_libdir}/Thunar
172 %attr(755,root,root) %{_libdir}/Thunar/ThunarBulkRename
173 %attr(755,root,root) %{_libdir}/Thunar/thunar-sendto-email
174 %dir %{_libdir}/thunarx-2
175 %attr(755,root,root) %{_libdir}/thunarx-2/*.so
176 %attr(755,root,root) %{_libdir}/xfce4/panel/plugins/libthunar-tpa.so
177
178 %{_datadir}/Thunar/sendto/*.desktop
179 %{_datadir}/xfce4/panel-plugins/*.desktop
180 %{_datadir}/dbus-1/services/*.service
181 %{_desktopdir}/*.desktop
182 %{_iconsdir}/hicolor/*/*/*
183 %{_pixmapsdir}/Thunar
184 %{_mandir}/man1/Thunar*
185
186 %dir %{_docdir}/Thunar
187 # move it to proper place
188 %{_docdir}/Thunar/README*
189
190 %files apidocs
191 %defattr(644,root,root,755)
192 %{_gtkdocdir}/thunarx
193
194 %files libs
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_libdir}/libthunarx-2.so.*.*.*
197 %attr(755,root,root) %ghost %{_libdir}/libthunarx-2.so.0
198
199 %files devel
200 %defattr(644,root,root,755)
201 %attr(755,root,root) %{_libdir}/libthunarx-2.so
202 %{_includedir}/thunarx-2
203 %{_pkgconfigdir}/thunarx-2.pc
204
205 %if %{with static_libs}
206 %files static
207 %defattr(644,root,root,755)
208 %{_libdir}/libthunarx-2.a
209 %endif
This page took 0.036135 seconds and 2 git commands to generate.