]> git.pld-linux.org Git - packages/Thunar.git/blob - Thunar.spec
- updated to 0.9.0
[packages/Thunar.git] / Thunar.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 %define         xfce_version    4.4.2
6 Summary:        Xfce file manager
7 Summary(pl.UTF-8):      Zarządca plików Xfce
8 Name:           Thunar
9 Version:        0.9.0
10 Release:        1
11 License:        GPL v2 / LGPL v2
12 Group:          X11/Applications
13 Source0:        http://www.xfce.org/archive/xfce-%{xfce_version}/src/%{name}-%{version}.tar.bz2
14 # Source0-md5:  0fc5008858661c0abd0399acbe30ef28
15 Patch0:         %{name}-desktop.patch
16 Patch1:         %{name}-locale-names.patch
17 Patch2:         %{name}-missing-audio-cds-for-volman.patch
18 URL:            http://thunar.xfce.org/
19 BuildRequires:  GConf2-devel >= 2.16.0
20 BuildRequires:  dbus-glib-devel >= 0.62
21 # XXX: gamin (>= 0.1.0) is preferred over fam
22 BuildRequires:  fam-devel
23 BuildRequires:  gettext-devel
24 BuildRequires:  glib2-devel >= 1:2.12.4
25 BuildRequires:  gtk+2-devel >= 2:2.10.6
26 BuildRequires:  gtk-doc >= 1.7
27 BuildRequires:  hal-devel >= 0.5.7
28 BuildRequires:  intltool
29 BuildRequires:  libexif-devel >= 0.6.13
30 BuildRequires:  libexo-devel >= 0.3.4
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  libpng-devel >= 1.2.12
33 BuildRequires:  libxfce4util-devel >= %{xfce_version}
34 BuildRequires:  pcre-devel >= 6.0
35 BuildRequires:  perl-base
36 BuildRequires:  pkgconfig
37 BuildRequires:  rpmbuild(macros) >= 1.311
38 BuildRequires:  startup-notification-devel >= 0.8
39 BuildRequires:  xfce4-panel-devel >= %{xfce_version}
40 Requires(post,postun):  desktop-file-utils
41 Requires(post,postun):  gtk+2
42 Requires(post,postun):  hicolor-icon-theme
43 Requires:       %{name}-libs = %{version}-%{release}
44 Requires:       hal >= 0.5.7
45 Requires:       libexo >= 0.3.4
46 Requires:       shared-mime-info >= 0.15
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Thunar is a modern file manager, aiming to be easy-to-use and fast.
51
52 %description -l pl.UTF-8
53 Thunar jest nowoczesnym zarządcą plików, nakierowanym na łatwość i
54 szybkość użycia.
55
56 %package apidocs
57 Summary:        Thunar API documentation
58 Summary(pl.UTF-8):      Dokumentacja API Thunar
59 Group:          Documentation
60 Requires:       gtk-doc-common
61
62 %description apidocs
63 Thunar API documentation.
64
65 %description apidocs -l pl.UTF-8
66 Dokumentacja API Thunar.
67
68 %package libs
69 Summary:        Thunar libraries
70 Summary(pl.UTF-8):      Biblioteki Thunar
71 Group:          Libraries
72
73 %description libs
74 Thunar libraries.
75
76 %description libs -l pl.UTF-8
77 Biblioteki Thunar.
78
79 %package devel
80 Summary:        Header files for Thunar libraries
81 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Thunar
82 Group:          Development/Libraries
83 Requires:       %{name}-libs = %{version}-%{release}
84 Requires:       GConf2-devel >= 2.16.0
85 Requires:       dbus-glib-devel >= 0.62
86 Requires:       fam-devel
87 Requires:       hal-devel >= 0.5.7
88 Requires:       libexo-devel >= 0.3.4
89 Requires:       libjpeg-devel
90
91 %description devel
92 This is the package containing the header files for Thunar libraries.
93
94 %description devel -l pl.UTF-8
95 Ten pakiet zawiera pliki nagłówkowe biblioteki Thunar.
96
97 %package static
98 Summary:        Static Thunar libraries
99 Summary(pl.UTF-8):      Statyczne biblioteki Thunar
100 Group:          Development/Libraries
101 Requires:       %{name}-devel = %{version}-%{release}
102
103 %description static
104 Static Thunar libraries.
105
106 %description static -l pl.UTF-8
107 Statyczne biblioteki Thunar.
108
109 %prep
110 %setup -q
111 %patch0 -p1
112 %patch1 -p1
113 %patch2 -p0
114
115 mv -f po/{pt_PT,pt}.po
116 mv -f po/{nb_NO,nb}.po
117
118 %build
119 %configure \
120         --enable-dbus \
121         --enable-exif \
122         --enable-gnome-thumbnailers \
123         --enable-gtk-doc \
124         --enable-pcre \
125         --enable-startup-notification \
126         --with-html-dir=%{_gtkdocdir} \
127         %{?with_static_libs:--enable-static}
128
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 rm -f $RPM_BUILD_ROOT%{_libdir}/thunarx-1/*.{a,la}
138
139 %find_lang %{name} --all-name
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post
145 %update_desktop_database_post
146 %update_icon_cache hicolor
147
148 %postun
149 %update_desktop_database_postun
150 %update_icon_cache hicolor
151
152 %post   libs -p /sbin/ldconfig
153 %postun libs -p /sbin/ldconfig
154
155 %files -f %{name}.lang
156 %defattr(644,root,root,755)
157 %doc AUTHORS ChangeLog NEWS README THANKS TODO
158 %attr(755,root,root) %{_bindir}/*
159 %dir %{_sysconfdir}/xdg/Thunar
160 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/Thunar/*.xml
161 %attr(755,root,root) %{_libdir}/ThunarBulkRename
162 %attr(755,root,root) %{_libdir}/ThunarHelp
163 %attr(755,root,root) %{_libdir}/thunar-vfs-*
164 %attr(755,root,root) %{_libdir}/thunar-sendto-email
165 %dir %{_libdir}/thunarx-1
166 %attr(755,root,root) %{_libdir}/thunarx-1/*.so
167 %attr(755,root,root) %{_libdir}/xfce4/panel-plugins/thunar-tpa
168
169 %{_datadir}/Thunar
170 %{_datadir}/xfce4/panel-plugins/*.desktop
171 %{_datadir}/dbus-1/services/*.service
172 %{_desktopdir}/*.desktop
173 %{_iconsdir}/hicolor/*/*/*
174 %{_pixmapsdir}/Thunar
175 %{_mandir}/man1/Thunar*
176
177 # FIXME: maybe it's common dir?
178 %dir %{_datadir}/thumbnailers
179 %{_datadir}/thumbnailers/*.desktop
180
181 %dir %{_docdir}/Thunar
182 # move it to proper place
183 %{_docdir}/Thunar/README*
184
185 %dir %{_docdir}/Thunar/html
186 %{_docdir}/Thunar/*.txt
187 %{_docdir}/Thunar/html/C
188 %{_docdir}/Thunar/html/*.css
189 %lang(es) %{_docdir}/Thunar/html/es
190 %lang(eu) %{_docdir}/Thunar/html/eu
191 %lang(fr) %{_docdir}/Thunar/html/fr
192 %lang(ja) %{_docdir}/Thunar/html/ja
193 %lang(nl) %{_docdir}/Thunar/html/nl
194 %lang(pl) %{_docdir}/Thunar/html/pl
195 %lang(ru) %{_docdir}/Thunar/html/ru
196 %lang(zh_TW) %{_docdir}/Thunar/html/zh_TW
197
198 %files apidocs
199 %defattr(644,root,root,755)
200 %{_gtkdocdir}/thunar*
201
202 %files libs
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
205
206 %files devel
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_libdir}/lib*.so
209 %{_libdir}/lib*.la
210 %{_includedir}/thunar*
211 %{_pkgconfigdir}/*.pc
212
213 %if %{with static_libs}
214 %files static
215 %defattr(644,root,root,755)
216 %{_libdir}/*.a
217 %endif
This page took 0.05982 seconds and 3 git commands to generate.