]> git.pld-linux.org Git - packages/SoundStudio.git/commitdiff
- updated to 1.0.5, updated URLs
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 31 Jul 2001 16:48:11 +0000 (16:48 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
TODO: change .wmconfig file to .desktop file

Changed files:
    SoundStudio.patch -> 1.2
    SoundStudio.spec -> 1.7

SoundStudio.patch
SoundStudio.spec

index a6b55330bf697aa9ade0a69f2eb97dc5550dd483..e5536d5623076ae422af09230c48de67c832d3ae 100644 (file)
@@ -1,18 +1,27 @@
---- SoundStudio-0.8.2/studio.orig      Tue May 19 15:54:17 1998
-+++ SoundStudio-0.8.2/studio   Tue May 19 15:55:17 1998
-@@ -17,13 +17,13 @@
- # Please set them as is applicable.
+--- SoundStudio/build.orig     Mon Nov 20 16:37:41 2000
++++ SoundStudio/build  Tue Jul 31 08:32:25 2001
+@@ -8,7 +8,7 @@
+ # Set your system-dependencies here!
  
- # I need the full path Where my files are;
--set MYFILES   .
-+set MYFILES /usr/lib/SoundStudio
+ # Which compiler would you like to invoke?
+-CC="gcc -O2"
++CC="gcc ${OPT}"
  
- # I need a directory to store my temporary files;
- set TEMP_DIR  /tmp
+ if [ $# = 0 -o $# -gt 1 ] ; then
+     printf "%s\n" "Usage: build (config|default|install|dfltinst|backup)"
+@@ -56,6 +56,7 @@
+            fi
+            sedCmd2="s:@TEMP_DIR@:$TEMP_DIR:"
  
- # Where do I find Sox?
--set SOX_DIR $MYFILES
-+set SOX_DIR /usr/bin
++           if [ -z "$SOX_DIR" ]; then
+            if SOX="`which sox`" ; then
+                SOX_DIR=`dirname $SOX`
+                if [ "$Ask" != "Don't" ] ; then
+@@ -94,6 +95,7 @@
+                    printf "\n"
+                fi
+            fi
++           fi
+            sedCmd3="s:@SOX_DIR@:$SOX_DIR:"
  
- ##################################
- # Please Leave the Rest to me.....
+            printf "%s\n" "*** Building script \"studio\""
index 8638be971622f5cd8ec3fc8eebc00e5a71ada579..d71993f4596b8f2976c8d0cb32562df670b5f5d4 100644 (file)
@@ -1,57 +1,76 @@
 Summary:       tk sound editor, with record, playback, and mixer facilities 
+Summary(pl):   Edytor d¼wiêku z mo¿liwo¶ci± nagrywania, odtwarzania i miksowania
 Name:          SoundStudio
-Version:       0.9.1
-Release:       2
+Version:       1.0.5
+Release:       1
 Group:         Applications/Sound
 Group(de):     Applikationen/Laut
 Group(pl):     Aplikacje/D¼wiêk
 License:       GPL
-Source0:       http://www.elec-eng.leeds.ac.uk/staff/een6njb/Software/Studio/%{name}-%{version}.tar.gz
-URL:           http://www.elec-eng.leeds.ac.uk/staff/een6njb/Software/Studio/screens.html
+Source0:       http://prdownloads.sourceforge.net/studio/%{name}-%{version}.tar.gz
 Source1:       %{name}.wmconfig
 Source2:       studio.xpm
 Patch0:                %{name}.patch
+URL:           http://studio.sourceforge.net/
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Requires:      tcl >= 7.4, tk >= 4.0, sox >= 11, /bin/more
 
 %description
 Sound Studio provides a graphical user interface for manipulating
-digitised sound. It allows you to record, play and edit sound files in
+digitized sound. It allows you to record, play and edit sound files in
 various formats, such as Microsoft's wav files, Sun's audio files
 (.au) and Creative Lab's .voc format. It also provides access to a
 sound card's built-in mixer to adjust recording levels and output
 volumes. Also Sound Studio provides you with information about the
 sample and allows conversion into other formats, sampling rates etc.
 
+%description -l pl
+Sound Studio daje graficzny interfejs do obrabiania cyfrowego d¼wiêku.
+Pozwala na nagrywanie, odtwarzanie i edycjê plików d¼wiêkowych
+w ró¿nych formatach: Microsoft .wav, Sun .au, Creative Labs .voc.
+Daje tak¿e dostêp do miksera karty d¼wiêkowej. Pozwala na konwersjê do
+innych formatów i czêstotliwo¶ci próbkowania.
+
 %prep
-%setup -q
-%patch0 -p1 -b .patch
+%setup -q -n SoundStudio
+%patch0 -p1
 
 %build
-./install
+MYFILES=%{_libdir}/%{name} SOX_DIR=/usr/bin OPT="%{rpmcflags}" ./build default
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-install -d ${RPM_BUILD_ROOT}%{_sysconfdir}/X11/wmconfig
-install -d ${RPM_BUILD_ROOT}%{_datadir}/icons/mini
-install -m755 -d ${RPM_BUILD_ROOT}%{_libdir}/${RPM_PACKAGE_NAME}
-install -m755 -d ${RPM_BUILD_ROOT}%{_bindir}
-install -m555 studio reset_dsp ${RPM_BUILD_ROOT}%{_bindir}
-install -m555 maxmin studio_mixer studio_tool ${RPM_BUILD_ROOT}%{_libdir}/${RPM_PACKAGE_NAME}
-install -m444 *.tk *.ico ${RPM_BUILD_ROOT}%{_libdir}/${RPM_PACKAGE_NAME}
-install -m444 help1.hlp matra.wav test.au woof.wav ${RPM_BUILD_ROOT}%{_libdir}/${RPM_PACKAGE_NAME}
-install $RPM_SOURCE_DIR/SoundStudio.wmconfig $RPM_BUILD_ROOT%{_sysconfdir}/X11/wmconfig/SoundStudio
-install $RPM_SOURCE_DIR/studio.xpm $RPM_BUILD_ROOT%{_datadir}/icons/mini/studio.xpm
+install -d $RPM_BUILD_ROOT{%{_pixmapsdir}/mini,%{_libdir}/%{name},%{_bindir}}
+install studio reset_dsp $RPM_BUILD_ROOT%{_bindir}
+install fader maxmin studio_mixer studio_tool $RPM_BUILD_ROOT%{_libdir}/%{name}
+install *.tk *.ico $RPM_BUILD_ROOT%{_libdir}/%{name}
+install help1.hlp v12.au StudioHelp $RPM_BUILD_ROOT%{_libdir}/%{name}
+install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/mini/studio.xpm
+
+# change it to .desktop
+#install -d ${RPM_BUILD_ROOT}%{_sysconfdir}/X11/wmconfig
+#install $RPM_SOURCE_DIR/SoundStudio.wmconfig $RPM_BUILD_ROOT%{_sysconfdir}/X11/wmconfig/SoundStudio
+
+gzip -9nf README
 
 %clean
-rm -fr ${RPM_BUILD_ROOT}
+rm -rf ${RPM_BUILD_ROOT}
 
 %files
 %defattr(644,root,root,755)
-%doc COPYING README StudioHelp studio-${RPM_PACKAGE_VERSION}.lsm  DOCS/*
+%doc README.gz
 %attr(755,root,root) %{_bindir}/studio
 %attr(755,root,root) %{_bindir}/reset_dsp
-%{_libdir}/SoundStudio
-%{_sysconfdir}/X11/wmconfig/SoundStudio
-%{_datadir}/icons/mini/studio.xpm
+%dir %{_libdir}/%{name}
+%attr(755,root,root) %{_libdir}/%{name}/fader
+%attr(755,root,root) %{_libdir}/%{name}/maxmin
+%attr(755,root,root) %{_libdir}/%{name}/studio_mixer
+%attr(755,root,root) %{_libdir}/%{name}/studio_tool
+%{_libdir}/%{name}/*.tk
+%{_libdir}/%{name}/*.ico
+%{_libdir}/%{name}/*.hlp
+%{_libdir}/%{name}/*.au
+%{_libdir}/%{name}/StudioHelp
+%{_pixmapsdir}/mini/studio.xpm
+#%{_sysconfdir}/X11/wmconfig/SoundStudio
This page took 0.04056 seconds and 4 git commands to generate.